Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Having a strange audio issue in FFX
#1
For some reason the dialog is shifting to this low quality tape-player like sound for random lines. One character will be speaker perfectly normal in high quality audio, then the person they were speaking to will respond and sound like he is talking through a tin can & string, then it'll go back to normal by the next line.

All my emulation settings are default except for 2 things: I set EE clamp to full to fix the backwards charters in battles bug, and turned on MTVU.

Would appreciate any help with this.

System Specs:
i5-3570k @ 4.2ghz
8GB ram @ 1600mhz
GTX 670 FTW
Intel DZ77GA-70K mobo
Reply

Sponsored links

#2
whats the fps you get when it goes weird?
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#3
(12-28-2012, 08:15 PM)refraction Wrote: whats the fps you get when it goes weird?

Had to play for a bit to get to make it to a scene with more talking. It didn't happen this time, but I did get an audio hiccup on one of the lines. The sound speech cut out twice for that one line then was normal for the rest of them. FPS was pegged at 60 the entire time according the fraps, and was varying from 59.xx to 60.xx by the counter on the title bar.

I'm also getting some random video choppyness that may or may not be related to the audio. When moving around the game will "stutter" for a second sometimes but the framerate will be at 60fps throughout, it's really weird.

I forgot to mention that I'm trying to run it at 3x scale with texture filtering on, which it did flawlessly before I had to set the EE clamp on full because of the glitches. In 1.0.0 it was impossible, but with the r5484 svn version it seems to be pulling it off except for these couple of quirks.

Is there anything else I could try to get it going smoother before backing off on the graphics?
Reply
#4
you could try pressing Page Up, which should activate FXAA. As an alternative if that doesnt work, i believe the hardware hacks section has an MSAA setting you can use. options you can use are generally 2, 4, 8, 16. Id recommend using 4
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#5
Sadly neither of those had any effects, however I turned off speedhacks and it seems to have fixed the issue with no noticeable slowdowns.
Reply
#6
Oh my is this frustrating. Turns out that actually didn't fix it at all. The problem is just intermittent enough that it seemed to. However I started playing the game again today and I'm still getting the issue.

I've tried turning clamping back to normal, lowering resolution, changing speed hack settings, removing texture filtering, and I've also tried all the different types of audio interpolation. Nothing is working. Sad

Is there anything else I can try changing that would have an effect on the audio playback?

Edit: also a quick question about a minor issue: if I set aeons sequences to "short" in game ifrits rock he throws during his overdrive is invisible. Have no problem ignoring this, just wondering if anyone has ran into it before.
Reply
#7
Ifrit's invisible rock is unrelated to your problem. I'm getting that, too

inb4 noob trying to help:
how about using a different audio plugin? it's been a while since I had to set the emulator up, but IIRC there were multiple ones to choose from. maybe the one you're using now clashes with your hardware in some weird way?
/noob trying to help
Reply
#8
Noob tips appreciated. Smile Gave the ZeroSPU plugin a try as it was the only other one included with PCSX2, and it was just crackling and poor quality galore so no dice there. Unless there are other plugins available for download (I wasn't able to find any) I think I might be out of luck.

I made a quick video sort-of demonstrating the problem, though you may need to be using headphones to hear it. It is way more pronounced during the long talking scenes, but it's hard to do multiple "takes" of those until it happens. Instead I just spammed Lulu for like 3 minutes. The 1st and 4th times I speak to her are the ones that are off the most, and the 2nd is how it should sound.

Video here: http://www.youtube.com/watch?v=McDz_sCXjEw
Reply
#9
if the audio is crackling, you probably need to increase the latency in SPU2-X
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#10
(01-03-2013, 12:48 AM)refraction Wrote: if the audio is crackling, you probably need to increase the latency in SPU2-X

The cracking was only from the ZeroSPU plugin when I tried it, SPU2-X is actually perfect except for dialog lines randomly being lower quality.

Someone else posted in the SPU2-X plugin thread about running into this problem in Kingdom Hearts so hopefully we will be able to get some light shed on what's actually causing it.
Reply




Users browsing this thread: 1 Guest(s)