Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Having about ~12 fps during gameplay
#1
So I don't know if it's game based or not, but I'm currently playing Star Ocean 3.

When I start up the game it goes fine until I come to the gameplay, where it drops down to about 12 fps.

My settings are following:

Graphics:
I've tried all 3 of the GSdx (SSSE3, SSSE2, SSSE41), all resulting in the same.
Using default settings, (alpha correction, texture filtering, and NLOOP hack with a gray check) as well as pixel shader 2.0 along with Direct3D9 (Hardware).


Sounds:
All default, nothing checked. And both on recommended settings.

CD/DVD:
Using Gigaherz plugin 0.7.0.

I have Direct X9 installed and my computer setup is following:

According to CPU config in PCSX2 it's 3046 MHZ, an Intel Core2Duo E7300.
I'm using Windows XP and I have 2 GB of RAM.
(EDIT: I forgot to add; I have an ATI Radeon 4850 graphic's card.)

Overall settings on PCSX2 is on default, as I'm pretty clueless, I also tried modifying some without any result, so went back to default and came here.

Any help is appreciated.

Thanks.
Reply

Sponsored links

#2
Did you check the fix for Tri Ace games in config->gamefixes?
Nappa: Vegeta! What does the scouter say about his power level?
Vegeta: It's...one thousand and six.
Nappa: Wh-...really?
Vegeta: Yeah! Beat him up Nappa!
Nappa: Yay!
Reply
#3
(12-01-2009, 02:26 AM)dr_thrax Wrote: Did you check the fix for Tri Ace games in config->gamefixes?



Yes. It's checked in. I couldn't start the game without it.
Reply
#4
Well, I don't have the game so my help is limited, but I would start by using pixel shader 3.0, make an ISO of the game and use Linuz Iso. If you haven't tried it already, you should try the latest beta (r1888) and see if it makes a difference.
Nappa: Vegeta! What does the scouter say about his power level?
Vegeta: It's...one thousand and six.
Nappa: Wh-...really?
Vegeta: Yeah! Beat him up Nappa!
Nappa: Yay!
Reply
#5
(12-01-2009, 02:43 AM)dr_thrax Wrote: Well, I don't have the game so my help is limited, but I would start by using pixel shader 3.0, make an ISO of the game and use Linuz Iso. If you haven't tried it already, you should try the latest beta (r1888) and see if it makes a difference.



If you're referring to latest beta as of in the emulator, I have it. I will convert it to an ISO and post the results tomorrow, as it's getting pretty late, as the convertion takes some time.

I'll come back with results tomorrow. If someone else has any comments, it'd be helpful.

Thanks so far as well and for the quick replies, Thrax.
Reply
#6
Yeah my bet is on ISO performance benefits here. Games that do a lot of active content streaming (and I think all of the Tri-ace games do this) get severe performance penalties reading from CD.
Jake Stine (Air) - Programmer - PCSX2 Dev Team
Reply
#7
Decided to try it out before I went to bed anyway. I still have huge fpsproblems, still around 12. Using an ISO created through both Linuz Iso converter and an ordinary ISO with Gigaherz.

I have a hard time seeing it being a problem with my computer, as it SHOULD be able to handle atleast more than 12 fps.

Any other suggestions?

And thanks so far as well.

(EDIT; Oh and. Maybe it's a part of what's the problem, the sound goes in slowmotion as well when the FPS drops, if that has any meaning.)
Reply
#8
So i waited this ALONG TIME, and there your Intel core 2 Duo performance? (dva podduva!) 12FPS? well you found trouble game? so after all my CPU very good, i find good emulated games and throw snapshots with 60FPS Wink

And please don't say me what weaker E3000 or E5200 intel CPU faster and smoother than my CPU, and in this topic i see E7300? which run game very badly, if you know russian language, read journal igromania, in this journal a lot info and expert testing hardware and always you may see rivalry test Intel vs AMD, please read for example: minimum 500 books or journals before write wrong info Smile
Reply
#9
Damarisu;

New idea: Grab the r1888 beta from our Betas section, as it sounds like you might not be using it (assumption based on the NLOOP hack, which has long since been removed from our beta). The 0.9.6 Official has serious slowdown issues on ATIs which are fixed in r1888 and that could be the cause of your performance issues.
Jake Stine (Air) - Programmer - PCSX2 Dev Team
Reply
#10
Make sure you have an up to date GSDx. If you're using 0.9.6, update to the latest beta (revision 1888) as a speedupwas added to star ocean in GSDx sometime between stable and that latest beta that makes a HUGE difference (I get perfect speed with latest beta, but older GSDx I'd be getting 20FPS or fewer)
[Image: 2748844.png]
Reply




Users browsing this thread: 1 Guest(s)