Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Help needed!
#1
Hi, everyone! I am completely new to pcsx2, so i thought i should ask you guys about this issue i have:

In short, I am trying to play Dragon Quest 8, but the speed of the game ranges from 20 fps to 60 fps ( it sticks to the lower end most of the time). The graphics look great, though the game is usually slow enough to be fairly annoying, especially during the speeches (but sometimes i also seem to be running fairly slowly around town). I am wondering if there are options (without having to change my hardware!) that i can use to speed / normalize my game's speed a bit.

As i have said, i am a noob... so i am hoping that you can explain things to me in simple terms.

My spec:
RAM: 2gb ddr2
GPU: ATI Radeon HD 5770
CPU: Core 2 Duo Q6600 @ 2.4 GHz
OS: I am using Windows 7 Ultimate (using compatible mode @ Windows XP SP3 for pcsx2)

The pc is around 3 years old...
Reply

Sponsored links

#2
You cpu is quite slow and most likely the bad guy. You can try and use speedhack, just dont turn them one all at a time. Try them out one by one to see which work for this game(dont have it myself so I can help you here). Do note that these are hacks so while some might get you more speed they can also break the game in one way or another.

Another thing you can do is overclock your cpu, this will easily solve your issue.

One last thing. You really dont need to run pcsx2 in compatability mode it has no issues with win7.
Specs:
CPU: C2D E8400 @ 3.6
GPU: GTX 560Ti 2Gb
MOB: Asus P5QL
RAM: Crucial 4Gb
OS: Windows 7 64bit/XP 32bit
Reply
#3
Have tried overclocking 'cuz your clocks are a bit slow to run that game.What settings are you using in Gsdx?
Intel E5700 @3.0Ghz,
Xfx Radeon 5670 1Gb,
4Gb DDR3 Ram,
Microsoft Windows7 Ultimate x86
Reply
#4
(09-09-2010, 09:02 PM)Speedy42 Wrote: Have tried overclocking 'cuz your clocks are a bit slow to run that game.What settings are you using in Gsdx?

I haven't changed anything, so my Gsdx is pretty standard. ( disabled framelimit and disabled fram skipping)
Reply
#5
If you post all your settings plugins we could provide more help, screenshots are you friends. In gsdx make sure you try running in dx10 if not already, it can be faster in some cases. Also try native, although your graphic card is quite good but try it anyway.
Specs:
CPU: C2D E8400 @ 3.6
GPU: GTX 560Ti 2Gb
MOB: Asus P5QL
RAM: Crucial 4Gb
OS: Windows 7 64bit/XP 32bit
Reply




Users browsing this thread: 1 Guest(s)