Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Help setting up Okami
#1
Hello. I’m new to the forums and I’ve been looking for some help regarding Okami. Trough experimentation I managed to run the game with most post processing effects but with this weird ghosting effect that can be partially fixed with TC offset. however, there is some problems in places like Tsuta Ruins where the fog is not rendered correctly (fog effect looks layered, like various transluscent layers one after the other). As a work around I used Bilinear (PS2) for Texture Filtering, revert the TC offset back to 0 and activated Round Sprite to Full which makes the game look precisely how it should, for the big exception of: 1) it produces a green shadow on certain shadows (like enemy shadows) and 2) the moment I leave Tsuta Ruins the post processing effects are all over the place (shadow effects look solid for instance). All of this in DX11.

Alternatively, as suggested on other posts, I used OpenGL and the post processing effects work fine but the ghosting effect and the problem with the fog in Tsuta Ruins are back. I also read that I should enable full depth emulation but couldn’t find that option anywhere.

I don’t know much about reporting bugs or asking for help to configure the emulator for a game so please let me know If some screenshots or log, or something like that can help others help me back.

I hope someone might be able to help me as I was on the middle of a stream which I had to stop because of the fog issues (had already given up on removing that weird ghosting effect completely). Thanks in advanced and do let me know If you require any other information.

PC Specs:
CPU: Intel Core I7 4790 3.60GHz
GPU: NVIDIA GeForce GTX 745
RAM: 12GB. 2 x 4 GB + 2 x 2GB. 798.11MHz
OS: Windows 10 64-bit

Also I’m using EmuCR-pcsx2-20160327-x86.

EDIT: Added screenshots that I think may help show my problems.

1) Shows how I’ve been playing so far. The ghosting problem is visible tough the problem with the fog hides it a bit.
2) The game as it should look after I activate Bilinear (PS2) and Round Sprite: Full. There are some color problems but that’s because of the shader and manual color corrections to make up for the color washing that the ghosting effect generates in 1.
3) After the workaround from 2 I can leave Tsuta Ruins and the rest looks fine except for those green shadows which I mentioned and highlighted in red here.
4) When outside Tsuta Ruins if at any time I keep the settings from 2, pause emulation and resume it will be set back to how Bilinear (PS2) always looks with bad post processing effects.

With OpenGL it looks a little worse than 1 but it has the same basic problems and a more noticeable ghosting problem.

EDIT 2: Apparently there’s no support for unofficial builds. I apologize for not knowing this beforehand. So I retested everything done so far on the latest official build 1.4.0 and all the problems mentioned are still there. So can anyone please help me out given that whichever build I use the problems mentioned are still there (except on 1.2.1 where they are actually worse). Just in case anyone was wondering I’ve tested everything mentioned here on 4 builds. 2 unofficial, including the one mentioned here, and 2 official (1.4.0 and 1.2.1).


Attached Files Thumbnail(s)
   
Reply

Sponsored links

#2
Quote:EmuCR-pcsx2-20160327-x86
We don't support unofficial builds
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
(04-04-2016, 06:23 AM)jesalvein Wrote: We don't support unofficial builds

Oh ok. Then assume everything I said was done on 1.4.0. Which is basically the case since every single problem I have with that build occurs as well on 1.4.0.
Reply
#4
HW depth is in the main config of gsdx.

Please try as well the latest git build and this pr. Gregory is currently working on a better depth support and it seems very promising.

If you don't like certain effects you can either increase skipdraw or play with the CRC hack level. (Btw. Partial is recommended for OGL and Full for DX11)
Reply
#5
(04-04-2016, 05:26 PM)willkuer Wrote: HW depth is in the main config of gsdx.

Please try as well the latest git build and this pr. Gregory is currently working on a better depth support and it seems very promising.

If you don't like certain effects you can either increase skipdraw or play with the CRC hack level. (Btw. Partial is recommended for OGL and Full for DX11)

Hello. Thank you very much for your help. I will keep the progress of this git build in mind for the future. For the time being, I’ve tried your suggestions and I still have the same basic problems. Though I have continued my stream anyway. I simply changed Texture Filtering to Bilinear (PS2) whenever I find that layered fog problem. So far is only Tsuta Ruins so I just ignored the green shadows and as soon as I left the place I changed Texture Flittering back to Bilinear (Forced). Still not Ideal, but its working just fine for now.

In any case, thanks a lot for your help. I hope sometime in the future I can play the whole game without having to work around graphical problems.
Reply




Users browsing this thread: 1 Guest(s)