Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Help speed up Digital devil saga
#1
Hi guys. I just downloaded the pcsx2 0.9.8
and i'm having a few speed problems with digital devil saga.

The opening fmv, and the title screen play at normal speed, but when i load my game, it massively slows down. When i pull up the in game menu, the speed goes back to normal. So Seraph is walkin around at the speed of super snail. The sound is also slow, or "drowsy".

The game also slows down when a random battle occurs, and goes back to normal when i'm selecting commands, but the atk/spell animations take forever.

the game almost seems fluid, except for these speed problems. I'll post some of my cpu specs, and pcsx settings below.

this is what the program log says:

PCSX2 0.9.8.r4600 - compiled on Apr 27 2011
Savestate version: 0x9a010000

Host Machine Init:
Operating System = Microsoft Windows 7 Home Premium Edition (build 7600), 64-bit
Physical RAM = 5119 MB
CPU name = AMD Athlon™ II X2 240 Processor
Vendor/Model = AuthenticAMD (stepping 02)
CPU speed = 2.799 ghz (2 logical threads)
x86PType = Standard OEM
x86Flags = 178bfbff 00802009
x86EFlags = efd3fbff

x86 Features Detected:
MMX.. SSE.. SSE2.. SSE3
MMX2 .. 3DNOW .. 3DNOW2.. SSE4a

Reserving memory for recompilers...

Loading plugins...
Binding GS : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\gsdx-sse2-r4600.dll
Windows 6.1.7600
ATI Radeon HD 4350 (8.14.1.6099)
Binding PAD : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\lilypad-r4600.dll
Binding SPU2 : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\spu2-x-r4600.dll
Binding CDVD : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\cdvdGigaherz.dll
Binding USB : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\USBnull.dll
Binding FW : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\FWnull.dll
Binding DEV9 : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\DEV9null.dll
Plugins loaded successfully.

I hope this isnt too much info, i know some of it is probly useless, but I'm a bit new to emulation, so i dont quite know what i'm doing.

If anyone could help me run DDS at its normal speed or better, so i could enjoy the animations, battles, and music. That person would be my hero Tongue

thanks in advance,
Chunchasku
Reply

Sponsored links

#2
Lower the internal resolution, your GPU is on the weaker side.

Use Speedhacks (if lowering the resolution didn't help enough), since your CPU could be faster.

Also, consider not keeping PCSX2 in the "Program Files" folder. Use a custom location you create for it (i.e. "C:\PCSX2").
Reply
#3
ok, so heres some exact FPS numbers i'm getting.
Opening FMV: 58-61fps 57-68%EE 18-27%GS
Title Screen:59-61fps 57-67%EE 4-20%GS
Load screen:59-60fps 7-15%EE 0%GS

Here's where it starts to suck

Walking around:28-29fps 33-44%EE 6-11%GS
Random encounter(transition to command selection):22-25fps 28-30%EE 5GS
Battle animations: i'm in a no battle spot, but the animations were like 18-22fps
In game menu:fps 60 10-20%EE 4-8%GS heres some more possibly helpfull info w/ my settings.

EE/IOP
-Eomotion/IOP (Recompiler)
-EE/FPU (chop/zero) Clamp mode (Normal

VUs
-VU0/VU1 (microVU Recompiler)
-VU0/Vua Advanced recompiler options
-round mode (Chop/Zero)
-Clamping mode (Normal)

GS
-Framelimiter
-base adjust 100%
-Slow motion adjust 50%
-Turbo adjust 200%
-NTSC Framerate 59.94 FPS
-PAL framereate 60 FPS
-Frameskipping(disabled)
(i've tried to enable it, but the graphix glitch out in some spots)
-not using synchonized MTGS or Disable gs out put

GS Window
-fit to windo/screen
-custom size 640X480
-zoom 100%

Speedhacks
-Enabled
-EE Cyclerate 3
-VU cycle stealing 0 (if i turn this up, the screen starts shaking and i cant fix it) the game was shaking initially, but i used F5 to fix that. This for some reason does not help w/ this setting.
(Other hacks)
-Enable INTC Spin Detection
-Enable Wait Loop Detection
-Enabled mVU hack

Game fixes
-Enabled EE timing hack(multi purpose hack) It says its known to affect DDS. is this for the better or worse?

Other than that maybe i'm using the wrong drivers?

Gs: GSdx 4600(MSVC 15.00, SSE2 0.0.16 [gsdx-sse2-r4600]
SPU2: SPU2-X r4600m 1.4.0 [spu2-x-r4600]
CDVD: cdvdGigaherz (r4510) 0.8.0 [cdvdGigaherz]
USB: USBnull Driver 0.7.0 [USBnull]
FW: FWnull Driver 0.7.0 [FWnull]
DEV9: DEV9null Driver 0.5.0 [Dev9null]

thanks again
chun
Reply
#4
The Gamefix "Fixes FMV and crashes". Sounds good to me. Smile

You need to go to the GSdx settings (video settings).

From PCSX2's main window, go to Config -> Video (GS) -> Plugin Settings...

Have you been in here? Check the "Native" box. (Also, you can change DirectX usage, if you haven't already)

BTW - It's normal to have the menus run fast, while in-game is another story. Wink
Reply
#5
What PCSX2 settings? PLugin settings? What do the EE/GS% numbers in the game window say when you get slowdowns?

Try ticking the "Native" checkbox in GSdx.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#6
(05-20-2011, 11:54 PM)Rezard Wrote: The Gamefix "Fixes FMV and crashes". Sounds good to me. Smile

You need to go to the GSdx settings (video settings).

From PCSX2's main window, go to Config -> Video (GS) -> Plugin Settings...

Have you been in here? Check the "Native" box. (Also, you can change DirectX usage, if you haven't already)

BTW - It's normal to have the menus run fast, while in-game is another story. Wink

ok, so you've helped me out a bit so far. ty ^^
i originally had the native box checked, but it slowed down the game.
i tried your solution to turn the internal resolution down, and it helped a little, my "walking around" FPS has gone from what it was to 42-45 fps, wich is a noteable change, but its still a bit slow.
the resolution was at 1024X1024. I changed it to 720X480. This resulted in the improved change.
any way i could further improve the speed?
Thanks
Chun
Reply
#7
Wait, it's slower with native checked than when set to 720x480...? IIRC, native is lower than 720x480. Native should be faster or make no change, not get slower...

Could you post a screen shot of your GSdx settings?
Reply
#8
(05-21-2011, 12:02 AM)Shadow Lady Wrote: What PCSX2 settings? PLugin settings? What do the EE/GS% numbers in the game window say when you get slowdowns?

Try ticking the "Native" checkbox in GSdx.

ok, so heres some exact FPS numbers i'm getting.
Opening FMV: 58-61fps 57-68%EE 18-27%GS
Title Screen:59-61fps 57-67%EE 4-20%GS
Load screen:59-60fps 7-15%EE 0%GS

Here's where it starts to suck

Walking around:28-29fps 33-44%EE 6-11%GS
Random encounter(transition to command selection):22-25fps 28-30%EE 5GS
Battle animations: i'm in a no battle spot, but the animations were like 18-22fps
In game menu:fps 60 10-20%EE 4-8%GS heres some more possibly helpfull info w/ my settings.
(05-21-2011, 12:11 AM)Rezard Wrote: Wait, it's slower with native checked than when set to 720x480...? IIRC, native is lower than 720x480. Native should be faster or make no change, not get slower...

Could you post a screen shot of your GSdx settings?

how do i post a screen shot of the settings?
Reply
#9
How to take the screen shot? You could just use the Snipping Tool (built into Windows).

You could upload it with a service site like Image Shack, or just attach it to a post here. Smile
Reply
#10
(05-21-2011, 01:18 AM)Rezard Wrote: How to take the screen shot? You could just use the Snipping Tool (built into Windows).

You could upload it with a service site like Image Shack, or just attach it to a post here. Smile

oh, ok. here ya go ^^
[Image: Gssettings.png]

wow, that makes things a whole lot easier XD thanks. So what are we workin with, and do u need any more screenshots?
Reply




Users browsing this thread: 1 Guest(s)