Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Help with compiling pcsx2.
#1
I need help trying to compile pcsx2 on Linux Mint 13 64bit, I have did this.
svn checkout http://pcsx2.googlecode.com/svn/trunk/ pcsx2-read-only

And then this.
./build.sh

But I am getting errors.

rm: cannot remove `install_log.txt': No such file or directory
-- The C compiler identification is GNU 4.6.3
-- The CXX compiler identification is GNU 4.6.3
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
CMake Warning at CMakeLists.txt:51 (message):


PCSX2 does not support a 64-bits environment and has no plan to support a 64-bits architecture in the future.
It would need a complete rewrite of the core emulator and a lot of time.



You can still run a 32-bits binary if you install all 32-bits libraries (runtime and dev).



Ubuntu users, please upgrade to 12.04.


CMake Warning at cmake/Pcsx2Utils.cmake:64 (message):
PCSX2 will stop to support GCC 4.6 in a near future. Please upgrade it to
GCC 4.7.
Call Stack (most recent call first):
CMakeLists.txt:96 (check_compiler_version)


-- BuildType set to Devel by default
-- Disable the stripping by default in Devel build !!!
-- Disable the building of po files by default in Devel build !!!
-- checking for module 'freetype2'
-- found freetype2, version 14.0.8
-- Could NOT find Freetype (missing: FREETYPE_LIBRARY FREETYPE_INCLUDE_DIRS) (found version "14.0.8")
-- Some or all of the gtk libraries were not found. (missing: GTK2_GTK_LIBRARY GTK2_GDKCONFIG_INCLUDE_DIR GTK2_GDK_LIBRARY GTK2_GLIBCONFIG_INCLUDE_DIR GTK2_GLIB_LIBRARY)
-- Could NOT find ALSA (missing: ALSA_LIBRARY) (found version "1.0.25")
-- Could NOT find BZip2 (missing: BZIP2_LIBRARIES BZIP2_INCLUDE_DIR)
-- Found Gettext: /usr/bin/msgmerge (found version "0.18.1")
-- Could NOT find JPEG (missing: JPEG_LIBRARY JPEG_INCLUDE_DIR)
-- Found OpenGL: /usr/lib/libGL.so
-- Looking for include file pthread.h
-- Looking for include file pthread.h - not found
-- Could NOT find Threads (missing: Threads_FOUND)
-- Could NOT find SDL (missing: SDL_LIBRARY) (found version "1.2.14")
-- Found Subversion: /usr/bin/svn (found version "1.6.17")
-- Could NOT find wxWidgets (missing: wxWidgets_FOUND)
-- Could NOT find ZLIB (missing: ZLIB_LIBRARY) (found version "1.2.3.4")
-- Could NOT find AIO (missing: AIO_LIBRARIES AIO_INCLUDE_DIR)
-- Found Cg: /usr/lib/i386-linux-gnu/libCg.so;/usr/lib/i386-linux-gnu/libCgGL.so
-- Could NOT find EGL (missing: EGL_LIBRARIES EGL_INCLUDE_DIR)
-- Could NOT find GLESV2 (missing: GLESV2_LIBRARIES GLESV2_INCLUDE_DIR)
-- Could NOT find GLEW (missing: GLEW_LIBRARY GLEW_INCLUDE_DIR)
-- Could NOT find Libc (missing: LIBC_LIBRARIES)
-- Could NOT find PortAudio (missing: PORTAUDIO_LIBRARIES PORTAUDIO_INCLUDE_DIR)
-- Could NOT find SoundTouch (missing: SOUNDTOUCH_LIBRARIES)
-- Could NOT find SparseHash (missing: SPARSEHASH_INCLUDE_DIR)
-- Could NOT find SparseHash_new (missing: SPARSEHASE_NEW_INCLUDE_DIR)
-- Skip build of common libraries: miss some dependencies
-- check these libraries -> wxWidgets (>=2.8.10), sparsehash (>=1.5), aio
-- Skip build of pcsx2 core: miss some dependencies
-- check these libraries -> wxWidgets (>=2.8.10), gtk2 (>=2.16), zlib (>=1.2.4), pcsx2 common libs
-- Skip build of CDVDiso: miss some dependencies
-- check these libraries -> bzip2 (>=1.0.5), gtk2 (>=2.16)
-- Skip build of GSdx: miss some dependencies
-- check these libraries -> opengl, egl, X11
-- Skip build of zerogs: miss some dependencies
-- check these libraries -> glew (>=1.6), opengl, X11, nvidia-cg-toolkit (>=2.1)
-- Skip build of zzogl: miss some dependencies
-- check these libraries -> glew (>=1.6), jpeg (>=6.2), opengl, X11, nvidia-cg-toolkit (>=2.1), pcsx2 common libs
-- Skip build of onepad: miss some dependencies
-- check these libraries -> sdl (==1.2)
-- Skip build of spu2-x: miss some dependencies
-- check these libraries -> soundtouch (>=1.5), alsa, portaudio (>=1.9), sdl (==1.2) pcsx2 common libs
-- Skip build of zerospu2: miss some dependencies
-- check these libraries -> soundtouch (>=1.5), alsa
-- Configuring done
-- Generating done
-- Build files have been written to: /home/woody/pcsx2-read-only/build
Scanning dependencies of target translations_pcsx2_Iconized
Scanning dependencies of target translations_pcsx2_Main
[ 1%] [ 3%] [ 5%] Generating ms_MY__pcsx2_Iconized.gmo
Scanning dependencies of target CDVDlinuz
Generating ru_RU__pcsx2_Iconized.gmo
Generating ms_MY__pcsx2_Main.gmo
[ 7%] Building C object plugins/CDVDlinuz/Src/CMakeFiles/CDVDlinuz.dir/buffer.c.o
In file included from /usr/include/errno.h:29:0,
from /home/woody/pcsx2-read-only/plugins/CDVDlinuz/Src/buffer.c:37:
/usr/include/features.h:324:26: fatal error: bits/predefs.h: No such file or directory
compilation terminated.
[ 9%] [ 11%] [ 12%] Generating pt_BR__pcsx2_Iconized.gmo
Generating ru_RU__pcsx2_Main.gmo
Building C object plugins/CDVDlinuz/Src/CMakeFiles/CDVDlinuz.dir/convert.c.o
make[2]: *** [plugins/CDVDlinuz/Src/CMakeFiles/CDVDlinuz.dir/buffer.c.o] Error 1
make[2]: *** Waiting for unfinished jobs....
[ 14%] /home/woody/pcsx2-read-only/plugins/CDVDlinuz/Src/convert.c:45:23: fatal error: sys/types.h: No such file or directory
compilation terminated.
[ 16%] [ 18%] Generating fr_FR__pcsx2_Iconized.gmo
Generating zh_CN__pcsx2_Iconized.gmo
Generating pt_BR__pcsx2_Main.gmo
make[2]: *** [plugins/CDVDlinuz/Src/CMakeFiles/CDVDlinuz.dir/convert.c.o] Error 1
make[1]: *** [plugins/CDVDlinuz/Src/CMakeFiles/CDVDlinuz.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[ 22%] [ 22%] [ 24%] Generating tr_TR__pcsx2_Iconized.gmo
Generating zh_TW__pcsx2_Iconized.gmo
Generating es_ES__pcsx2_Iconized.gmo
[ 25%] Generating fr_FR__pcsx2_Main.gmo
[ 27%] Generating cs_CZ__pcsx2_Iconized.gmo
[ 29%] [ 31%] Generating tr_TR__pcsx2_Main.gmo
[ 33%] Generating zh_CN__pcsx2_Main.gmo
[ 35%] Generating th_TH__pcsx2_Iconized.gmo
Generating nb_NO__pcsx2_Main.gmo
[ 37%] [ 38%] [ 40%] Generating ar__pcsx2_Main.gmo
[ 42%] Generating zh_TW__pcsx2_Main.gmo
Generating id_ID__pcsx2_Iconized.gmo
Generating de_DE__pcsx2_Iconized.gmo
[ 44%] [ 46%] Generating ko_KR__pcsx2_Iconized.gmo
Generating it_IT__pcsx2_Iconized.gmo
[ 48%] [ 50%] [ 51%] Generating cs_CZ__pcsx2_Main.gmo
[ 53%] Generating es_ES__pcsx2_Main.gmo
Generating sv_SE__pcsx2_Iconized.gmo
Generating pl_PL__pcsx2_Iconized.gmo
[ 55%] [ 57%] [ 59%] Generating th_TH__pcsx2_Main.gmo
[ 61%] Generating fi_FI__pcsx2_Iconized.gmo
Generating hu_HU__pcsx2_Iconized.gmo
Generating id_ID__pcsx2_Main.gmo
[ 62%] [ 64%] Generating ja_JP__pcsx2_Iconized.gmo
[ 66%] [ 68%] Generating de_DE__pcsx2_Main.gmo
[ 68%] Generating ko_KR__pcsx2_Main.gmo
Generating it_IT__pcsx2_Main.gmo
Built target translations_pcsx2_Iconized
[ 70%] Generating sv_SE__pcsx2_Main.gmo
[ 72%] [ 74%] [ 75%] Generating pl_PL__pcsx2_Main.gmo
Generating hu_HU__pcsx2_Main.gmo
Generating fi_FI__pcsx2_Main.gmo
[ 77%] Generating ja_JP__pcsx2_Main.gmo
[ 77%] Built target translations_pcsx2_Main
make: *** [all] Error 2
[ 35%] Built target translations_pcsx2_Iconized
[ 74%] Built target translations_pcsx2_Main
[ 75%] Building C object plugins/CDVDlinuz/Src/CMakeFiles/CDVDlinuz.dir/buffer.c.o
In file included from /usr/include/errno.h:29:0,
from /home/woody/pcsx2-read-only/plugins/CDVDlinuz/Src/buffer.c:37:
/usr/include/features.h:324:26: fatal error: bits/predefs.h: No such file or directory
compilation terminated.
make[2]: *** [plugins/CDVDlinuz/Src/CMakeFiles/CDVDlinuz.dir/buffer.c.o] Error 1
make[1]: *** [plugins/CDVDlinuz/Src/CMakeFiles/CDVDlinuz.dir/all] Error 2
make: *** [all] Error 2
Reply

Sponsored links

#2
It looks like you've got some missing dependencies.

Code:
-- found freetype2, version 14.0.8
-- Could NOT find Freetype (missing: FREETYPE_LIBRARY FREETYPE_INCLUDE_DIRS) (found version "14.0.8")
-- Some or all of the gtk libraries were not found. (missing: GTK2_GTK_LIBRARY GTK2_GDKCONFIG_INCLUDE_DIR GTK2_GDK_LIBRARY GTK2_GLIBCONFIG_INCLUDE_DIR GTK2_GLIB_LIBRARY)
-- Could NOT find ALSA (missing: ALSA_LIBRARY) (found version "1.0.25")
-- Could NOT find BZip2 (missing: BZIP2_LIBRARIES BZIP2_INCLUDE_DIR)
-- Found Gettext: /usr/bin/msgmerge (found version "0.18.1")
-- Could NOT find JPEG (missing: JPEG_LIBRARY JPEG_INCLUDE_DIR)
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#3
PCSX2 is generally difficult to impossible to compile using standards methods using the wonky multiarch system. So use the PPA instead.

sudo add-apt-repository ppa:gregory-hainaut/pcsx2.official.ppa
sudo apt-get update
sudo apt-get install pcsx2-unstable:i386

It's not the latest and greatest SVN version but it still beats the so-called stable version.
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply
#4
He trying to compile it because of issue in the other thread.
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#5
I think because I am using Linux mint 13 I can't update to Gregory's to one of his newer pcsx2 that he has on the ppa, so I might have to update to Linux Mint 16.
I believe the newer dependencies can't be installed on Linux Mint 13, I have the same problem with Dolphin-emu 4.0 so I am stuck with 3.5
Reply
#6
Multiarch is not as good as once thought, but it does allow for some flexibility between 32 bit and 64 bit programs in Linux. When you try to install certain :i386 dependencies, you end up running into dependency hell.

I can't find my old thread, but I had a method that worked on 64 bit Ubuntu-based distro for 12.04 64 bit. It doesn't work anymore though on current distro. Sad It went like this...

Install Virtualbox, repos are fine.
Install 32 bit of your exact same Linux distro in the VB.
Add the PPA to the repos in your 32 bit VB distro.
Update your repos and type sudo apt-get build-dep pcsx2-unstable
Download and compile the latest SVN the 'hard way'(not the PPA version! We only want help with the dependencies only).
Move the fully compiled SVN to your master 64 bit distro. It won't work in the VB distro due to gpu driver problems.
It 'should' play ok from then on.

Again, it's been a long time since I used this method so I don't remember all my exact steps. But it did work.
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply




Users browsing this thread: 1 Guest(s)