Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Help with optimising PCSX2
#1
Hey. im kinda like all new to this emulator stuf, but found it quite amazing and entertaining Smile Brings back alot of memories Wink

Anyways, im having problems, i use everything default + speedhack box enabled, but i get from 30-60 fps, and the games goes rly rly slow, any suggestions to what i should do?

My comp :
Intel Pentium T4200 2GHz dual-core
Ati Radeon HD 4570 512 MB
4Gb DDR3 Ram

its a laptop, but i thought it should be enuf to play PS2 games, it atleast is better than the reccomended speccs on the PCSX2 homepage.

Any help would be mostly appreciated Smile
Reply

Sponsored links

#2
It's not better than the recommended specs.
You will run a lot of 2D games and final fantasy X/kingdom hearts well but the cpu isn't enough for a lot of games.
[Image: 1454055.png]
Reply
#3
But im having trouble with Kingdom Hearts 1 and 2, i understand some lag on the 2nd, but thought it should be enough for the first..

i use all default drivers in the emulator, think i should change some of them? read that some use some speedhacks e.c.t. to makes the games run faster, and changed "lots of weird names on things" in preferences.. hmm, u think that will help me?
Reply
#4
(05-25-2010, 04:52 PM)XtrM Wrote: But im having trouble with Kingdom Hearts 1 and 2, i understand some lag on the 2nd, but thought it should be enough for the first..

i use all default drivers in the emulator, think i should change some of them? read that some use some speedhacks e.c.t. to makes the games run faster, and changed "lots of weird names on things" in preferences.. hmm, u think that will help me?

First use GSdx SSSE3 or SSE2 (recommend SSSE3 if your laptop support it) with "native" enabled. And use Direct3D 10 Hardware as this is the most fastest. At Advanced option, change Round Mode to Chop/Zero, change clamp mode to None, enable all of the Flush to Zero and Denormals are Zero. At sound plugin, use SPU2-X with the interpolation set to 'No Interpolation"

Well that might help a bit, or should boost the emulation speed.

edit: post your problems as we don't get your problems here. You may apply the configuration I stated above.
SPECS:
i7-2630QM
NVIDIA GT540M
500GB SATA
4GB DDR3
Windows 7 Home Premium 64-bit
Windows 7 Professional 64-bit
Windows 8 Pro 64-bit


Acer Aspire 4750G
Reply
#5
(05-25-2010, 03:35 PM)XtrM Wrote: i use everything default + speedhack box enabled

"speedhack box" thats an svn there, i am sorry but svn's are not supported use 1888 with march plugins and try again
OS: Win 7 Ultimate x64 sp1, MoBo: Asus P5QD Turbo, CPU: Q6600 @ 3,0Ghz, RAM: Trancend 2x2gb 6-6-6-18 800 MHz, GPU: HD 4850 1gb.
Pcsx2: Always Latest
Reply
#6
(05-25-2010, 12:41 PM)iakoboss7 Wrote: "speedhack box" thats an svn there, i am sorry but svn's are not supported use 1888 with march plugins and try again

What the ?? Are you sure Tongue2 ? you mean that emulation options window with speedhacks tab ?
SPECS:
i7-2630QM
NVIDIA GT540M
500GB SATA
4GB DDR3
Windows 7 Home Premium 64-bit
Windows 7 Professional 64-bit
Windows 8 Pro 64-bit


Acer Aspire 4750G
Reply
#7
only svn builds have a box you can tick so after you tick it you can enable speedhacks.
   
OS: Win 7 Ultimate x64 sp1, MoBo: Asus P5QD Turbo, CPU: Q6600 @ 3,0Ghz, RAM: Trancend 2x2gb 6-6-6-18 800 MHz, GPU: HD 4850 1gb.
Pcsx2: Always Latest
Reply
#8
Well that's what I mean. But we can't assume that he's using svn. the speedhacks window also called "box" Get what I mean ?
SPECS:
i7-2630QM
NVIDIA GT540M
500GB SATA
4GB DDR3
Windows 7 Home Premium 64-bit
Windows 7 Professional 64-bit
Windows 8 Pro 64-bit


Acer Aspire 4750G
Reply
#9
Im not 2 smart, so yeh, clicked the window.. ermm, well, hmm, the "enable speedhacks" box, and EE Cyclerate to two instead of 1, and Enable INTC spin detection and Enable Wait loop Detection :o
Reply
#10
At Advanced option, change Round Mode to Chop/Zero, change clamp mode to None, enable all of the Flush to Zero and Denormals are Zero. At sound plugin, use SPU2-X with the interpolation set to 'No Interpolation"

Couldnt figure out where "advanced option" was Tongue2 and .. hmm, sound plugin, i put it at "0-nearest" and checked the box with "disable effect procesing"

was that correct? =)

THnx for the help so far Smile
Reply




Users browsing this thread: 1 Guest(s)