Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Help with settings!! KH.
#1
Hi!, I want to know if somebody can help me with the settings just to play Kingdom Hearts, also sorry for my English ^^. I'll try to explain the best as I can. So, I try to configure PCSX2 watching YouTube videos and some of they works but then I have other problems.

First of all, my first problem was FPS. When I'm in Destiny Island FPS decrease (when the game starts I have 40-60 fps) but then, I'm having 22 fps or even 11 fps. It's annyoing cause I can't move. The second problem was while I was playing PCSX2 have problems and Windows close it. I though it was a compability problem, so I changed it to Windows XP Service Pack 3, but today I saw that it doesn't work, PCSX2 close too.

Trying some settings I have 50 fps stables, but in cinematics I have 11 fps (when Riku, Sora and Kairi are talking after you search the boat items.

Finally, I don't know what to do, cause whatever I try, it doesn't work well. Here I post the specs of my PC (I have a laptop):

Quote:http://puu.sh/a3ZGN/9207682bbc.png

Graphics card are Intel Graphics and AMD Radeon HD 8670M. I hope somebody can help me. Thanks ^^.
Reply

Sponsored links

#2
Your cpu is not very strong. Can you please post your emulation and gsdx settings? (For example using the screenshot function)
Reply
#3
(07-09-2014, 09:15 PM)willkuer Wrote: Your cpu is not very strong. Can you please post your emulation and gsdx settings? (For example using the screenshot function)

The last that I try are in this video (sent you in private) I think, works better but problem now is in cinematics.
Reply
#4
I actually hate videos. There is no easier way to stretch information into waste of time than in a youtube video.
The video you send to me supports piracy which is already a bad starting point. The pcsx2 version is also not official and he puts a lot of plugins inside that are not needed.
Then he/she only uses default settings. So no magic can be found here.

Try this:
1. use the latest stable release (1.2.1) it is slightly faster than GIT/SVN/unstable-versions
2. set the gs plugin to gsdx....avx2....dll.
3. Don't use any speedhack for the moment; especially not MTVU hack. Your cpu only has two real cores. MTVU might slow you down.
4. Disable gamefixes, set gsdx plugin to default settings (native ticked) and select your gpu in the adapter selection. Use DX10/11 (Hardware)
5. Go ingame to a demanding scene and note FPS, EE% and GS% in the titlebar in windowed mode
6. Enable all recommended speedhacks (all tickboxes except for fastcdvd and MTVU)
7. Go ingame to the same demanding scene and note FPS, EE% and GS% in the titlebar in windowed mode
8. Enable MTVU-hack
9. Go ingame to the same demanding scene and note FPS, EE%, VU% and GS% in the titlebar in windowed mode

Post all three value triples in this thread.
Reply
#5
(07-09-2014, 10:09 PM)willkuer Wrote: I actually hate videos. There is no easier way to stretch information into waste of time than in a youtube video.
The video you send to me supports piracy which is already a bad starting point. The pcsx2 version is also not official and he puts a lot of plugins inside that are not needed.
Then he/she only uses default settings. So no magic can be found here.

Try this:
1. use the latest stable release (1.2.1) it is slightly faster than GIT/SVN/unstable-versions
2. set the gs plugin to gsdx....avx2....dll.
3. Don't use any speedhack for the moment; especially not MTVU hack. Your cpu only has two real cores. MTVU might slow you down.
4. Disable gamefixes, set gsdx plugin to default settings (native ticked) and select your gpu in the adapter selection. Use DX10/11 (Hardware)
5. Go ingame to a demanding scene and note FPS, EE% and GS% in the titlebar in windowed mode
6. Enable all recommended speedhacks (all tickboxes except for fastcdvd and MTVU)
7. Go ingame to the same demanding scene and note FPS, EE% and GS% in the titlebar in windowed mode
8. Enable MTVU-hack
9. Go ingame to the same demanding scene and note FPS, EE%, VU% and GS% in the titlebar in windowed mode

Post all three value triples in this thread.

Here's the screenshots that I take, first using only this, also I'm using Europe BIOS 2.20 :

1. use the latest stable release (1.2.1) it is slightly faster than GIT/SVN/unstable-versions
2. set the gs plugin to gsdx....avx2....dll.
3. Don't use any speedhack for the moment; especially not MTVU hack. Your cpu only has two real cores. MTVU might slow you down.
4. Disable gamefixes, set gsdx plugin to default settings (native ticked) and select your gpu in the adapter selection. Use DX10/11 (Hardware)

GS Options:
Quote:http://puu.sh/a4RCN/13b8b8242d.png

Quote:http://puu.sh/a4QHY/d4f91b555f.jpg
http://puu.sh/a4QJP/caff58e184.jpg
http://puu.sh/a4QOv/b369bf2b68.jpg
http://puu.sh/a4R4l/717d07530d.jpg
http://puu.sh/a4R7u/cfdd63e09c.jpg
http://puu.sh/a4RbK/9aa9e79b2c.jpg
http://puu.sh/a4Reo/286fd54fd7.jpg
http://puu.sh/a4RfM/20093c1d37.jpg
http://puu.sh/a4Rhb/a95959ec46.jpg
http://puu.sh/a4RiE/938cb2c457.jpg

I noticed than in some scenes FPS goes to 40-50 fps max, and then in gameplay decrease to 30-40. In simples scenes I got the first FPS that I said, but as u can see, when I'm talking with Kairi I only got 30 fps and decreasing (30-20). Also in gameplay I got sometimes 40-50 fps but in Destiny Island i got 30 max.

Here I try the second option right now using USA 2.00 6. Enable all recommended speedhacks (all tickboxes except for fastcdvd and MTVU). Settings are:
Quote:http://puu.sh/a4RAv/17f6e4aef0.png

Quote:http://puu.sh/a4RLL/a17d207d13.jpg
http://puu.sh/a4RNW/39d4caf737.jpg
http://puu.sh/a4ROT/13e62bf818.jpg
http://puu.sh/a4RPD/88ad2d44b2.jpg
http://puu.sh/a4RQw/39c53100d0.jpg


Seems the same ... I don't see changes. Maybe I forgot to pick one hack, but I don't think that will be change so much.

Finally, with the last settings that you told:

Quote:http://puu.sh/a4S0y/921e77bd27.jpg
http://puu.sh/a4S1C/5fb90a2f80.jpg
http://puu.sh/a4S3L/57a1dbb904.jpg
http://puu.sh/a4Sc7/882affc11c.jpg

Cinematics:
Quote:http://puu.sh/a4SdR/24cd2cea9c.jpg
http://puu.sh/a4SeE/71c22a2b6e.jpg
http://puu.sh/a4Sfi/33969c1d8e.jpg
http://puu.sh/a4Sge/affa4e7c25.jpg
http://puu.sh/a4Sh4/ed1a04647f.jpg
http://puu.sh/a4ShU/5e775aa300.jpg
http://puu.sh/a4SiK/f4a517cbf0.jpg
http://puu.sh/a4Sjz/4905ff7718.jpg
http://puu.sh/a4Skc/466635f760.jpg
http://puu.sh/a4Sl5/51eebf483b.jpg
http://puu.sh/a4Slw/b1fea3bb42.jpg
http://puu.sh/a4Sml/992c318420.jpg
http://puu.sh/a4Snb/40ec79c16c.jpg

Seems to work better, I got 55 fps max but they're not stable at all. I noticed that in EE, when I have lows FPS they decrease as u can see. With 55 FPS EE are in 98 % and with 11, are in 32 %.

I hope the screenshots can help and sorry about the video, but at this time I don't have the PC to take screenshots.[/quote]
Reply
#6
You forgot to tick the other tickboxes in the speedhacks section. Since MTVU is working well you can tick all tickboxes except the bottom left one (activar cdvd rapido).

Now you can try to increase the left of the two sliders (velocidad de ciclos EE) by one (value = 2) and recheck fps, if it is not sufficient test value = 3.

If this is not sufficient or even worse you can leave it on the best setting EE=1/2/3 (whatever works best)

Since the game seems to really do something in the VU you can try SuperVU as VU-engine. It can be found in the emulation settings VU0/1. Just select SuperVU instead of microVU.

Report back how that worked.
Reply
#7
Using the first settings that you told, I can play better, FPS are 50-40 right now in gameplay, maybe when I fight it goes to 37 fps but then they comeback to 50-40. I can't try with cinematics because they're not so much in this moment. The first try was with this configuration:
Quote:http://puu.sh/a55jJ/bda3776ee7.png
. I realised that I have (Robar ciclos) too, but then I changed it in 1, and works well too.

Screenshots are here:

Quote:http://puu.sh/a55rj/7072733fdd.jpg
http://puu.sh/a55tN/e063cecf16.jpg
http://puu.sh/a55CZ/5d4ecf2611.jpg
http://puu.sh/a55DU/718b99a05b.jpg
http://puu.sh/a55Ln/8f5c807ead.jpg
http://puu.sh/a55Nb/e2f0010c04.jpg
http://puu.sh/a55O6/844c4a55b2.jpg
http://puu.sh/a55Pj/32e36d61a6.jpg
http://puu.sh/a565s/66276fd719.jpg
http://puu.sh/a56cU/e061e96d07.jpg
http://puu.sh/a56fu/13919665d0.jpg


Then, I changed the settings but only change "velocidad de ciclos EE", and the settings at this moment are:

Quote:http://puu.sh/a56Xu/5ea9da0e81.png

Screenshots:
Quote:http://puu.sh/a5762/4a609b1a20.jpg
http://puu.sh/a57ff/2a34b435d5.jpg
http://puu.sh/a57g1/3463cc4e8f.jpg
http://puu.sh/a57k4/f95a825149.jpg
http://puu.sh/a57ne/f70e3ce62b.jpg


I don't take many screenshots cause it seems to works as EE value 2. So, I change it again to EE value 2 cause for me, works a bit better. Finally last settings
Quote:http://puu.sh/a57Ab/aa3c966d79.png
. Screenshots:

Quote:http://puu.sh/a57Fr/1d0eac65f9.jpg
http://puu.sh/a57Ge/e387262933.jpg
http://puu.sh/a57Hj/bfcc43d9d6.jpg
http://puu.sh/a57Il/c1554f816d.jpg
http://puu.sh/a57P7/f0a8b70bfd.jpg
http://puu.sh/a57Yv/a327ad82c1.jpg
http://puu.sh/a57ZK/4785e710f5.jpg
http://puu.sh/a580Z/711099c4a1.jpg

I noticed that FPS goes to 38-45 fps as max fighting and also moving, so I decided to change it. Finally I comeback to the first settings. That's all.
Reply
#8
Keep in mind: "Robar ciclos de VU" is faking fps. Real fps can be lower than what is written. But nevertheless it can be good to touch this slider as well.

What you should do if the fps are that close to full speed is to set the output mode in SPU2-X settings to async mix. This reduces the stuttering of music.

The last thing I would try is set the clamping modes ("mode pinzado") to none ("Ninguono") and see if it helps. This can crash the game so if it doesn't help set it back to normal.

If the settings are in the end ok to play you might also play around with upscaling and improving video quality by that.


You have now changed a lot of settings to non-default values. Keep in mind that this can cause crashes. Try not to depend on savestates but use the ingame save function as often as possible.
Reply
#9
(07-10-2014, 04:40 PM)willkuer Wrote: Keep in mind: "Robar ciclos de VU" is faking fps. Real fps can be lower than what is written. But nevertheless it can be good to touch this slider as well.

What you should do if the fps are that close to full speed is to set the output mode in SPU2-X settings to async mix. This reduces the stuttering of music.

The last thing I would try is set the clamping modes ("mode pinzado") to none ("Ninguono") and see if it helps. This can crash the game so if it doesn't help set it back to normal.

If the settings are in the end ok to play you might also play around with upscaling and improving video quality by that.


You have now changed a lot of settings to non-default values. Keep in mind that this can cause crashes. Try not to depend on savestates but use the ingame save function as often as possible.

Changing SPU-2X to Async and clamping modes ("mode pinzado") to none makes the game works better. I think that I'm not going to improve video quality, I think it's fine. So, thanks you for all ^^. Now I can play without lag and crashes Smile
Reply




Users browsing this thread: 1 Guest(s)