Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
High CPU consumption cause pcsx2 FPS down and bad sound
#1
Hi,

I don't know why CPU consumption become high above 20% when i play a PS2 game with pcsx2 (other application do not like this). It cause FPS down and bad sound. I search in the google and i edited /etc/pulse/daemon.conf become :

Quote:; daemonize = no
; fail = yes
; allow-module-loading = yes
; allow-exit = yes
; use-pid-file = yes
; system-instance = no
; enable-shm = yes
; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB
; lock-memory = no
; cpu-limit = no

high-priority = no
nice-level = 0

realtime-scheduling = no
realtime-priority = 5

; exit-idle-time = 20
; scache-idle-time = 20

; dl-search-path = (depends on architecture)

; load-default-script-file = yes
; default-script-file =

; log-target = auto
; log-level = notice
; log-meta = no
; log-time = no
; log-backtrace = 0

resample-method = trivial
; enable-remixing = yes
; enable-lfe-remixing = no

flat-volumes = no

; rlimit-fsize = -1
; rlimit-data = -1
; rlimit-stack = -1
; rlimit-core = -1
; rlimit-as = -1
; rlimit-rss = -1
; rlimit-nproc = -1
; rlimit-nofile = 256
; rlimit-memlock = -1
; rlimit-locks = -1
; rlimit-sigpending = -1
; rlimit-msgqueue = -1
; rlimit-nice = 31
; rlimit-rtprio = 9
; rlimit-rttime = 1000000

; default-sample-format = s16le
; default-sample-rate = 44100
; default-sample-channels = 2
; default-channel-map = front-left,front-right

default-fragments = 8
default-fragment-size-msec = 10

I kill and start pulseaudio daemon. It works, now CPU consumtion for pulseaudio average 4 - 5 %. And pcsx2 worked normally.

Maybe do you have a good setting and suggestion fot pulseaudio configuration ?

Thanks in advance.
Reply

Sponsored links





Users browsing this thread: 1 Guest(s)