Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
High GPU load, poor fps
#1
I'm running PCSX2 1.4 on Ubuntu 14.10 with i5 3570k and Radeon HD7950 - prophietary drivers installed. In GT4, the menus are ok but 3d scenes are extremely slow even with native resolution set on gs plugin.  FPS is around 10-15 and amdconfig shows %96 GPU load. What's the reason of such poor performance?
Reply

Sponsored links

#2
I am a little out of my element here both in terms of os and video card manufacturer but have you tried selecting DX11 HW as your renderer and making sure you have your Radeon 7950 selected as your adapter under GSDX settings?
Reply
#3
GT games are notoriously difficult to emulate. Plus Catalyst doesn't seem to perform as well as Nvidia. Try software mode with extra tendering threads. That's all I can think of at this time.
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply
#4
You can try to disable accurate blending on the menu. You could also disasble the depth effect emulation
Reply
#5
(02-10-2016, 09:19 AM)gregory Wrote: You can try to disable accurate blending on the menu. You could also disasble the depth effect emulation

Yeah disabling accurate blending made a huge difference! Now getting mostly +60fps, increasing the native resolution to 2x or 3x doesnt seems to affect the performance that much either.

Now I've got another issue and I'm not sure if I should open another thread for it because I think it's related another topic; FPS drops to 30's-35's when I'm around AI cars in a race. When I monitor GPU usage it stays around %60 with 3x native resolution. So I suppose this is a CPU bottleneck right? I'm running 3570k at 4.2ghz, I have already enabled all the speedhacks expect EE cyclerate and VU stealing, and I used to run GT4 on Windows with same settings-rig with a constant 60fps. Does Linux version requires more CPU power or am i missing something here?
Reply
#6
Nah you don't need to bother with another thread might as well try and solve everything in one place.

Under emulation settings try setting preset level 1 safest then untick the preset box to modyfy settings manually and under speedhacks tick both the mVU and MTVU boxes. Lastly reduce the EE by 33%. Those are my recommended settings for PCSX2. I don't recommend any other setting changes beyond that.
Reply
#7
Speed impact of accurate blending really depends on the game. I would advice to enable it every time you can.

Except amd driver, linux perf is likely on par with windows.
Reply
#8
(02-10-2016, 01:39 PM)NRX Wrote: Yeah disabling accurate blending made a huge difference! Now getting mostly +60fps, increasing the native resolution to 2x or 3x doesnt seems to affect the performance that much either.

Now I've got another issue and I'm not sure if I should open another thread for it because I think it's related another topic; FPS drops to 30's-35's when I'm around AI cars in a race. When I monitor GPU usage it stays around %60 with 3x native resolution. So I suppose this is a CPU bottleneck right? I'm running 3570k at 4.2ghz, I have already enabled all the speedhacks expect EE cyclerate and VU stealing, and I used to run GT4 on Windows with same settings-rig with a constant 60fps. Does Linux version requires more CPU power or am i missing something here?

Your cpu have enough power (higher ipc with higher frecuency), main problem as other said stay in gpu drivers


In my case runs good, stay above 55 to 60fps in race





System Specs Used in Test

Distro: Linux Mint 17.2 Raffaela 64bits
Desktop: XFCE
Kernel: 4.00.0-40000-generic
CPU: INTEL Pentium G3258 (Haswell 22nm) at 4.1Ghz + Artic Cooling Alpine 11 Plus
GPU: Nvidia Geforce GT 630 2048mb
Driver: Nvidia 361.16
PCSX2 Version: 1.4.0
Settings: Appears in video
Speed: Appears in video*

*However when stay recording loss around 8% of cpu when stay recording at 30fps and around 16-18% when stay recording at 48 or 60fps

Smile
Linux Mint 17.2 XFCE Edition 64Bit - Kernel 4.00
CPU: INTEL Pentium G3258 (Haswell 22nm) at 4.1Ghz + Artic Cooling Alpine 11 Plus
MEM: 8GB DDR3 1333 (4x2) patriot value (21/8 Gb/s)

GPU: Zotac NVIDIA Geforce GT630 (GK208 28nm: 384 Shaders / 8 ROPS) Passive Cooling 2GB DDR3 64Bit (14.4 Gb/s)
BOARD: MSI H81M E33
Reply




Users browsing this thread: 1 Guest(s)