Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
High framerates but runs slowly?
#1
Hey all,
I've been tracking through this forum reading every bit of advice I could from other people but I still can't get this fixed. I'm trying to run Kingdom Hearts and when in a non-intensive area, I get 60FPS but my CPU sits at 100% according to the little monitor at the top of PCSX2's window. When I turn my view to a more intense area, my framerate drops a little (to about 50 or possibly 45 sometimes) but my CPU drops down to 50% and the game starts to lag tremendously. I thought the lower your CPU percentage the better since it isn't working as hard?

I'm running it on a gaming laptop which I just bought with these specs:
1. AMD Athlon Dual Core M300 2.0GHz (Slightly better than the T4200 for you Intel people)
2. 4GB DDR2 RAM
3. ATI Mobility Radeon HD 4650 (Almost a Class 1 graphics card)
4. Windows 7

I don't think that it's my computer seeing as I can run Modern Warfare 2 and other new-release games on the highest settings flawlessly. I did read in the forums however that apparently my clock speed for my CPU needs to be ridiculous. But, I did see someone else post a "Will it run on..." thread with a laptop that was well below my specs and someone told them yes and their clock speed was about the same.

My configs are below:

GSDX SSE2 plugin
1. Windowed resolution
2. D3D 10 (Hardware)
3. Pixel Shader 2.0 (Grayed out, which I think is because D3D 10 uses Pixel Shader 4.0)
4. Blend bff for interlacing
5. Stretch aspect ratio (I have a 16:10 screen)
6. 1024 X 1024 internal resolution
7. Texture filtering and waitVSync are checked on

All other plugins are set to default. All speedhacks are off and all advanced settings are default as well.

I've messed around for about 2 hours with the configs (using D3D 9 and speedhacks and punching my cat) and nothing has worked. Does anyone have any suggestions? Perhaps I'm not doing the right combination of speedhacks or I should stick to some special config of D3D 9 or something? Maybe it's a sound problem too since when things get choppy my sound gets a little funny.

Any help would be appreciated, tell me if you'd like other specs or settings.
Thanks!
Reply

Sponsored links

#2
CPU% based on the PCSX2 window? If so, the CPU% is going down because your CPU is too slow. The window only shows the CPU core that handles the graphics... If it's at 90-100% that means your graphics card is either just barely scraping it, or your game is slowing down because the graphics is too weak.

If it's below 80% or so, and you're getting a lot of slowdown... it's because that CPU core is waiting. It can't be pushed to 100%, because your main CPU core (handling all the other parts of the emulator) is bogged down and isn't passing data to it fast enough. Of course, if you aren't getting any slowdown in games, neither value is particularly important Wink

Laptops are terrible PS2 emulation machines at this point. Mainly because most PS2 games require a 3ghz+ dual core... and you're sitting at exactly 2ghz. Well below what's recommended. Kingdom hearts games are luckily on the light end so are mostly PLAYABLE at that clockrate... but there is a definite difference between playable, and plays at 100% full speed 100% of the time.

(edit) A couple tips that may help you though... #1: Always use DX10 mode as it's faster. #2: Update to the latest beta (revision 1888) as it's a good 10-20% faster depending on the game and situation. #3: Turn Vsync off, it causes all sorts of problems in the current PCSX2 when in used with dual+ core CPU. The problem will be fixed when 0.9.7/0.9.8 is released.
[Image: 2748844.png]
Reply
#3
That's an interesting bit about my CPU waiting for my graphics card. I don't think it is though seeing as my graphics card is pretty close to top of the line. However, it is strange if what you said is true and my CPU is "waiting" for my graphics card to render. Perhaps its some setting I missed?

As for the CPU itself, it is kind of crappy that I see most threads recommending a 3GHz dual core since most (if not all?) laptop CPU's come less than 3GHz standard speed.

For the VSync issue, if I don't turn it on, I get... well Vsync issues haha. Not only that, but my game will run at a million miles a second with 100+ FPS and 35% CPU usage. Then, when I turn the screen to a graphics heavy area, I get the same problem where the game starts to slow down.

Thanks for the help though, Koji. I appreciate it. I'll try using the beta and see if something happens.
Reply
#4
Ah, what a cruel world. Ran it on the beta and although it's a little better (maybe) I'm still getting the same problems. Looks like I'll just have to keep tweaking to see if I get any results with the beta. Please feel free to keep contributing to this thread if you have any ideas.

Thanks all.
Reply
#5
(12-01-2009, 05:54 AM)lagoona2003 Wrote: That's an interesting bit about my CPU waiting for my graphics card. I don't think it is though seeing as my graphics card is pretty close to top of the line. However, it is strange if what you said is true and my CPU is "waiting" for my graphics card to render. Perhaps its some setting I missed?

Sorry but the card isnt close to top of the line and neither is the CPU but they should be enough for kingdom hearts.

Quote:As for the CPU itself, it is kind of crappy that I see most threads recommending a 3GHz dual core since most (if not all?) laptop CPU's come less than 3GHz standard speed.

Maybe so, but PS2 emulation is pretty intensive and it's not PCSX2's fault if laptops dont come on higher speeds generally, I mean even "gaming" laptops come with pretty weak processors but just a better GPU which is more needed for PC games nowadays.

But again your system should be enough for kingdom hearts anyway.

Quote:For the VSync issue, if I don't turn it on, I get... well Vsync issues haha. Not only that, but my game will run at a million miles a second with 100+ FPS and 35% CPU usage. Then, when I turn the screen to a graphics heavy area, I get the same problem where the game starts to slow down.

I'd recommend you try enabling frame limiter in "config > cpu" and turn off Vsync in GSdx instead and maybe tick the "native" option in GSdx althou maybe this one wont make a difference at all.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#6
Disable Vsync, turn on Frame limiter in Config->CPU and check 'native' in the GSdx plugin. That should at least reduce the lag when you're viewing heavy scenes for your graphics card.

Quote:As for the CPU itself, it is kind of crappy that I see most threads recommending a 3GHz dual core since most (if not all?) laptop CPU's come less than 3GHz standard speed.

PCSX2 is really not recommended to be used with a laptop. The massive stress it puts on the processor will generate LOTS of heat, so in many cases laptops start throttling (clocking down your processor) to compensate or even shut down.
In the end, PCSX2 needs a very powerful dual core (or a high clocked quad) which laptops currently lack. Although you can get specs like that nowadays in a desktop for real cheap.

Oh and about this:

Quote:don't think that it's my computer seeing as I can run Modern Warfare 2 and other new-release games on the highest settings flawlessly. I did read in the forums however that apparently my clock speed for my CPU needs to be ridiculous.

Maybe you'll want to read the thread "Why is PCSX2 slow" from the FAQ (at useful links) before comparing PC games to PS2 emulation which are 2 totally different things

Edit: Damn you Shadowlady!! Tongue
[Image: newsig.jpg]
Reply
#7
I blame ref :<
I took my sweet time making my post too xD

I forgot to mention other things you could try to increase some speed are checking the "disable effects processing" option in SPU2-X or using ZeroSPU2 as Sound plugin, as well as setting the clamp modes in "config > advanced" to 'none'.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply




Users browsing this thread: 1 Guest(s)