Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How can I change the language of Final Fantasy X International completely?
#1
Hello, guys! How are you?
Ok, the game is running 50% Japanese, 50% English (voice in English, subtitles and interface in Japanese).
I know that, ingame, I can switch the subtitles and the interface of the game to English or Japanese making the game 100% English or 50/50, but I can't change the voice to Japanese... AND I WANT TO PLAY THIS GAME IN FULL JAPANESE!
Yes, I'm running the BIOS from Japan, and it is not working;
Yes, I tried to change the language from the system, it has two options, English and Japanese and it is set to Japanese;
And the code of my ISO is from Asia, I checked it.

I read a thread here about God of War, and the problem was almost the same. The guy wanted to play the game in another language but English (I don't remember which, now) and someone told him to Run -> Execute iirc, and it did work for him... but I have no idea what iirc means, my whole emulator doesn't have anything similar to iirc, I've checked.
Also, I noticed that when I run the game, the disc region is set to NTSC, not NTSC-J or PAL, it doesn't matter if I use Europe, USA or Japan BIOS.
It's pretty odd, since the ISO code is from Asia.
So... any help?
Sorry for the English, by the way. Blush
Reply

Sponsored links

#2
Final Fantasy X International only contains English voices. It does not contain any Japanese voices at all.
Reply
#3
(07-24-2015, 02:04 AM)Kyusuke Wrote: Final Fantasy X International only contains English voices. It does not contain any Japanese voices at all.

How can it be?
I dunno, bro.
Take a look at this video: https://www.youtube.com/watch?v=6m_sV5n0kDk
The guy is even using PCSX2 to play the game.
Reply
#4
The game's externally patched by a mod that replaces the English audio with the Japanese.
Reply
#5
(07-24-2015, 02:18 AM)Kyusuke Wrote: The game's externally patched by a mod that replaces the English audio with the Japanese.

Oh... I see...
I'm sad now. TT^TT
Thank you.
I was so worried about the emulation and BIOS itselves that I didn't even search about this detail.
Sorry for bothering.
Reply
#6
(07-24-2015, 01:12 AM)Ninjyare Wrote: Hello, guys! How are you?
Ok, the game is running 50% Japanese, 50% English (voice in English, subtitles and interface in Japanese).
I know that, ingame, I can switch the subtitles and the interface of the game to English or Japanese making the game 100% English or 50/50, but I can't change the voice to Japanese... AND I WANT TO PLAY THIS GAME IN FULL JAPANESE!
Yes, I'm running the BIOS from Japan, and it is not working;
Yes, I tried to change the language from the system, it has two options, English and Japanese and it is set to Japanese;
And the code of my ISO is from Asia, I checked it.

I read a thread here about God of War, and the problem was almost the same. The guy wanted to play the game in another language but English (I don't remember which, now) and someone told him to Run -> Execute iirc, and it did work for him... but I have no idea what iirc means, my whole emulator doesn't have anything similar to iirc, I've checked.
Also, I noticed that when I run the game, the disc region is set to NTSC, not NTSC-J or PAL, it doesn't matter if I use Europe, USA or Japan BIOS.
It's pretty odd, since the ISO code is from Asia.
So... any help?
Sorry for the English, by the way. Blush

Use this cheat code on pcsx2:

patch=1,EE,0031CE5E,extended,00000001

Game always in english.
Reply
#7
(07-24-2015, 08:51 AM)Be4stElectrjc Wrote: Use this cheat code on pcsx2:

patch=1,EE,0031CE5E,extended,00000001

Game always in english.

What's the patch for?
[Insert Witty Sig Here.]
Reply




Users browsing this thread: 1 Guest(s)