Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How does one downsample PCSX2
#1
So far I have found no way to set my window resolution to a resolution above my monitor's native. I can only up the internal rez, but on the "window settings" page there is only a resolution box for windowed mode: I want to play fullscreen.

I am asking because, some PC games that are inherently blurry can become sharp when downsampled. Maybe the same can be said of blurry PCsx2 games.
Reply

Sponsored links

#2
setting the internal res above your monitors resolution does cause downsampling.
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply
#3
Setting the internal res allows you to set it to much larger resolutions, resulting in way higher quality. Just double click the window to go to fullscreen after that.

I run all my games in 2560x1440 even though my monitor's max. res is 1920x1200. (It downsamples to 1920x1080 obviously, but you maintain that 'extra quality' basically).
Intel Core i5-4670K @ 3.40GHz | 16GB (2x8GB) DDR3-1866 G.SKILL Sniper Series
AMD Radeon R9 280 @ 3 GB | 120GB SSD | Windows 7 Ultimate x64 (SP1)
Reply
#4
Hmmmm right. I was thinking, internal rez leaves any blurring that is native to the game so maybe monitor downsmapling would work with that.
Of course it doesn't work like that, now does it.

Thanks ;(
Reply
#5
Comparison screenshot might be helpful here too.

Native PS2 Resolution
[Image: KH2-Native.jpg]

Internal Resolution: 1920x1080
[Image: KH2-1080p.jpg]

Internal Resolution: 3840x2160 (Downsampled 1920x1080)
[Image: KH2-UltraHD.jpg]


In the final screenshot the sprite of Sora looks way more detailed and 'sharper'.
Intel Core i5-4670K @ 3.40GHz | 16GB (2x8GB) DDR3-1866 G.SKILL Sniper Series
AMD Radeon R9 280 @ 3 GB | 120GB SSD | Windows 7 Ultimate x64 (SP1)
Reply
#6
Jup, that's the effect I wanted to achieve in Drakengard. However that game seems to have some blur implemented regardless of resolution. Possbily some hack can remove, but I'm not sure.
King's Field IV also has a blur. Setting skipdraw to a certain value will remove it...together with any and all UI....so yeah.
Reply
#7
Turn off texture filtering. Of course, this will affect even the textures that you want to be filtered. I don't think that there is a way to just affect the UI textures. The default try to do that, but it does not work in all games.

And for the billionth time, down-sampling does not improve textures. No idea why people keep thinking that. The sprite looks more pixelated, not sharpened.
Reply
#8
(05-20-2015, 11:41 PM)Ryudo Wrote: Comparison screenshot might be helpful here too.

Native PS2 Resolution
[Image: KH2-Native.jpg]

Internal Resolution: 1920x1080
[Image: KH2-1080p.jpg]

Internal Resolution: 3840x2160 (Downsampled 1920x1080)
[Image: KH2-UltraHD.jpg]


In the final screenshot the sprite of Sora looks way more detailed and 'sharper'.

Ultima Weapon. Wut.
[Insert Witty Sig Here.]
Reply
#9
(05-21-2015, 04:48 AM)K.F Wrote: Turn off texture filtering. Of course, this will affect even the textures that you want to be filtered. I don't think that there is a way to just affect the UI textures. The default try to do that, but it does not work in all games.

And for the billionth time, down-sampling does not improve textures. No idea why people keep thinking that. The sprite looks more pixelated, not sharpened.

Turning off texture filtering does not remove the blur. I get the feeling you're misinterpreting the topic.
Reply
#10
(05-21-2015, 02:49 PM)Renatar567 Wrote: Turning off texture filtering does not remove the blur. I get the feeling you're misinterpreting the topic.

Nope, it just means that the default setting actually works for kingdom hearts, so not much can be done about it.
Reply




Users browsing this thread: 1 Guest(s)