Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How to disable Bloom in Ratchet: Deadlocked? (re-post) HELP!
#1
This may or may not be in the wrong chunk of the forums, but there appears to be specific help regarding getting games to run.
This is a copy of the message from the general discussion.


I fully understand that Ratchet: Deadlocked is a ridiculously tough game to run for PCSX2. By the way, my general specs for my PC are as follows:
AMD 5700HD CPU 3.4GHZ overclocked to 4.1.
GTX 780
16GB of RAM
Windows 10 64 bit.

I have figured a way to run the game on Hardware mode with some slight drawbacks, by using these general settings:
D3D 11 Renderer. Aggressive CRC Hacks.
HW Hacks: Half Pixel, Align Sprite, Alpha. Skipdraw 1 for Planets and Deadly Gas challenges ONLY. Any higher breaks textures.

SpeedHacks: Standard mVU Flag, MTVU, Spin, Wait Loop. EE Cyclerate at -2, Cycle Stealing at 0. Cycle stealing causes the audio to not catch up to the rest of the game and provides apparently no benefits on my system.

For some video of these results, check out my Coub Below. The first 5 or so seconds are of the game in Software Mode D3D11, and the rather bloomtastic footage in the other half of the video is the game in Hardware mode with the settings above. Here is the link:                       http://coub.com/view/cllt5      

The Good news, the game runs at a somewhat manageable speed in Hardware mode on planets. The bad news, the bloom goes off of the charts with a skipdraw of 1. A skipdraw of 0 leads to massive colored bars that wholly obscure the screen.  In the video, I switch between Skipdraw at 1, at 0, and back again.           http://coub.com/view/cl6q7
By the way, check out the rest of my Coubs if you like!

Obviously, I want to make the best of the framerate granted to me in Hardware Mode, but the bloom effects obscure a lot of the action. Does anyone know how to disable or suppress bloom effects completely without the use of skipdraw?

As a mild glimmer of hope, during a landstalker challenge there was a small area where all bloom effects disappeared completely. I was quite excited until I realized that only happened when I angled my view downward in a very specific spot.

I really hope you guys can find a solution to my problem! be sure to check out my other Coubs of my PCSX2 Gameplay!
Thanks!

Hopefully, with more eyes on the issue, perhaps more people can put whatever answers come up to good use!
Reply

Sponsored links

#2
Are you sure you didn't enable the bloom secret?
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply
#3
(05-29-2016, 06:05 AM)Nobbs66 Wrote: Are you sure you didn't enable the bloom secret?

I have just started out on the game. Check out my Coubs for the details of the graphical errors. I do not have that cheat yet.
Reply
#4
What version of PCSX2 are you using?

You might want to try updating to one of the newer git builds of PCSX2 - I tried the same set of hacks you're using with a recent build and I don't get the massive bars all over the screen with Skipdraw set to 0: http://i.imgur.com/dRGnGc0.jpg
(the bright bar on the left is caused by the half-pixel hack, which is used to fix bloom alignment everywhere else in gameplay)

After updating you might get better performance using OpenGL (hardware) instead of Direct3D 11 (hardware). Testing the cutscene from the above screenshot (with frame limiting disabled), I get ~50% to 100% (!!!) better performance with OpenGL.
If you get a similar boost you might want to set the EE Cyclerate back to default, I think it having it on -2 actually causes some slowdown in certain scenes.

I think the Aggressive CRC, Align Sprite and Alpha Hacks may be unnecessary.
Textures will be at least partially broken in hardware mode no matter what settings you use.
Windows 7 Home Premium 64-bit | Intel Core i7 4770 @ 3.4GHz | Gigabyte GeForce GTX 770 OC 4GB
Corsair Vengeance 16GB DDR3, 1866MHz @ 9-9-9-24 | 256GB Samsung 840 Pro | 1TB 7200RPM WD Black


Reply
#5
Thank you for the response! I have the standard PCSX2 1.4.0 at the moment.

By the way, align sprite and Alpha were there just to clean up the sprites on the screen, but Aggressive crc was there to mildly improve performance.

I will in the next couple of days try and update PCSX2 and report back the results!
Reply
#6
Upon testing the game with the in development version of PCSX2 1.5.0, The odd bloom effects have been successfully countered with the use of the newest version of D3D11! Hooray!

I have done some testing with Using OpenGl Hardware mode using the standard version of 1.4.0, just to check some stuff out, and I have had simultaneous success and failure.

http://imgur.com/a/Hutyl

Using Open GL as the Hardware renderer has eliminated the overblown bloom effects, but the moment the game is put into a menu, once the menu closes, disaster strikes!

All world textures decide not to exist, and no matter what mode I change the game to, the world textures remain missing. the only way to fix this was to reload a save state.


here is the console log for the 1.5 development version ( I really need to know how to create a spoiler tag for this) : If the line was in red, I highlighted it the same here.
MTVU speedhack is enabled, saved states may not be stable

Saving GS
Saving PAD
Saving SPU2
(gzipThread) Data saved to disk without error.

Suspending single plugin: GS
(AT THIS POINT THE TEXTURES BREAK AS I LEAVE THE PAUSE MENU)
Saving GS
Closing GS

Option Interlace doesn't have a default value
(NOW SWITCHING TO VARIOUS MODES BOTH HARDWARE AND SOFTWARE TO SEE IF ANY REPLACE THE MISSING TEXTURES. NONE DO.)
Recovering single plugin: GS

Opening GS
Current Renderer: Direct3D11 (Hardware mode)

Option UserHacks_DisableGsMemClear doesn't have a default value

GSdx Lookup CRC:9BFBCD42
Loading GS
Frame buffer size set to 512x512 (2048x2048)

Suspending single plugin: GS

Saving GS
Closing GS

Option Interlace doesn't have a default value

Recovering single plugin: GS

Opening GS
Current Renderer: Direct3D11 (Software mode)
GSdx Lookup CRC:9BFBCD42
Loading GS

Suspending single plugin: GS

Saving GS
Closing GS

Option Interlace doesn't have a default value

Recovering single plugin: GS

Opening GS
Current Renderer: OpenGL (Software mode)

3.x GL context successfully created

OpenGL information. GPU: GeForce GTX 780/PCIe/SSE2. Vendor: NVIDIA Corporation. Driver: NVIDIA 362.00
INFO: GL_EXT_texture_filter_anisotropic is available
INFO: GL_ARB_gpu_shader5 is available
INFO: GL_ARB_draw_buffers_blend is available
INFO: GL_ARB_viewport_array is available
INFO: GL_ARB_shader_image_load_store is available
INFO: GL_ARB_clear_texture is available
INFO: GL_ARB_get_texture_sub_image is available
GSdx Lookup CRC:9BFBCD42
Loading GS

Suspending single plugin: GS

Saving GS
Closing GS

Option Interlace doesn't have a default value

Recovering single plugin: GS

Opening GS
Current Renderer: OpenGL (Hardware mode)

Option UserHacks_DisableGsMemClear doesn't have a default value

3.x GL context successfully created

OpenGL information. GPU: GeForce GTX 780/PCIe/SSE2. Vendor: NVIDIA Corporation. Driver: NVIDIA 362.00
INFO: GL_EXT_texture_filter_anisotropic is available
INFO: GL_ARB_gpu_shader5 is available
INFO: GL_ARB_draw_buffers_blend is available
INFO: GL_ARB_viewport_array is available
INFO: GL_ARB_shader_image_load_store is available
INFO: GL_ARB_clear_texture is available
INFO: GL_ARB_get_texture_sub_image is available
GSdx Lookup CRC:9BFBCD42
Loading GS
(end of Console Log)


I have now tried this with the latest development edition of 1.5.0, and the results are the same, great performance (even better than 1.4 and with less glitch messes) but when you use a menu all world textures break for any mode of PCSX2 that you are playing in.

Thank you for your help so far! you have brought me great hope in getting this great game running!
Reply
#7
(05-29-2016, 07:22 PM)KilledAlive Wrote: http://imgur.com/a/Hutyl

Using Open GL as the Hardware renderer has eliminated the overblown bloom effects, but the moment the game is put into a menu, once the menu closes, disaster strikes!
All world textures decide not to exist, and no matter what mode I change the game to, the world textures remain missing. the only way to fix this was to reload a save state.

I tried a few different things and found that enabling the "Disable Depth Emulation" hack seems to prevent that glitch (although it won't fix it if it has already occurred).
Note this could cause different glitches in other parts of the game (hopefully not as game-breaking as this one).
Windows 7 Home Premium 64-bit | Intel Core i7 4770 @ 3.4GHz | Gigabyte GeForce GTX 770 OC 4GB
Corsair Vengeance 16GB DDR3, 1866MHz @ 9-9-9-24 | 256GB Samsung 840 Pro | 1TB 7200RPM WD Black


Reply
#8
Could someone generate me a gs dump of this depth issue? I want to give it a look if I saw some errors in my openGL logging (but don't expect any fix).

By the way, I fixed the error message on the options.
Reply
#9
Here you go: https://drive.google.com/open?id=0B1YCSl...lpSY1hHamM (switched to Google Drive instead of the pop-up filled MediaFire)

Taken shortly after exiting the in-game menu.
Windows 7 Home Premium 64-bit | Intel Core i7 4770 @ 3.4GHz | Gigabyte GeForce GTX 770 OC 4GB
Corsair Vengeance 16GB DDR3, 1866MHz @ 9-9-9-24 | 256GB Samsung 840 Pro | 1TB 7200RPM WD Black


Reply
#10
Thanks for so much support for such a strange and specific issue for Deadlocked on OpenGL. I really hope that bringing this issue up will prevent this issue from being a problem for other people.

Just to give a quick update regarding my performance using the Git build of PCSX2 1.5.0, here is a general report on how well it is running.
As for me, I am both playing the game and recording important and funny cut scenes for posterity using fraps. So it is part of my job to have to ensure whatever I am recording plays at full or nearly full speed while the extra load of fraps is placed onto my computer.
For Gameplay, using Cycle Stealing works best for frantic gameplay, usually about 1-2 is preferable for play and recording.
For cut scenes however, using Cycle Stealing is not preferable for recording. Cycle stealing makes the audio run far ahead of the images during recording. So keeping Cycle at zero is preferable in that situation, boosting the EE Cycle-rate is preferable to prevent the audio from running off while providing pretty comparable performance boost to cycle Stealing otherwise.
Thank you once again for tackling this issue!
Reply




Users browsing this thread: 1 Guest(s)