Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How to get constant 60FPS?
#1
v0.9.8 Windows

I'm wanting to play Disgaea (USA), my computer far exceeds the requirements and I've changed the NTSC framerate setting to 60.00FPS (via the ini, I expect someone will say that breaks a lot of games hence why it's grayed out in the interface).

When I go to play my game the frame rate hovers between 59.94 and 60.08, never a constant 60FPS which is kinda needed when using Vsync to avoid unnecessary stutter.
Computer specifications:
Windows 10 x64 | Intel Core i7 @ 2.66GHZ | ASUS P6T | Gigabyte Windforce x3 Geforce  760 4GB | 8GB DDR3 1600MHZ RAM | Integrated Audio
Reply

Sponsored links

#2
vsync doesn't prevent stutter
vsync should not be needed to be enabled on windows 7 or vista with DWM running.
Reply
#3
Vsync can actually kill the chances to run near 60FPS since it delays the frame drawing until it can do together with the monitor's refresh rate. That mean if the application can't reach the refresh rate the FPS is capped, some times as low as half the refresh rate value (commonly 30FPS).

What Vsync prevents is image tearing, not stuttering indeed. If you experiment something like this it may be the wrong interlacing or lack of it. Two ways to solve the image shivering problem is cycling the several interlacing methods using the F5 key... a permanent solution is choosing the method that is better for you under the GSDX plugin config window (commonly the "blend bff" option).

PS: Now, the FPS around 59.4 and 60.8... sorry but that brought a smile to my face. That's OK, you should not be concerned with that variation, if you are seeing any actual problem it might be that shivering effect pointed above.
Imagination is where we are truly real
Reply
#4
I said a consistent 60fps would eliminate the stutter hence my request for a way to have consistent 60fps and I was expecting it to work with Aero even with Vsync disabled but I also thought the emulator might have a way of overriding it and using it's own implementation etc. hence my testing with the functionality both dis/enabled.

Yeah I know what Vsync is for and I can not stand screen tearing at all. The image doesn't shift or move every other frame which is why I ignored the interlace settings (The ATLUS logo stays perfectly still).


Like I said, framerate doesn't get quartered/halved as my computer can play the game full speed, it's just the lack of a consistent frame rate that killing my experience.
Computer specifications:
Windows 10 x64 | Intel Core i7 @ 2.66GHZ | ASUS P6T | Gigabyte Windforce x3 Geforce  760 4GB | 8GB DDR3 1600MHZ RAM | Integrated Audio
Reply
#5
I fear your request will not even be taken into account at this point, the fluctuation you are seeing is due to the recover time from the frame limiter and you are the first person I know to be bugged by that variation rate until now.

Whatever is giving that "stuttering", I bet it is not what you think. At this point you should go to the ini file and return the NTSC value to 59.94, it is a TV standard for NTSC and internal timing is dependent on it, it was grayed for a reason. Besides, that option don't limit or force FPS at all and you just messed the internal timings a bit.

And try at least to follow recommendations, even if just for the experimentation sake... the interlacing is expected since it's TV feature which the console follows and the games too, unless stated the game can do progressive scan. I don't know what you are calling stutter but is possible it is just the shaking due to lack of the expected interlacing.

If still a problem you can't stand it, you are out of luck.

I did not tell your FPS is capped, it would be a surprise if it did with such easy game... things may change when trying another....
Imagination is where we are truly real
Reply
#6
Hmm k, upon looking into it further it looks to be an exact duplicate of this issue which Ver Greeneyes managed to resolve with a very awesome custom Direct3D driver. A work around to this issue is to use a Aero Basic/non DWM display mode and enable Vsync in the emulator but Windows 7 has the fugliest borders and title bars in Aero Basic D:
Computer specifications:
Windows 10 x64 | Intel Core i7 @ 2.66GHZ | ASUS P6T | Gigabyte Windforce x3 Geforce  760 4GB | 8GB DDR3 1600MHZ RAM | Integrated Audio
Reply
#7
(06-23-2011, 07:22 AM)Franpa Wrote: I said a consistent 60fps would eliminate the stutter hence my request for a way to have consistent 60fps and I was expecting it to work with Aero even with Vsync disabled but I also thought the emulator might have a way of overriding it and using it's own implementation etc. hence my testing with the functionality both dis/enabled.

Yeah I know what Vsync is for and I can not stand screen tearing at all. The image doesn't shift or move every other frame which is why I ignored the interlace settings (The ATLUS logo stays perfectly still).


Like I said, framerate doesn't get quartered/halved as my computer can play the game full speed, it's just the lack of a consistent frame rate that killing my experience.

Yeah dude, people here help you for free. You should probably relax on that tone

And lol, to be completely honest, you're complaining about an insignificant frame rate difference, crying about it like a lil baby, grow up dude
Reply




Users browsing this thread: 1 Guest(s)