Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How to increase the speed?
#1
My laptop spec :
Operating System = Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bit
Physical RAM = 4006 MB
CPU name = Intel® Core™ i5-2430M CPU @ 2.40GHz
Vendor/Model = GenuineIntel (stepping 07)
CPU speed = 2.393 ghz (4 logical threads)
Video Card = Nvidia GT540M

I'm using Pcsx2 0.9.9.5347 (svn), enabled the option as below :
Speedhack : Everything is enabled except fast CDVD
Video : [SSE2] Gsdx9 Hardware with Native enabled, texture filtering unchecked, allow 8-bit texture checked.

The game I'm trying to play is Fate Unlimited Code, it's average Fps is around 20~25 fps, is there anything I should know or do to increase the Fps?
Reply

Sponsored links

#2
first use SSE4 instead of SSE2 and D3DX11 Hardware as a render
Reply
#3
I don't have D3DX11 as the option, does it mean that I don't have Direct X 11? If that's so I'll go download it.
Reply
#4
hmm that's weird are you sure you're using the GT540 instead of the internal one Intel HD3000 !!!

because the second one don't support DX11 Sad ( and that might be the problem since it's MUCH weaker )
Reply
#5
Yup, I checked the Device Manager and under the Display Adapters it shows NVIDIA GeForce GT 540M. Intel ® HD Graphic Family is showed there too if that matters.
Reply
#6
Make sure the dedicated GT 540M is used in PCSX2, not the HD 3000. You can set it in Nvidia Control Panel.
Intel Core 2 Quad Q9400 | nVidia GeForce GTX 750 | 4 GiB DDR3 @ 533 Mhz | MSI G41M-P28 | Cooler Master RS-390-PMSR-A3 | Xigmatek TYR SD962 | LG Flatron W1943SE | HP KB-0316 | MotoSpeed F60
Reply
#7
well i don't know how i can figure out if you're really using the External or the internal one but GTX 540 support DX11 and as a result D3DX11 render should be there ...

and the whole slowdown issue can result that you're ( or PCSX2 ) is using HD3000 instead ...
Reply
#8
I added Pcsx2 to Program Settings in Nvdia control Panel, and set the settings to High Performance Nvidia processor. The fps speeded up to 40~45 fps. Is there any other method to increase it further more?
Edit: Just saw D3D11 option is available now! Trying now...
Edit 2: It's around 55~60 fps, is it normal?
Reply
#9
that's a big increase you should be happy with it Smile

you got a playable speed Laugh

well i don't know the game if it's apropirate or not ...

but since it was a GPU bottleneck enable frame skipping in :

Config < Emulation settings < GS < tick enable Frame skipping


set 2 to Skip 2 to draw Smile


if the game become buggy just disable it ....
Reply
#10
Thanks a lot, at least it's not laggy anymore. Smile
Reply




Users browsing this thread: 1 Guest(s)