Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
I can't change some of my settings
#1
I have a weird problem. I can change some settings, like changing the plugins or Emulation settings, controls and settings in sound plugins. But I can't change anything in graphic plugin and in CDVD plugin. In Gdsx, when I'm trying to change anything and I'm pressing OK, everything goes back to default, so my settings are not saved. In CDVD plugin I can change the selector: Iso, plugin or Null, but I can't change my dvd drive - it's set to @ [No Disc] and I can't change it to my drive, the settings are coming back to default. I've bought the original game, so I have to run it from my dvd drive. The isos work good.
When I'm running as the administrator, everything is fine - I can change what I want without any problems. The emulator is outside Program Files folder. I can't run this program as an Administrator in my default account, because I'm getting an error. So if I want to play anything, I have to change my account and log in as an administrator every time, it's a little uncomfortable. Is there any way to save these settings on my default account?
I'm using this version: PCSX2 0.9.7 (r3878), I have WinXP SP3.
Reply

Sponsored links

#2
If it works with "run as admin" it indicates you have placed it in a protected folder(not just program files). Try placing it in C:\PCSX2 for example and if you still have a problem post back with results. Also its recommended you rip your dvd to an iso(with imgburn for example) and use either linuz plugin or the internal iso loader.
Specs:
CPU: C2D E8400 @ 3.6
GPU: GTX 560Ti 2Gb
MOB: Asus P5QL
RAM: Crucial 4Gb
OS: Windows 7 64bit/XP 32bit
Reply
#3
Yea, I have it already in C:\PCSX2 and it's still the same. I know that I can make an iso from it, but I would prefer to play from the dvd. When I'm on my Admin account, I can play from dvd without any problems.
Reply
#4
Are you using your custom location for the PCSX2 settings, or did you leave that on default (which is "My Docs")? With the GSdx and CDVD plugin, it sounds like it's not letting you save changes to the inis or something.
Reply
#5
I've left it default in My docs. Should I change it?
I searched for the CDVD settings in inis to change it manually, but I can't find the drive letter settings.
Reply
#6
Well, I'm pretty sure that's your problem. I would use your custom location for everything, and avoid the need to "Run as Admin".

If you locate the cdvdGigaherz.ini file, it should look like this:

Code:
[Config]
Source=@

Just insert the ROM's drive letter like this:

Code:
[Config]
Source=D
Reply
#7
It worked, thank you. I changed the inis folder to C:\PCSX2\inis and now I can save my settings.
Reply
#8
Albeit the problem is solved, there is something which can be added, keeping the ini, save and any other control file inside the Documents folder is not problem, unless the folder was already compromised by "bad practices" beforehand.

What must be avoided at all cost is installing (and running) applications in there, mainly games.

As prompted by Rezard: The "correct", not only for PCSX2 as any games, PC native or otherwise, is installing from the beginning under a user created folder, like the OP did (apparently not soon enough). Sadly the C:\Program Files (x86) is the "default", avoid it, keep distance of these folders since they almost always cause access right problems.

Any user created folder is enough to avoid the problem, it can be something like C:\Games or another partition or disc, like D:\Games\... or E:\Anyname\... the actual name does not matter.

Imagination is where we are truly real
Reply




Users browsing this thread: 1 Guest(s)