Thread Rating:
  • 2 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
I think my PC is not performing very well after removing some RAM
#1
I found out 2 of my 4 RAM modules were defective, so I have to RMA them, but anyway, does system RAM affect PCSX2 performances? I had 4Gb before, and I remember FFX working really well, now I tried it out of curiosity and the intro is so slow, and the game performs worse than I remember. I'm using the latest beta with every speedhack enabled (except VU cycle stealing, that didn't even existed when I first played FFX on this emulator), the game runs at about 45 or so during the intro cutscene. Could this problem be related to having only 2GB of system memory? I'm using the latest beta (no difference using the latest "stable" version), GSDX (latest), and SPU2X. My system specs are in sig.
Intel Core i5 3570K | Gigabyte GTX560Ti 448 | 8Gb Corsair Vengeance DDR3 | AsRock Z77 Ex4 | Windows 7 x64
Reply

Sponsored links

#2
It depends really. On Windows XP, 2 gigs should be plenty to run it, but with vista/7, its using up quite a bit of it, therefore the missing RAM could definitely be hurting you.
Reply
#3
I'm on Vista 64 (it's in my sig), so that could indeed be the problem. How well does FFX work on a PC similar to mine (with 4Gb)? Maybe I had problems back then too and I forgot about them. Another game that seems to be running really bad is Soul Calibur 3, I always had some graphical problems with it, but now it runs horribly, basically I can't get it to run better than 20FPS without setting VU cycle stealing to max (same with Shadow of the Colossus).
Intel Core i5 3570K | Gigabyte GTX560Ti 448 | 8Gb Corsair Vengeance DDR3 | AsRock Z77 Ex4 | Windows 7 x64
Reply
#4
i have 2 gb of ram and 64 bit windows 7 and my highest fps was hitting 200 fps, the only place where i got fps under 100% was in the Mi'ihen Road i think, gigantic map, alot of npcs and you could see everything in a single moment.
Check my profile for hardware/software and games i played on PCSX2.
Reply
#5
No, if you have 2 GB of ram they are more than enough for PCSX2. Except if you have god knows how many processes running, eating away about 1 GB of ram (is that even possible?) My RAM usage is maxed at 800mb / 2GB on Windows 7 with PCSX2 running.
[Image: newsig.jpg]
Reply
#6
Your RAM modules are in the right slots for dual channel memory usage, right? Two GB should be more than enough for PCSX2, unless you're running some really memory hungry background tasks. Or running some game where GSDX eats up an insane amount of memory.
Reply
#7
Vista(Well not actually all of vista, Firefox is really sucking up ram like it always does for some awful reason) is using 1.5GB right now. It normally uses a little more than this, like 1.7GB on vista 64bit while running the programs I run. Most of the usage due to firefox though.
Reply
#8
As you can see PCSX2 uses one of the cores to 100%, the ram is not being used up to 100%, and the game in the intro cutscene slows down quite a lot. I have dual core enabled in PCSX2, shouldn't it use 2 cores to 100% each or something like that? I honestly don't remember what happened back then, but I don't remember it overloading a single core either. I don't have a lot of processes using up ram, as you can see most of it is free (check my sidebar monitor thingy). Is there anything wrong?

http://img524.imageshack.us/i/asdzf.jpg/

Edit: I just tried to disable multi threaded mode, and I noticed that there is no difference in core usage for some reason, one core gets overloaded and the others not. I lose about 10 FPS in the same scene if I disable it though. I don't think this is normal, I mean, shouldn't it use 2 cores to 100% if I enable MT mode?
Intel Core i5 3570K | Gigabyte GTX560Ti 448 | 8Gb Corsair Vengeance DDR3 | AsRock Z77 Ex4 | Windows 7 x64
Reply
#9
Huh? You have 4 cores,so PCSX2 is distributed evenly on them (except for core 0). You have 100% and x3 32%, sounds about right. PCSX2 is using 50% of your CPU power since it can only use up to 2 cores, so 50% of a quad core == 2 cores.
If you're using speed hacks,disable them. Also use the latest released beta (1736)

(BTW what is that widget? Looks nice Tongue )
[Image: newsig.jpg]
Reply
#10
I knew there was something wrong, I just tried booting up Win7 RC, and running the same emu, same setting and everything, there is no slowdown at all in that scene. I wonder what's wrong with Vista, the emulator used to work great, now every game is slowed down!

http://img29.imageshack.us/i/asd7.png/

It says 56FPS probably because it dropped a bit when I started mashing the stamp button to take a screenshot, I tried multiple times and it was always 60 in that scene.

The 100% core happens in 7 too so that's not the problem.

By the way, the widget is called Multimeter, you could find it easily on google, I'm using a custom config, I can send it to you if you want (it's just an ini file).
Intel Core i5 3570K | Gigabyte GTX560Ti 448 | 8Gb Corsair Vengeance DDR3 | AsRock Z77 Ex4 | Windows 7 x64
Reply




Users browsing this thread: 1 Guest(s)