Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
I5 2500k throttling down using PCSX2
#1
Hi, many thanks for v1.0, great emulator that just got much better.

Having just upgraded from a Q8400, 8Gb DDR2, Asus P5QL, GTX 260, Win 7 - which ran PCSC2 rather nice, except in demanding games I had to lower gfx levels - I now have the following.

I5 2500k, 8Gb DDR3 Kingston, Gigabyte GA-Z77X-UD5H, GTX 560ti 1Gb, SSD M4 128Gb, Windows 7 Ultimate.
The I5 is overclocked to 4.5Ghz 1.3v, +0.050 offset (DVID), plus using all power saving options C1e - Speedstep, etc..The CPU idles at 1.6 Ghz, 1.0v 32c, and jumps upto 4.5ghz 1.300v and hovers around 58c on emulators and games, and 72c when running Prime95.

The problem I have is this, when running PCSX2 v1.0, on any game - GT4 for example - the CPU throttles down to 1.6ghz causing massive frame dips, it then sporadically jumps around from 4.5 - 1.6 to 4.5 down to 1.6, and keeps doing this on any game, even the demanding ones like SOTC.

Of course, I would like to keep using power saving for surfing and idle times, but this is just driving me nuts. Regular PC games are fine, and the CPU stays at 4.5 for the duration of the games.

Is there any shortcut one can make to PCSX2 that will keep a CPU from throttling down ?

Or, anyone having any suggestions ?

Many thanks,

John.

Sponsored links

#2
Have a look at Throttle Stop, it should work for you Smile
http://www.xtremesystems.org/forums/show...ore-i-CPUs
ROG Asus G74S laptop
Intel core i7 2670QM @2.2(3.1ghz turbo) Nvidia 3gig GTX560m 8 gigs DDr5 Blue-Ray Burner windows7 64 bit
[Image: r1gyld.jpg]
#3
omnikam, many thanks for the link, that looks like a very useful program. Smile
#4
No probs mate, hope it works for you, although im sure it will
ROG Asus G74S laptop
Intel core i7 2670QM @2.2(3.1ghz turbo) Nvidia 3gig GTX560m 8 gigs DDr5 Blue-Ray Burner windows7 64 bit
[Image: r1gyld.jpg]
#5
Maybe you can fix the automatic behavior by selecting a different power saving plan in windows.
It really shouldn't do what you're describing.
#6
(08-06-2012, 12:30 AM)omnikam Wrote: Have a look at Throttle Stop, it should work for you Smile
http://www.xtremesystems.org/forums/show...ore-i-CPUs

i guess that at end "all roads lead back to pcsx2 forum" Smile)
And regarding to issue at hand

Yes it should not be happening ,but it is happening.
And this is why:
BD PROCHOT stands for bi-directional prochot. PROCHOT stands for processor hot which is the signal that is activated within the CPU when it reaches approximately 100C to 105C depending on the model number. This signal is what initiates thermal throttling so the CPU can slow down and keep from over heating. Intel included a bi-directional feature so if something else like a GPU is running too hot, it would be able to send a PROCHOT signal directly to the CPU and force it to cool down so the entire laptop cools down. Very few laptops seem to use this type of throttling. This feature was added for the Asus G51. Disabling this will allow your CPU to continue to run at full speed. Disabling this will not prevent your CPU from thermal throttling at its normal Intel set thermal throttle temperature. By default this is locked and you will need to go into the Options window to unlock it so you can toggle it on and off.

If i am to be asked this is maybe smart thing BUT it has crucual flaw ..bios doesn't have that option to disable or enable and its NOT suppose to be existing on desktop PC's only for laptops!!

so what happens is that...if your gpu is running ~70C which almost any gpu will nowadays it will send instruction to cpu to throttle down resulting in cpu speed downclocking to 1.6ghz and killing the game ...ofc.. C1E and EIST should also be disabled for that profile (performance) example switch to another profile when not gaming

That's the only thing that is needed by this tool and is a hell of a good option to have..
Its just anoying that it took me half a year of googling with no real answer untill i readed this topic and post

Thanks and Kudos to you!
#7
In a way you got the answer, the downclocking is a power saving feature, it happens at CPU level, BIOS level and OS level. For some reason the combination Intel + Windows power saving fails to notice the CPU is being hardly demanded and sit down as it is almost unloaded (what causes the downclocking).

That's more common when EE is showing around 100% amd GS is almost iddle, that could reflect as a low average load leading to that downclock which would feedback increasing yet more EE stalling and GS being each time idler.

Putting Windows in a performance power plan is enough in most cases. On the other hand that is most common in laptops, maybe yours is a different case but let's start from experimenting with the power plan.

Edit: Notice EE % gauge is an indicator on how much EE is taking from the "available" CPU power, if the CPU is downclocked and fails to get at nominal speed or even to boost, this will make EE using almost 100% of that "seen" CPU power.
Imagination is where we are truly real
#8
Also shouldn't the OP turn off Speedstep if that still exists on Notebooks/Laptops that is. I thought that's a quite ancient function heh.
#9
turn off speedstep, If your on laptop i can understand using it but desktop. I would never use it
#10
(06-11-2013, 12:45 AM)StriFe79 Wrote: Also shouldn't the OP turn off Speedstep if that still exists on Notebooks/Laptops that is. I thought that's a quite ancient function heh.

Being unused to Intel I didn't ever recall that option exist, now at the database, thanks for the info.
Imagination is where we are truly real




Users browsing this thread: 1 Guest(s)