Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ISO crashes upon launch
#1
Hi there,

First post here, I've read Kaze's installation/troubleshooting FAQ and I have uninstalled/installed PCSX2/XQuartz the portaudio and plugins etc. a few times each but I'm unable to manage to get a game to run.
I have also done a few searches in this forum to look for similar issues with resolutions but haven't been able to find any suggestions that resolve my issue.

I can install everything okay and I can get the window for PCSX2 to come up but every time I run an ISO, it crashes and I get a generic mac Problem Report highlighting that PCSX2 has quit unexpectedly.

Any help would be appreciated - I'm hoping that it's a glaringly obvious mistake on my part.

I'm using:
MacBook Pro (Retina, 13-inch, Mid 2014)
Processor 2.6 GHz Intel Core i5
Memory 8GB 1600 MHz DDR3
Graphics Iris Intel 1536 MB

Here is the transcript from XQuartz:

 F1 - save state
        (Shift +) F2 - cycle states
        F3 - load state
PCSX2 beta (r2620254) - compiled on Jan 27 2011
Savestate version: 8b410001
EE pc offset: 0x2a8, IOP pc offset: 0x208
x86Init:
Features:
Loading plugins...
        Loading GS...
        Loading PAD1...
        Loading PAD2...
        Loading SPU2...
        Loading CDVD...
        Loading DEV9...
        Loading USB...
        Loading FW...
Plugins loaded successfully.
Resetting...
Ready
Initializing plugins...
Plugins initialized successfully.
 * CDVD Disk Open: DVD, Single layer or unknown:
 * * Track 1: Data (Mode 1) (2210704 sectors)
Bios Version 1.0
Framelimiter rate updated (UpdateVSyncRate): 59.94 fps
Opening Plugins...
Notice: GS Plugin does not implement GSsetFrameLimit.
MTGS > Thread Started, Opening GS Plugin...
ZZogl: Using ZZ Ogl :0.21.213
ZZogl: creating zerogs
ZZogl: Got Doublebuffered Visual!
ZZogl: glX-Version 1.4
Plugins opened successfully.
loadElfCRC: cdrom0:\SLPS_250.88;1
loadElfFile: 4730008 bytes
loadElfFile: cdrom0:\SLPS_250.88;1; CRC = 658597E2
XML Loader returned an error. Trying to load a pnach...
No patch found.Resuming execution without a patch (this is NOT an error).
ZZogl: Disabling MRT depth writing
Issuing EE/iR5900-32 Recompiler Reset [mem/structure cleanup]
vtlb/mmap: Block Tracking reset...
iR3000A Resetting recompiler memory and structures
* PCSX2 *: ExecuteBios
# Initialize memory (rev:3.17, ctm:393Mhz, cpuclk:295Mhz )
Xlib:  extension "XFree86-VidModeExtension" missing on display "/private/tmp/com.apple.launchd.EzpDnr65Bu/org.macosforge.xquartz:0".
# Total accessable memory size: 32 MB (B:2:8:0)
# TLB spad=0 kernel=1:12 default=13:30 extended=31:38
# Initialize Start.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize User Memory ...
ZZogl: Depth 24
ZZogl: you have Direct Rendering!
ZZogl: Using multitexturing
ZZogl: Maximun texture size is 16384 for Tex_2d and 16384 for Tex_NV
ZZogl: Disabling MRT depth writing
ZZogl: Fill bilinear blocks failed!
ZZogl: Creating effects
# Initialize Scratch Pad ...
# Initialize Done.

EE DECI2 Manager version 0.06 Dec 10 1999 17:48:37
  CPUID=2e20, BoardID=0, ROMGEN=2000-0117, 32M

ZZogl: Creating extra effects
ZZogl: using full shaders
ZZogl: initialization successful
# Loader 'rom0OhmySDSYS'Tongue2c=00200008
Issuing EE/iR5900-32 Recompiler Reset [mem/structure cleanup]
vtlb/mmap: Block Tracking reset...
* PCSX2 *: ExecuteBios Complete
loadElfFile: cdrom0:\SLPS_250.88;1
Loading from a CD rom or CD image
loadElfFile: 4730008
ElfProgram different load addrs: paddr=0x02000000, vaddr=0x00000000
addr 12608 "rom0OhmySDSYS" -> "cdrom0:\SLPS_250.88;1"
addr 12d70 "rom0OhmySDSYS" -> "cdrom0:\SLPS_250.88;1"
addr 1e558 "rom0OhmySDSYS" -> "cdrom0:\SLPS_250.88;1"
addr 89580 "rom0OhmySDSYS" -> "cdrom0:\SLPS_250.88;1"
loadElfFile: cdrom0:\SLPS_250.88;1; CRC = 658597E2
XML Loader returned an error. Trying to load a pnach...
No patch found.Resuming execution without a patch (this is NOT an error).
Opening Plugins...
Plugins opened successfully.
ZZogl: Disabling MRT depth writing
Offset 0xea0fccf0 invalid. Legit SIGSEGV. Aborting.
pcsx2.sh: line 2:  4935 Segmentation fault: 11  ./pcsx2

Many thanks

Sponsored links

#2
segfault errors is usually because your iso is damaged.
How did you dump it ?
using command line or disc utility ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
#3
(10-29-2015, 10:13 AM)jesalvein Wrote: segfault errors is usually because your iso is damaged.
How did you dump it ?
using command line or disc utility ?

Hey thanks for the reply man,

So try a different download?

Not 100% sure.

I launched the iso by clicking file>run iso image in the xquartz window...
#4
Our forum does not tolerate any kind of warez talk / discussion / links and no support will be given as such.
Read our rules,specifically rule #1. Thread closed.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go




Users browsing this thread: 1 Guest(s)