Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Intermittent Slowdown: All Games
#1
Recently started converting a laptop into a media pc after the screen broke.

it's a somewhat mid level gaming laptop running windows 7 with stats:
quad core intel core-i7 clocked at 2ghz (4 real, 8 virtual)
Discrete nvidia GeForce GT 555 M
and integrated Intel HD 3000
6 Gb DDR5 RAM


I've been adding emulator launchers to XBMC and they've all worked perfectly until i got to the ps2. I've got pcsx2 up and running properly or what i'm pretty sure is properly. i've read many of the guides and lurked to make sure i know what everything does and i've had the same problem in nearly every game i've played.

the games will run fine at 60 fps for a little while but then every few seconds for a couple seconds the fps will drop to around 30-40 and then return to 60 fps a couple of seconds later. this repeats and makes the games pretty unplayble. it's not a variable thing where the game will run somewhere between 40 and 60 fps but the EE and GS cores will jump up from 50-60% to nearly 100% load on both engines and the fps will drop.

i've done some profiling of it and the load on the gfx card never goes above 20% and my cpu never gets above around 45 % so i'm pretty sure they aren't being taxed to heavily.

Also this problem seems to be independent of resolution as it happens at both native resolution, 2x and 3x.

WHAT I'VE TRIED:
the newest stable build pf pcsx2(1.0) and the latest svn revision(r5730)
i've made sure that pcsx2 is using my discrete card(geforce GT 555M)
made sure i'm using the highest performance modes in my power management
checked for speed step settings in my bios
all manner of speedhacks
skipdraw up to 20
8-bit textures both on and off
ee-timing hack(for when all else fails)
windows classic theme
direct x 9 and 11 in hardware as well as software
graphics plugins SSE 2 through 4.1
agressive CRC and disable CRC (not at the same time)

Guesses:

the 555m in this laptop looks like it shares its vram with the integrated card but the load for both of them has never been close to the max(1024mb)

the times when it's running at 60fps are the outliers and theres some sort of turbo coming into effect that i don't know about(seems unlikely due to simmilar issues at higher resolutions)

there's some setting or issue with pcsx2 that i don't know about causing this problem on this specific system.(seems likely as i've been able to run pcsx2 without this problem on both more and less powerful machines)

i would post a screenshot of my config but given how many permutations i've tried it seems pretty useless.

is there anything i'm missing?
Reply

Sponsored links

#2
did you check if your CPU is heating using something like coretemp ?
because 2 ghz is low for pcsx2 and since I guess it's a mobile cpu, that won't help either.

Can you please post the emulog.txt after you run a game ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
Just tried software dx9 with 3 extra threads and it appears the intermittent slowdown is gone but i only get about 55FPS.
bumping it up to 4 threads gets me to 60FPS at native resolution.
so now i'm using nearly all of the 8 virtual cores at about 45% load, just to run pcsx2 at a pretty lame resolution so it's not really ideal.

so it appears that this is an issue with the hardware rendering. i'm using the latest drivers from nvidia(327.23). any ideas?
Reply
#4
(09-26-2013, 11:31 PM)deathsheep Wrote: Just tried software dx9 with 3 extra threads and it appears the intermittent slowdown is gone but i only get about 55FPS.
bumping it up to 4 threads gets me to 60FPS at native resolution.
so now i'm using nearly all of the 8 virtual cores at about 45% load, just to run pcsx2 at a pretty lame resolution so it's not really ideal.

so it appears that this is an issue with the hardware rendering. i'm using the latest drivers from nvidia(327.23). any ideas?

tried reading my post ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#5
CPU is indeed heating up heres log files

the first is from the software rendering and the second is from hardware rendering


Attached Files
.txt   emuLog.txt (Size: 4,42 KB / Downloads: 117)
.txt   emuLog (2).txt (Size: 2,92 KB / Downloads: 127)
Reply
#6
based on that config it looks like it's still selecting the integrated graphics. apparently my setting for that dissapeared. tried it again with proper settings and its using the 555M now. still having the issue however
Reply
#7
2 things :

1 - overheating is probably causing your CPU throttling down. Whether you find a way to cool it down, whether you try throttlestop (google it). That won't cool down your CPU, but will allow it to keep its speed constant. be careful, though. this can damage your CPU

2 - from the emulogs :
Quote:Intel® HD Graphics 3000 (9.18.13.2723)
looks like your geforce 555M isn't used by pcsx2. You should use nvidia optimus to create a profile in order to make pcsx2 use it instead of the integrated crappy intel GPU

edit : ok, forget the second point since you figured it out.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#8
ok so i can't seem to get the nvidia settings to stick but thats a different issue.
Throttlestop was an excellent suggestion! found out my processor was throttleing back to about 700 megahertz thanks to intel's processor stepping. turning off EIST in Throttlestop(you also need to check off 'set multiplier') cleared up the problem and i've disabled the turbo on the processor as well to keep the heat down. hovering at about 75 C right now so i think i'll go buy a more powerful fan.

Thanks so much that was very helpful!
Reply
#9
also a little more dangerous but helpful is turning off BD PROCHOT which prevents the graphics card from sending a similar step signal that drops the clock speed.
Reply
#10
Btw buying a colling pad is better.
Pentium Dual-core G2010 2.8Ghz
RAM=4GB
nvidia GT 610
pcsx2 version-1.3.1  


Still surfing with Browser?, Try the pcsx2 forum App !
Reply




Users browsing this thread: 1 Guest(s)