Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Intermittent stuttering (CPU problem?)
#1
Hi again. I've been testing out my old PS2 games as a way of checking my computer build's capabilities. Thus far, I've gotten most of them to run just fine at high-quality settings - the exceptions are Zone of the Enders 2 (which was expected), Viewtiful Joe (unexpected, but apparently common), and the Ace Combat series (also unexpected). One problem has persisted, though, and I'm wondering what the cause could be.

When I'm playing, say, Onimusha 3, and I get into a battle, there will be occasional hiccups where the game simply hangs for a moment. It clears itself up within a beat, only to repeat a few seconds later. (It happens mostly at random, but using Jacque's hook-and-throw attack tends to trigger it fairly regularly.) I've tried fiddling with the graphics (resolution, hw/sw, DX9/11, etc.) and sound options, and the EE/VU settings, and so on and so forth, but no combination has gotten rid of that stutter. (This happens in my Kingdom Hearts tests as well.)

Any advice? Is my CPU just not up to snuff? Thanks very much, all.
CPU - AMD Athlon X4 750K @ 4.6GHz
RAM - 8GB DDR3 1600
GPU - AMD Radeon R7 260X (1GHz, 2GB GDDR5)
OS - Windows 7 64-bit

Base PCSX2 Settings:
PCSX2 Ver. - 1.2.1.r5873
Video Plugin - GSdx 5875 (MSVC 18.00, AVX) 0.1.16
Audio Plugin - SPU2-X r5830 2.0.0
Reply

Sponsored links

#2
are you playing from a disc or iso?
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply
#3
Ripped them into ISOs for the better load times. I'm loading them off the internal ISO loader.
CPU - AMD Athlon X4 750K @ 4.6GHz
RAM - 8GB DDR3 1600
GPU - AMD Radeon R7 260X (1GHz, 2GB GDDR5)
OS - Windows 7 64-bit

Base PCSX2 Settings:
PCSX2 Ver. - 1.2.1.r5873
Video Plugin - GSdx 5875 (MSVC 18.00, AVX) 0.1.16
Audio Plugin - SPU2-X r5830 2.0.0
Reply
#4
Can you look at the GS% and EE% readings during lags?

Which speedhacks do you use/have you tested?

An old cpu is always the easiest solution... but let's try to fix that without looking to much on the generation. And your clock speed is unexpected high.
Reply
#5
During battle (which is when this happens), EE can have 100% spikes, though it typically stays around the 50-60% range. GS% hovers around 40-50.

All four major speedhacks are checked (INTC, Wait loop detection, mVU hack, MTVU). No fast CDVD, no EE underclocking, no VU stealing. Automatic gamefixes, nothing manual.

As for my clock speed, I WAS surprised I managed to get it that high and stable. (It's 3.4 at stock, and at 4.7 it started dropping cores during AIDA64/Prime95 stress tests.) I'm considering lowering it, though, to see if that helps.

EDIT:

Widescreen patches applied as well. I disabled those, ran the game, same results.
CPU - AMD Athlon X4 750K @ 4.6GHz
RAM - 8GB DDR3 1600
GPU - AMD Radeon R7 260X (1GHz, 2GB GDDR5)
OS - Windows 7 64-bit

Base PCSX2 Settings:
PCSX2 Ver. - 1.2.1.r5873
Video Plugin - GSdx 5875 (MSVC 18.00, AVX) 0.1.16
Audio Plugin - SPU2-X r5830 2.0.0
Reply
#6
those 100%EE spikes are probably the problem.
Have you tested speedhacks? First all recommended ones. Then probably also MTVU.

Keep in mind that pcsx2 is like a benchmark for your processor. Make sure it runs stable at that clock.
Reply
#7
I've just tried it again with all combinations of speedhacks (excluding the EE/VU cyclerate sliders), and no dice. I'm going to run some stress tests to make sure it is or isn't my OC. (Last tests I performed ran overnight and everything was stable then, but when all other options are exhausted...)
CPU - AMD Athlon X4 750K @ 4.6GHz
RAM - 8GB DDR3 1600
GPU - AMD Radeon R7 260X (1GHz, 2GB GDDR5)
OS - Windows 7 64-bit

Base PCSX2 Settings:
PCSX2 Ver. - 1.2.1.r5873
Video Plugin - GSdx 5875 (MSVC 18.00, AVX) 0.1.16
Audio Plugin - SPU2-X r5830 2.0.0
Reply
#8
Stress tested for about two hours, no problems. Brought the CPU clock down to 4.5 just in case.

Tried tweaking the EE cyclerate, and the max setting seemed to help EE% numbers overall without doing any harm to the game (yet). Problem persisted.

Turned EE recompiler rounding to Nearest (was at default), and the problem went away for a short time, then returned. Not convinced it had any real effect, but game wasn't affected, so am keeping it at Nearest for now.

Have now disabled all speedhacks except for the previously-mentioned EE cyclerate. Problem persisted with and without them, and the game runs fine at 60fps without them. Or at least the bit I'm testing at, anyway.

I might just bear with it if I have to. It does make me curious, though, as I'm sure it's a sign of something off in my hardware configuration. Maybe bring the CPU clock down further? Hm...
CPU - AMD Athlon X4 750K @ 4.6GHz
RAM - 8GB DDR3 1600
GPU - AMD Radeon R7 260X (1GHz, 2GB GDDR5)
OS - Windows 7 64-bit

Base PCSX2 Settings:
PCSX2 Ver. - 1.2.1.r5873
Video Plugin - GSdx 5875 (MSVC 18.00, AVX) 0.1.16
Audio Plugin - SPU2-X r5830 2.0.0
Reply
#9
Is this problem game independent or only happening in Onimusha 3?
Reply
#10
Game independent. I've been using Onimusha 3 as the testing game, but the games in which I've had it happen:

- Kingdom Hearts
- Kingdom Hearts 2
- Kingdom Hearts 2 Final Mix
- Fatal Frame 2
- Soul Calibur II

The last of those, SCII, was running completely fine before this started happening. I put a solid amount of hours into it, unlocking all unlockables and completing all missions.

I'm gonna reinstall PCSX2, see if that helps at all. Will be back with an update.
CPU - AMD Athlon X4 750K @ 4.6GHz
RAM - 8GB DDR3 1600
GPU - AMD Radeon R7 260X (1GHz, 2GB GDDR5)
OS - Windows 7 64-bit

Base PCSX2 Settings:
PCSX2 Ver. - 1.2.1.r5873
Video Plugin - GSdx 5875 (MSVC 18.00, AVX) 0.1.16
Audio Plugin - SPU2-X r5830 2.0.0
Reply




Users browsing this thread: 1 Guest(s)