Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Is a T&L capable video card required?
#1
I've been trying to run Kingdom Hearts II: Final Mix, and I've been having some problems. For one, if I try using the Direct 3D 10 Plugin (Hardware), it practically crashes upon entering the menus for a New Game or Loading. The monitor goes black, comes back, I get a task bar notification about a video card, and the window for the game is black. I still hear the sound, though.

Trying something like Direct 3D 10 (Software) gets me to the menu and then some. The intro FMV is a bit laggy, but worse is the gameplay if I skip the FMV. The opening scene is incredibly slow, and after skipping that, we get to some gameplay, with laggy music and video.

I've tried so many different settings with that plugin, and I just don't know which I should choose. Is it my computer? I don't have a T&L capable video card, like you get from Nvidia or better yet, ATI.

Processor: Pentium Dual-Core CPU T4300 @ 2.10GHz, 2.10 GHz
RAM: 4.00 GB
System type: 64-bit Operating System
DirectX Version: DirectX 11

And going under the display tab in the DirectX diagnostic tool...

Name: Mobile Intel 4 Series Express Chipset Family
Approx. Total Memory: 1695 MB
DAC Type: Internal

I have no idea if my stuff is out of date or not, really. Is this laptop too out-of-date to be trying to run this properly? Do I need a better video card?
Reply

Sponsored links

#2
the 4 series consists of GMA 4500 and X4500
It has 10 SM4 shaders and a poorly implemented OpenGL 2.1

iirc, DX9 and higher devices do T&L Emulation via shaders, and DX9 shader partitioning (VS/PS) are emulated in the API on SM4 and up hardware. (nearly zero overhead)

The 4500 series does lack many D3D9/10 colour formats, which would explain the hardware mode crashing.
Reply
#3
T&L is phased out we are in the pixel shader era now.

btw pcsx2 doesnt want T&L it requires 2.0 pixel shader.

(07-23-2011, 06:25 AM)Kisai Wrote: I have no idea if my stuff is out of date or not, really. Is this laptop too out-of-date to be trying to run this properly? Do I need a better video card?

if your laptop is unable to tune-up your video card to Ati Radeon or Nvidia 4xx,5xx then you need to get a new/modern laptop soon.
Main Hub:i5-4670(3.4Ghz Factory Clocked),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
Reply
#4
Goddamn this crappy video card. It continues to fail me.
Reply
#5
Not only a better video card, but a better processor as well. I wonder why the computer manufacturer add a 4 GiB of RAM to a laptop with a Pentium E and an Intel GMA.
Intel Core 2 Quad Q9400 | nVidia GeForce GTX 750 | 4 GiB DDR3 @ 533 Mhz | MSI G41M-P28 | Cooler Master RS-390-PMSR-A3 | Xigmatek TYR SD962 | LG Flatron W1943SE | HP KB-0316 | MotoSpeed F60
Reply
#6
(07-23-2011, 06:42 AM)tallbender Wrote: T&L is phased out we are in the pixel shader era now.

btw pcsx2 doesnt want T&L it requires 2.0 pixel shader.


if your laptop is unable to tune-up your video card to Ati Radeon or Nvidia 4xx,5xx then you need to get a new/modern laptop soon.

Well, I'm told you can't upgrade stuff on a laptop. But I'd love to get an ATI video card for it. And it certainly supports 2.0 pixel shader.
Reply
#7
You can't replace an IGP with a discrette one. Check and see your motherboard has any PCIe x16. I'm sure it doesn't.
Intel Core 2 Quad Q9400 | nVidia GeForce GTX 750 | 4 GiB DDR3 @ 533 Mhz | MSI G41M-P28 | Cooler Master RS-390-PMSR-A3 | Xigmatek TYR SD962 | LG Flatron W1943SE | HP KB-0316 | MotoSpeed F60
Reply
#8
I'm... not sure how to check for that, honestly.
Reply
#9
If it's a laptop, you're out of luck.
Reply
#10
Updating drivers might fix the crashing.
Reply




Users browsing this thread: 1 Guest(s)