Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Is it possible to compile 32 bit pcsx2 on 64 bit ubuntu with sh command.
#1
I tried to but this happened

family@ubuntu:~/Emulators/PCSX2$ ls
bios docs help launch_pcsx2_linux.sh plugins
cheats GameIndex.dbf Langs pcsx2
f
amily@ubuntu:~/Emulators/PCSX2$ sudo sh launch_pcsx2_linux.sh
Error the script was directly 'called'
Use either /absolute_path/launch_pcsx2_linux.sh or ./relative_path/launch_pcsx2_linux.sh

family@ubuntu:~/Emulators/PCSX2$ sudo sh /absolute_path/launch_pcsx2_linux.sh
sh: Can't open /absolute_path/launch_pcsx2_linux.sh

family@ubuntu:~/Emulators/PCSX2$ sudo sh ./relative_path/launch_pcsx2_linux.sh
sh: Can't open ./relative_path/launch_pcsx2_linux.sh

family@ubuntu:~/Emulators/PCSX2$ sudo sh /relative_path/launch_pcsx2_linux.sh
sh: Can't open /relative_path/launch_pcsx2_linux.sh

family@ubuntu:~/Emulators/PCSX2$
Reply

Sponsored links

#2
If you had no errors in configure and build then I suppose it should be okay - although I'm surprised - I didn't think ubuntu was multi-arch yet...

Just curious: Why are you launching as sudo? Is this the normal way to call pcsx2 in ubuntu...?
Also don't think the output means you to literally type "relative_path" as a path Wink If you have already changed to the pcsx2 directory launch directory just type ./launch_pcsx2_linux.sh
Otherwise type (for example)
Code:
sh ~/pcsx2-read-only/bin/launch_pcsx2_linux.sh

Try launching as a normal user not sudo.

By the way, you could always use the packages Gregory has stickied in this forum.
Also on the pcsx2 googlecode page here is a wiki about pcsx2 on 64bit that might help you.

EDIT: I think you mean "is it possible to launch pcsx2 using the sh command...?" (not compile) compiling is a different issue altogether so you probably won't want the googlecode page. I'm not sure if you still need to use a chroot in ubuntu (ubuntu users feel free to help me out here) but I think all you need to do to find out is
Code:
cd [to your pcsx2 directory]
, then launch pcsx2 with
Code:
./launch_pcsx2_linux.sh
Reply
#3
./launch_pcsx2_linux.sh

/pcsx2: error while loading shared libraries: libwx_baseu-2.8.so.0: wrong ELF class: ELFCLASS64
Reply
#4
Okay, it doesn't like the 64-bit flavour of libwx, so I guess the answer to your question of "is it possible" is no.

You'll need to compile it in a chroot.
Check out these threads:

http://forums.pcsx2.net/Thread-PCSX2-for-Debian-Ubuntu

http://code.google.com/p/pcsx2/wiki/Chro...tatusLinux

http://ubuntuforums.org/showthread.php?t=1712017

The last thread gives instructions for installing pcsx2 in chroot in ubuntu.
Reply
#5
Yes it is possible to compile/run pcsx2 on ubuntu. But no it is not easy. It will be easier on ubuntu 11.10 (oneiric), and I hope it will be transparent from ubuntu 12.04. You need to manually install 32 bits library on /usr/lib32.

Anyway do not use sudo. It give you uneeded super user right.
Reply
#6
I'm having a similar problem in 64-bit 11.04 (Natty). I get the same error as the OP and I'm kinda new to linux, but comfortable with the terminal. How would I go about installing 32 bit libraries? Can I use sudo apt-get or when you say manually, do you mean download them and stick them in the /user/lib32 folder by hand?

edit: I have tried compiling and using the download on the download page for pcsx2, bot give me this error.

More information, I'm using terminal and I cd into pcsx2/bin and type
./launch_pcsx2_linux.sh
or
./pcsx2

both give me this error. I should have all dependencies installed, but I believe I may have installed the 64bit versions of the dependencies. I've tried to make a chroot in the past and it didn't seem to be working properly.

(08-25-2011, 07:37 PM)gregory Wrote: Yes it is possible to compile/run pcsx2 on ubuntu. But no it is not easy. It will be easier on ubuntu 11.10 (oneiric), and I hope it will be transparent from ubuntu 12.04. You need to manually install 32 bits library on /usr/lib32.

Anyway do not use sudo. It give you uneeded super user right.

Reply
#7
The easiest solution.
1/ upgrade to oneiric
2/ enable multiarch (normally done by default)
3/ To install 32bits library foo
sudo apt-get install foo:i386
If some 64 bits library are remove go to point 4
4/ copy the 32bits library (do not overwrite)
sudo cp /usr/lib/libfoo* /usr/lib32/
5/ reinstall 64 bits package that were removed
Reply
#8
I think I see why chroot is recommended as the solution to this. It probably has something to do with the crazy amount of unmet dependencies and a few other reasons. For several packages when I try to sudo apt-get install foo:i386 I'm met with messages telling me I need 1-7 packages that are not going to be installed and I have to try to go though and type all of them out and hope they don't have dependencies. Would it be easier/faster to use chroot, or is there a way to force apt-get to grab the dependencies when I tell it to install something?

(11-10-2011, 11:32 PM)gregory Wrote: The easiest solution.
1/ upgrade to oneiric
2/ enable multiarch (normally done by default)
3/ To install 32bits library foo
sudo apt-get install foo:i386
If some 64 bits library are remove go to point 4
4/ copy the 32bits library (do not overwrite)
sudo cp /usr/lib/libfoo* /usr/lib32/
5/ reinstall 64 bits package that were removed

Reply
#9
Well chroot can be easier. which package is blocking you? Normally apt will get dependency.

There is a script to test multiarch package on this tread : thread Can you run it and give me the output? I send some patches to fix several package for future ubuntu (namely wxwidget, portaudio, nvidia-cg-toolkit), but perhaps others are bad too.
Reply




Users browsing this thread: 1 Guest(s)