Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Is my cpu too *****? :/
#1
Hey guys.

I got a PS2 and such and quite a few games but I don't wanna look through all my stuff and hook it up again just to play a few games I'm missing. So I'm wondering if my cpu is too ***** to run this, cuz when I try to run something, either it's too fast, or it goes too slow, I can't seem to find the middle. lmao

Anyway my cpu specs are

AMD Phenom II X4 955 processor 3.20ghz
4gb Ram
ATI Radeon 5750 (DirectX 11) 1gb with 2.8 gb Available graphics memory (Dunno if that matters much)


I can only run the SSE2 plugin, damn you AMD... And I think that's whats killing me.
Reply

Sponsored links

#2
Laugh lol

No, dude, it's not complete crap.
There's just gonna be games that won't be able to reach and/or run at full speed (60fps for NTSC, 50fps for PAL).

If a game runs over full speed, use the Framelimiting option in Emulation Settings (under the GS tab), or toggle it by pressing F4 during gameplay. Smile

BTW - that extra 1.8GB of V-RAM is just additional RAM your GPU could barrow from your system's. It is pretty useless in this case.
Reply
#3
Dude works even though I'm a gamergirl. Tongue

Thank you Rezard for the hints, I've gotten Soul Calibur 2 to run pretty good at least if nothing else, which was the main game I wanted to "relive". Laugh

I didn't think it was complete crap but hey, I was starting to lose faith. Smile

Oh and the framelimiting option was not checked, says I have to do that to disable it, so I guess it's enabled.
Reply
#4
Default options will mostly have you covered. Some games are emulated much better than others. If your CPU is fine, up your graphics details.

In Config -> Video (GS) -> Plugin settings
Change (if you haven't already) your Renderer to Direct3D11 Hardware
Go to the "Or use scaling" and change it to 3x or 4x and click Texture Filtering.
Click OK

Try running your game like that if you haven't already. PCSX2 isn't about just reliving games for me, It's about playing true 1080p versions of them. Things really can look very good now thanks to PCSX2.
Reply
#5
Thanks Sky, I will try those settings, I have had Texture Filtering on all the time, but I also had allow 16 bits thing on or what it is, I unchecked that now.
Reply
#6
Now I've tried all the settings suggested, and it ends up the same way, either the sound glitches and goes way to fast on music and slows down in the fights, or I get the linear black lines on the screen. :/

I'm about to give up.
Reply
#7
Have you been changing the settings a lot?

Clear all settings back to default, then just start with the following:

GS plugin set to Direct3D11 (Hardware)
Internal resolution custom at 1024x1024
Speedhacks enabled in Emulation Settings

See how the game runs like that. If the FPS is low, try moving the EE Cyclerate or VU Cycle Stealing up little by little, and see if they're helping. You could also try setting the VU in Emulation Settings to superVU, or try the MTVU hack in SVN.
Reply
#8
Try to find a little older GSdx version. The one from the 0.9.8 release could be fine already.
Soul Calibour 2 and 3 got lots slower from a GSdx fix introduced not too long ago.
Reply
#9
I'll try your suggestion first Rezard, resetting the emu settings. And doing what you said, if that don't work I'll see if I can find an older GSdx version, I am using 0.9.8 already though so if that's fine i dunno. lol

Now running with your first suggestion Rezard, everything seems good in SC as far as the sound goes and such, some speed glitches during fights but nothing major, the only problem I have now is that the screen is like, idk how to explain it, blurry, like the letters and such are shaking. lol
Reply
#10
Try different Interlacing modes and see if one helps the blur/shaking.
You can change it in the Video (GS) Plugin Setting,
or cycle through them while playing with F5 to make seeing the differences easier. Smile
Reply




Users browsing this thread: 1 Guest(s)