Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Is my laptop good enough?
#1
Hi,is my laptop good enough to run PCSX2 ?

Intel Pentium B960 2.2 ghz ( dual core )
4 Gb ram ddr3
Nvidia geforce 610m 1 gb
Reply

Sponsored links

#2
which games do you own
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply
#3
I tried DBZ budokai tenkaichi 2.... it doesnt have incredible lag,but its not runing smooth either..i think its about 30-40 fps.Can i improve that?or my laptop isnt strong enough?
Reply
#4
Your notebook is really on the weaker side of the moon. You don't have - by luck - another pc around?

What version and settings do you use?
Reply
#5
With those specs, you won't be able to have many games running as playable unfortunately. I think Kingdom Hearts is really light on resources, if that's a game you're interested in playing.

Posting settings and your PCSX version may be able to help us to determine any speedhacks you can use to get an extra speed up though.
Reply
#6
you could try playing the budokai series, the Budokai tenkaichi series will be unplayable on that rig.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#7
http://gifmaker.cc/PlayGIFAnimation.php?...IYRGIb.gif
Reply
#8
The GIF makes it hard to take a look at one section continuously, care to post images of every single one of them. Tongue ( though, optimizing the settings won't make much difference)
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#9
You should better find a real PS2 than playing with this machine, it will be slow, you can still test it.
i5 2500k@4,9ghz / Gtx980 Msi Gaming / 2x SSD Samsung 840pro 256gb / Acer Predator 24" G-sync
Corsair K95 RGB / Logitech G502 Proteus Core / Bose Companion 2 Serie III
Old JRPG fan, experienced mmo player, PC hardware expert
Reply
#10
You might want to turn off manual game fixes unless necessary. Also, try turning off MTVU as you only have a dual-core cpu. Resolution should be kept at native in the gsdx settings, and any postprocessing effects should be off. Try playing with the EE/VU sliders. Turn on high performance mode and play plugged in.
Reply




Users browsing this thread: 1 Guest(s)