Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Issue with wxWidgets
#1
Hello all

Since I'm using 64bit architecture I'm copy the x86 libs into "3rdPartyLibs" folder, but on execute an error occurred;

Code:
./pcsx2: relocation error: ./pcsx2: symbol _ZTV20wxwxMenuItemListNode, version WXU_2.8 not defined in file libwx_gtk2u_core-2.8.so.0 with link time reference
Reply

Sponsored links

#2
Fedora? If yes see here: http://forums.pcsx2.net/Thread-PCSX2-for-Fedora
Reply
#3
(08-08-2012, 06:46 PM)gregory Wrote: Fedora? If yes see here: http://forums.pcsx2.net/Thread-PCSX2-for-Fedora

Nope
openSUSE x86_64
Reply
#4
Which version of wx do you have exactly. Mine is 2.8.12.1?
Reply
#5
2.8.12-6.1.2
Reply
#6
Be sure to use launch_pcsx2_linux.sh otherwise it won't pick 3rdPartyLibs libs!

Then, can you check that you don't miss any wx library.
1/ Set you LD_LIBRARY_PATH to 3rdPartyLibs
2/ Just do a ldd on pcsx2 and 3rdPartyLibs/* (you can grep found)

Can you try this command too:
Code:
readelf -W -s  3rdPartyLibs/libwx_gtk2u_core-2.8.so  | grep ZTV20wxwxMenuItemListNode
Reply
#7
I'm copy the following libs into 3rdPartyLibs
libbz2.so
libwx_baseu-2.8.so
libwx_gtk2u_adv-2.8.so
libwx_gtk2u_core-2.8.so
Reply
#8
I'm not sure you have all libraries. Anyway, maybe you can try to compile pcsx2 on your system but you need to install the 32bits dev packages for each dependency
Reply
#9
(08-09-2012, 06:45 PM)gregory Wrote: I'm not sure you have all libraries. Anyway, maybe you can try to compile pcsx2 on your system but you need to install the 32bits dev packages for each dependency
Many thanks for your reply. It fixed, I'm wrongly put the wxwidgets-stl instead of wxcontainer.
Reply




Users browsing this thread: 1 Guest(s)