Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Issues with framerate on FFXII
#1
Hi there I currently have a problem with the Final Fantasy XII where I would be running the game at a nice 60fps but for some odd reason the game would slow down to 30fps. It doesn't matter whether the map I'm currently on has alot of npc's in it or not the game would just slow down this also includes ingame cutscenes.
Also on a side note i can run FFX at 60fps no problem.

The current build of Pcsx2 im running is 0.9.8 r4600
My computer specs are:
Intel i5-460m
ATI Radeon HD 5650
4gb of ram

Are there any configurations I can make to increase my fps to around 45+?
Or is it just a problem with my laptop and I can't do anything about it
Reply

Sponsored links

#2
First set native res at gsdx plugin, Use speedhacks, If doesnt enough try with frameskip option.
Notebook ASUS A43TA|CPU AMD Llano APU A6-3400m Triple core (1 core disable) OC to 2.6+Ghz|GPU CF|HD 6520 400Mhz/667Mhz iGPU|HD6650M OC 780Mhz/985Mhz dGPU|RAM 8GB DDR3 1333|Windows 7 Ultimate Sp.1 x64 bit.
>> Emulation speed differs for each game. There will be some you can run fast easily, but others will simply require more powerfull hardware <<.
Reply
#3
First guess is because you're using a laptop... The very nature of them can sometimes be a hindrance for PCSX2 since it can get the processor overly hot, then the BIOS automatically underclocks the CPU for a set time till the temperatures cool back down.
[Image: 2748844.png]
Reply
#4
Thanks for the suggestions setting the emulator to run at native resolution seems to help abit but I it still seems to slow down.
Is there anyway to stop the Bio's from underclocking my CPU?
Reply
#5
How long has it been since the last time you clean your laptop heat sink? If it have been 6 months more, now is the time to rape your laptop again Tongue.

The machine automatically downclocks the CPU to avoid permanent damage due to heat issue. I'm afraid there is no way to stop it, but if there were, you would have a very high chance end up with a motherboard replacement.
Intel Core 2 Quad Q9400 | nVidia GeForce GTX 750 | 4 GiB DDR3 @ 533 Mhz | MSI G41M-P28 | Cooler Master RS-390-PMSR-A3 | Xigmatek TYR SD962 | LG Flatron W1943SE | HP KB-0316 | MotoSpeed F60
Reply
#6
Well isn't that a "mobile" CPU? Aren't they notoriously bad compared to desktop CPUs? Just saying in case people only glanced over his specs and thought it was a regular i5.
Reply
#7
I'm not really sure but the laptops been with me for 3 months now. Would a laptop cooler help?
Reply
#8
It would make a difference, but I don't know if it'd be an important difference. CPUs with an "m" in the name are, as far as I know, always "mobile" - that is, made for laptops in order to do lightweight office tasks. They're not really made for gaming or other heavy duty stuff. That said, if it's running it at 60fps sometimes and then slowing down, it does sound like overheating. You could try getting a program like SpeedFan. It will record your fan speed and CPU temperature. You can leave it running while you play FFXII and when the game slows down to 30fps, minimize it and check SpeedFan for temperature spikes (which will be recorded on a graph).
Reply
#9
Tropxe: Just because a CPU is marked mobile it doesn't necessarily mean much worse, in fact that's becoming less and less so. Instead of reducing the feature set (beyond maybe lowering the L3 cache which wouldn't effect PCSX2 much) they, instead, favor using lower clockrates/voltages.

Lee: You can try forcing windows to be in performance mode. Just type in "power-saving" and click "change power-saving settings" and set it from "energy saver" (which is the default for laptops) to "balance" or "performance" and see if that works better for you.
[Image: 2748844.png]
Reply
#10
and don't forget to put the laptop/notebook in the powersocket, cause your battery will be empty in no-time Tongue
Reply




Users browsing this thread: 1 Guest(s)