Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Justice League Heroes Runs in Hardware...!!! But not so well
#1
Hey there. Here's the thing: After a long wait, I could finally play Justice League Heroes in HD!! The game now runs properly with Directx11 hardware graphics. The game works a little slow, so I had to use the speed hacks. I'm using a Core2Quad Q6600 2.4 GHz, 4 GB RAM (3.5 usable, since my Windows 7 is 32 bit), Motherboard DP35DP, Graphics Card Nvidia N560GTX. The game runs great, except for this problem:

[Image: thump_9402186gsdx20150626220308.jpg]

wich shortly after it starts to self repair, like this:

[Image: thump_9402187gsdx20150626220309.jpg]

Here is my setup of the emulator:

[Image: thump_9402193vus.jpg]

[Image: thump_9402192video-ugin.jpg]

[Image: thump_9402191speedhacks.jpg]

[Image: thump_9402185gs.jpg]

[Image: thump_9402184gs-window.jpg]

[Image: thump_9402183eeiop.jpg]

and I'm not using any manual game fixes. By the way, I'm using the Super VU recompiler, because if I use the microVUrecompiler the screen goes black for a few tenths of seconds every now and then, and it's annoying. Also, I'm using both clamping modes at maximun, because the game doesn't work at all without them, at least in my computer.
I also took a few GSDumps, here (in the pictures that seem fine, they are not: in the upper left corner of the screen it can be seen a texture missing):

https://onedrive.live.com/redir?resid=4C...file%2crar

And this problem remains throughout the entire game. For example, at the interdimensional place, I ended up running mostly in the air, because the textures didn't load, or loaded after I ran through the place. A workaout solution I found was to press start when this happens, so I give the game time to properly load the textures. But this only works for the screen the camera is showing, I had to practically do it at every step. This doesn't happen always, but it does extremely often. The only thing I could think of was to disable both the EECyclerate and the VU Cycle Stealing. It worked, at least at the start screen of the beginning of the game (it's the first moment of the game, wich is shown all black in the previous photo) that didn't look black at all; but the game worked extremely slow. I don't think the problem is neither the resolution nor the texture filtering, since I have understood that this is done by the Graphics Card in DirectX11 Hardware mode. Also, I tried to apply the 4GB patch to this version of the emulator (1.3.1-581), but the exe shows the message that it couldn't open the executable, and then it closes. It makes a backup of the exe, though.
So,
1) Are the speedups the problem? I'm not sure because I only played the game without them for a little while. During that time, there weren't any textures missing. If not, what could be the problem?
2) If the speedups are the problem, is there some other way to make the game run faster? without them, the game runs at 20-30 fps.
3) I recently made a modification in the BIOS, the one that allows the VirtualBox to use more than one core in virtual machines. Could this be related?

For any doubts left, the emuLog is at the bottom of this post.


Attached Files
.txt   emuLog.txt (Size: 9,83 KB / Downloads: 104)
Reply

Sponsored links

#2
The reason your screen turns black because you've got mad with your speed hacks. Turn the vu slider down to 1 or nothing, turn mtvu off and turn the ee slider down then put microvu back on.

Don't tell me you've ticked every game fix too?

Oh and put all the clamping for ee and vu down to normal, you don't need higher, you might even get away with none
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#3
(06-27-2015, 04:00 AM)paraemuladores Wrote: 4 GB RAM (3.5 usable, since my Windows 7 is 32 bit), Motherboard DP35DP, Graphics Card Nvidia N560GTX. The game runs great, except for this problem:

Also, I tried to apply the 4GB patch to this version of the emulator (1.3.1-581), but the exe shows the message that it couldn't open the executable, and then it closes. It makes a backup of the exe, though.

Why would you want the 4GB patch applied to PCSX2? You can't even utilize 4GB.

Quote:1) Are the speedups the problem? I'm not sure because I only played the game without them for a little while. During that time, there weren't any textures missing. If not, what could be the problem?
2) If the speedups are the problem, is there some other way to make the game run faster? without them, the game runs at 20-30 fps.
3) I recently made a modification in the BIOS, the one that allows the VirtualBox to use more than one core in virtual machines. Could this be related?

For any doubts left, the emuLog is at the bottom of this post.

1. Yes. Like refraction said, tone them down.

2. Sorry, but you'd have to get a better computer. That CPU has an STP (Single Thread Performance) of 966. You need at least 1600 these days to run most games at full speed.

3. Doesn't matter. It only makes things better for VMs but other than that you won't notice any change on your system.
Intel Core i5-4670K @ 3.40GHz | 16GB (2x8GB) DDR3-1866 G.SKILL Sniper Series
AMD Radeon R9 280 @ 3 GB | 120GB SSD | Windows 7 Ultimate x64 (SP1)
Reply
#4
First of all, thanks! I can now play the game with the modifications refraction indicated, not at 50 fps, but at 45-50, wich is more than enough! Thanks a lot!
What I did was I put the EE/IOP Clamping mode in normal, and the VUs Clamping mode in Extra. If put less than extra, the screen suddenly starts to show random colors without sense, and although the music keeps playing, the sound eventually stops and the game remains like that and doesn't recover. But, still, just by lowering the EE/IOP Clamping to normal and the VUs Clamping to Extra (instead of Extra+Preserving sign) and with the EE Cyclerate in 2, the VU Cylcle Stealing in 1, and every other speedup turned on, the game now works great! No more textures unloaded!

(06-27-2015, 12:58 PM)Ryudo Wrote: Why would you want the 4GB patch applied to PCSX2? You can't even utilize 4GB.

I applied the 4GB patch because in earlier versions of the emulator, after a while of playing, it appears the known half screen problem, and in the PCSX2 program log window, it appears constantly the "out of memory" message. This was solved with the 4GB patch, because I red here in the forum that the patch still enhances the memory used by the emulator if you have 3.5GB, wich I believe is true, because that never ever happened again through the entire gameplay. So I'm a little scared that since I can't apply the patch in this version of the emulator, the half screen problem returns again after a while of playing. The latest version in wich I applied the patch was version 1.3.1-532. Will the problem return now that I can't apply the patch?

(06-27-2015, 12:58 PM)Ryudo Wrote: 3. Doesn't matter. It only makes things better for VMs but other than that you won't notice any change on your system.
Thanks for that answer. I was afraid that it could be hurting the performance of the emulator.
Reply
#5
why cant you apply the patch to this version? It should work on any version.
also you should be able to use the new version of GSDX on the old version of PCSX2 and the half screen problem will still be gone.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#6
Maybe there's a remnant process of pcsx2 running in the background?

Check it out and see if it's definitely not running in the taskmanager while you're trying to apply the patch.
Intel Core i5-4670K @ 3.40GHz | 16GB (2x8GB) DDR3-1866 G.SKILL Sniper Series
AMD Radeon R9 280 @ 3 GB | 120GB SSD | Windows 7 Ultimate x64 (SP1)
Reply
#7
Well, I could finally apply the 4GB patch... in Windows Safe Mode. It wasn't running on backgroud, I even tried to reboot the pc and apply the patch first thing of all, but it still didn't work in any version. However, I installed a lot of programs lately, heavy programs that install a lot of useless thing very integrated with Windows, and also updated my Avast from Free to Pro, so I suppose the avast or some other program is stopping the patch from working correctly. But it's okay, I don't mind, I'll only apply the patch once per version anyway.

Also, I also ended up playing with texture filtering at the middle option, and allowing the 8bit textures, and the game works amazingly smoothly, at least the small time I played it. The letters are the only real difference, other than that the game looks the same, and the letters are are still readable. So, I think I'll now be able to play the game properly. I'll start the game again from the start and I'll play it through the end, and then I'll see if everything runs okay. Thanks for everything, guys!!Happy

Edit: I also applied a lot of enhancements from the Nvidia panel, so that did the trick.
Reply
#8
Before i read all of your post (i got to the bit about doing it in safemode) I was going to say your antivirus is probably locking the file, then you said about avast, so I'm pretty confident now about that.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#9
(06-27-2015, 08:20 PM)refraction Wrote: Before i read all of your post (i got to the bit about doing it in safemode) I was going to say your antivirus is probably locking the file, then you said about avast, so I'm pretty confident now about that.

Yup. Also, for any user who can't apply the patch, this may help. Not even disabling the antivirus did the trick; the only way to do it was in windows Safe Mode.
Reply




Users browsing this thread: 1 Guest(s)