Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
KH2 - PAL at 60 FPS Sound can't catch up
#1
All right, I hope you guys can help me out.
I just started using the PCSX2 emulator a few days ago and I'm loving it so far.
Anyway the problem I have is that I find 50 fps a bit low on KH2 (my eyes are sensitive to low FPS and slowdowns and the like haha, not a good thing I guess).

So I went ahead and edited the ini file to let me play at 60 fps on the PAL version of KH2. I can immediately tell the difference. But the problem is that it runs too fast for the voices and some sounds to catch up. I was wondering if there was any way to maintain 60 fps while slowing down the actual game speed. For example, playing the game FEAR. There are these slow-mo sequences where you go into this matrix type thingy. The game goes into slow-mo but maintains 60 fps (at least on PC).

If you guys can help me out it would be really appreciated.
Also if it helps, I am using the 0.9.8 (r4600) build of PCSX2.
Reply

Sponsored links

#2
Console games arent expected to slow down or speed up as the devs know how its gonna run, so the frame skippy thing you get in PC games (like FEAR) isnt required in console games, so they don't put it in.

you can make the sound run faster, if you use SPU2-X and make sure you have time stretching on, it should be ok Smile
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#3
Some games are straight down conversions from 60 to 50 and suffer from it

KH2 does not, at all.
It is just as smooth at 50 as it is at 60. what could be occuring is forcing vsync is affecting the game just enough for you to notice input lag.

Then theres also that time stretching on KH games causes readily apparent audio lag of up to half a second off.

trying to sync the audio will almost always result at random clipping where the notes are stopped short, even with time stretching.
Reply
#4
(08-26-2011, 01:22 AM)Squall Leonhart Wrote: Some games are straight down conversions from 60 to 50 and suffer from it

KH2 does not, at all.
It is just as smooth at 50 as it is at 60. what could be occuring is forcing vsync is affecting the game just enough for you to notice input lag.

Then theres also that time stretching on KH games is readily apparent.

Both me and my friend can confirm that there is a difference. He was there when I switched it to 60 fps and both of us were like 'whoa dude, rainbows and *****' (I'm paraphrasing a little of course) but there is definitely a difference in those 10 frames per second.

Also, may I ask what is time stretching in terms of KH games?
Reply
#5
the stretching is on the sound as the sound in the game is designed to run with 50fps video, as youre speeding it up, the sound needs to be sped up to. Time stretching manages to do this without changing the pitch (which would normally happen).

It applies to all games, not just KH Tongue but itll stop it sound like the sound is jumping
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#6
Tongue2 time stretching is an spu2x audio synchronisation method. it helps prevent games from becoming out of sync during mainly cut scenes in games.

it has the unfortunate side affect of adding a fair bit of additional latency, though it has come down a fair amount in the last 50 revisions.

you'll notice it easily on the main menu where the selection sound should occur right on moving the menu cursor.
Reply
#7
(08-26-2011, 01:31 AM)refraction Wrote: the stretching is on the sound as the sound in the game is designed to run with 50fps video, as youre speeding it up, the sound needs to be sped up to. Time stretching manages to do this without changing the pitch (which would normally happen).

It applies to all games, not just KH Tongue but itll stop it sound like the sound is jumping

But is there any way to make it play at 60 fps, but slow it down so it plays like it was originally at 50 fps?

Also, in reply to your first reply, FEAR doesn't skip frames it just slows it down, that's what it looks like anyway. here's a video just skip through it a little bit as it has some unrelated crap at the start.

http://www.youtube.com/watch?v=35Gh6RZfa0g
Reply
#8
All right guys, I'm going to bed for the night, it's late here in Ireland. If any of you have any more suggestions, don't be afraid to post them.

Also thanks for the help you guys have already posted. I'll try to find a tutorial for the SPU2-X and mess around with that for a while tomorrow. Mean while please post any other suggestions you might have.
Reply
#9
I can't seem to find any tutorial on how to configure the SPU2-X plugin. There are 3 options:
Sequence length:
Seekwindow size:
Overlap:

At default settings on timestretch it doesn't catch up either. And a line of dialog starts a fraction of a second after the last and it sounds really weird.

Also is there any way to fix the weird DoF that is used during cutscenes? It seems to create two images really close to each other and it doesn't look nice at all.
Reply
#10
don't bother changing the timestretching settings, just reduce the latency slider as low as you can without it stuttering.
Reply




Users browsing this thread: 1 Guest(s)