Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
KH2 on PCSX2 is ridiculously slow!
#1
Hi. I downloaded PSCX2 because I really want to play Kingdom Hearts 2 on my PC. I have it for PS2 also, but I just think it'd be so cool to play it here. I figured I would have the correct specs since I have 6GB of ram, a pretty decent graphics card (I guess) among other things. I'll post my specs below!

Operating System
MS Windows 7 Home Premium 64-bit
CPU
AMD Athlon II X2 235 35 °C
Regor 45nm Technology
RAM
6.0GB Dual-Channel DDR2 @ 334MHz 5-5-5-15
Motherboard
eMachines MCP61PM-GM (CPU 1)
Graphics
CPD-2401 @ 1280x1024
256MB GeForce 6150SE nForce 430 (Acer Incorporated [ALI])
Hard Drives
732.57GB Seagate ST375052 8AS SCSI Disk Device (IDE)
Optical Drives
HL-DT-ST DVDRAM GH41N SCSI CdRom Device
Audio

I downloaded PCSX2 versions 0.9.7 and 0.9.6 and they're both super slow. I tried messing around with the speed settings but I'm not seeing any improvement. Is my computer just not fit for this emulator?

Thanks so much in advance!

Edit: By 'slow' I mean absolutely crawling. The sound is distorted and it's extremely laggy.
Reply

Sponsored links

#2
GeForce 6150SE is weak. Your processor isn't too bad, but definitely not what's holding you up. Make sure you use native resolution if you are gonna try.
Reply
#3
and I'd recommend trying in software mode with 4 threads. software will probably be better for you.
Reply
#4
(10-30-2010, 04:02 AM)Rezard Wrote: GeForce 6150SE is weak. Your processor isn't too bad, but definitely not what's holding you up. Make sure you use native resolution if you are gonna try.

Okay, I tried native resolution but it's still a no-go. The drag-y sort of lag is still there.

(10-30-2010, 04:09 AM)Saiki Wrote: and I'd recommend trying in software mode with 4 threads. software will probably be better for you.

Direct3D10 software, Direct3D9 software or Null software? I gave the first two a shot and still nothing...

I mean, the game starts up and everything but the sound is very "dragged" and lagging, and it's somewhat choppy and freezes. I can hear the computer itself struggling with the program because something is making it super heavy. x.x;
Reply
#5
ok, do this: in the GSdx dialog change the resolution to 384x384. tell me if it still crawls (yes, uncheck native)
Reply
#6
(10-30-2010, 04:27 AM)Saiki Wrote: ok, do this: in the GSdx dialog change the resolution to 384x384. tell me if it still crawls (yes, uncheck native)

It does, HOWEVER, I did notice something. After I changed it to 384x384 and I clicked "OK", I re-opened that same dialog box and it said 1024x1024 again. Could this be a problem, or is this normal of the program?

EDIT: I figured out why none of my settings would change. Hold on, I'm going to try what you guys recommended now.
Reply
#7
(10-30-2010, 04:32 AM)faburizu Wrote:
(10-30-2010, 04:27 AM)Saiki Wrote: ok, do this: in the GSdx dialog change the resolution to 384x384. tell me if it still crawls (yes, uncheck native)

It does, HOWEVER, I did notice something. After I changed it to 384x384 and I clicked "OK", I re-opened that same dialog box and it said 1024x1024 again. Could this be a problem, or is this normal of the program?

EDIT: I figured out why none of my settings would change. Hold on, I'm going to try what you guys recommended now.

1. When I changed the resolution to 384x384 and started the game, PCSX2 froze and had to be manually closed and restarted.

2. I changed it to native resolution and wow - it worked! It's running so much more smoothly now! The problem was that I had forgotten to remove the program itself from my Programs folder. It's now in my Documents and after changing it to Native resolution, it's perfect! Thanks so much. I won't be sleeping tonight! Too much gaming that needs to get done. <3

Reply
#8
odd.. it shouldn't have crashed *shrugs* I used to use that myself. but at least it's cooperating with you now
Reply
#9
It would crash in 0.9.6 but should work fine in 0.9.7, also software renderer with 2-3 "SW. threads" should probably work better... but anyways enjoy Tongue2
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#10
it worked fine in 0.9.6, that's what surprises me
Reply




Users browsing this thread: 1 Guest(s)