Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Katamari Damacy progress
#1
I've been playing around with my NTSC Katamari Damacy game and have successfully played it with only minor graphical glitches. I felt like comparing with other people who might have tried this on pcsx2 at some point.

I'm using the latest beta (r1888) and the march '10 plugins package. my pc setup is the following:

windows XP Pro SP3
Intel Core 2 Duo E6750 @ 2.66GHz
EVGA NVidia 8800GT 512mb
2gb DDR2 ram

I had to enable patches to skip the opening video, but once enabled it worked fine. using only the 1.5x EE speed hack I get a full 60 fps. Sadly, there are still some annoying graphical glitches with jagged 3d forms popping up onscreen. (curiously, the sequel, we love katamari, has 0 problems and no graphics glitches.)

I played with GSdx 2693 SSSE3 0.1.16's settings to see if I could fix the graphical problems, but no luck yet. Has anyone else found solutions or fixes?

here are some screenshots (1680x1050 16:10, these screens were taken at ps2's default d3d internal res, however.)

[Image: pcsx2r18882010042012323.th.png]
[Image: pcsx2r18882010042012280.th.png]
Reply

Sponsored links

#2
It still has some of these problems but they are very rare these days. Make sure under Config->CPU microVU0 and microVU1 are enabled
[Image: newsig.jpg]
Reply
#3
(04-20-2010, 07:59 PM)Bositman Wrote: It still has some of these problems but they are very rare these days. Make sure under Config->CPU microVU0 and microVU1 are enabled

aha, thank you! that fixed the random jagged polygons. some surface textures are still weird but it's playable.
Reply
#4
in the new gui + r3113, what settings need to be changed for this game?
Reply
#5
(04-20-2010, 08:06 PM)Capico Wrote:
(04-20-2010, 07:59 PM)Bositman Wrote: It still has some of these problems but they are very rare these days. Make sure under Config->CPU microVU0 and microVU1 are enabled

aha, thank you! that fixed the random jagged polygons. some surface textures are still weird but it's playable.

yeah i have the same graphical glitch with gsdx 890 (msvc 15.00 sse2) 0.1.14, under the cpu config it's enabled VU0rec and VU1rec.
any ideas?


edit1:
nevermind, i solved it

edit2:
ok. after 2 years of completing katamari damacy I forgot the gpu settings and was forced to re-learn all the stuff what pcsx2 had to offer.
hereby I write down the official list that I have learned for the future (me) to remember it if something goes wrong. Look at it as a future time capsule.

download pcsx2 1.0.0.
plugins used:
- gsdx 5334 (msvc 16.00, sse2) 0.1.16 [gsdx32-sse2-r5350]
settings in it (default)
- renderer: d3d9 (HW)
- interlacing = auto
- native reso.
- texture filtering = (greyed out)
- logar. z = check
- alpha corr. (FBA) = check
- pad:lilypad svn (r5282) 0.11.0 [lilypad-r5350]
- cdvd: cdvdgigaherz (r4488) 0.8.0 [cdvdgigaherz]

These are the most important things for the game (Katamari_Damacy_USA_PS2DVD-JEI) to run without glitches.

Attached 2 pics too.

PS: my current rig:
cpu: phenom 2 X4 965 3.4ghz
gpu: gb 7850 oc
ram: 8gb @ 1600mhz
os: win7 64bit

Thanks future Jim Wink


Attached Files Thumbnail(s)
       
Reply




Users browsing this thread: 1 Guest(s)