Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Keyboard at times stops responding
#1
Sometimes, when I'm mid game, no matter what the game, the keyboard will just ..stop working. I can literally button mash the directional keys for instance and the character might move a step if Im lucky, Im having to restart my emulator all the time and sometimes that doesnt even solve the problem. Oh also, I'm running PCSX2 1.0.0 because for whatever reason the newer versions dont want to download correctly, they always tell me Im missing a file. I am using the lilypad 0.11.0 currently for the pad input. the keyboard API is set to windows messaging ( i have tried the other settings as well and that didnt seem to change anything ) Can someone please help me, this is driving me absolutely bat ***** nuts. Thanks.
Reply

Sponsored links

#2
The new versions require new runtimes and directx. Get the installer version of 1.2.1 and make sure you install the VC 2013 runtime and the DirectX update.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#3
[quote='refraction' pid='382279' dateline='1403721521']
The new versions require new runtimes and directx. Get the installer version of 1.2.1 and make sure you install the VC 2013 runtime and the DirectX

I tried both the web installer and stand alone versions of 1.2.1 they wont work for me. When I try to ru it after install it tells me the program cant start because MSVCR120.dll is missing from my computer. I was getting it drectly from pcsx.net I did notice 1.0.0 has directx, mine is using direct3d11, and I think I have the run time as well, although not 100 percent on that as during installation there was the redit thing that just would not initialize the install even, it would just sit there.
Reply
#4
if it tells you that MSVCR120.dll is missing, then you aren't installing the VC 2013 runtime pack.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#5
(06-25-2014, 08:56 PM)refraction Wrote: if it tells you that MSVCR120.dll is missing, then you aren't installing the VC 2013 runtime pack.

Alright, ill definitely try again, but what happens if the VC 2013 runtime pack just doesnt initialize its install? Is it supposed to take forever, and I mean upwards of then minutes.
Reply
#6
run the setup as administrator, that should be fine, if that doesnt work, you may have to download it manually from here:

http://www.microsoft.com/en-gb/download/...x?id=40784

Make sure you get the x86 version.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#7
This specific issue where Lilypad stops accepting user input was fixed after PCSX2 1.0 and before 1.2.1. You could try just the latest Lylipad from latest pcsx2, but I doubt it'll work without the VC2013 runtime.

In the meantime, IIRC doing ALT-TAB to another window and then back to the "Game window" should fix it.
[i7-3630qm/gt650m-2G/Win-7] [i7-4500u/R.HD8850m/Win-8.1] [2010-MBA/OSX-10.9.x]. Scroll smoothly with SmoothWheel for Firefox.
Reply
#8
(06-25-2014, 09:01 PM)refraction Wrote: run the setup as administrator, that should be fine, if that doesnt work, you may have to download it manually from here:

http://www.microsoft.com/en-gb/download/...x?id=40784

Make sure you get the x86 version.

Well, unfortunately running as the administrator did absolutely nothing to change that, I downloaded it manually from your link and it seems to be the same situation it wont moved past initializing. Ive attached an image, is it by any chance because i already have something similar that it just wont install ?


Attached Files Thumbnail(s)
   
Reply
#9
Those are similar, but you need the 2013 x86 version to use the new versions of the emulator. If you cannot install them, it's probably the case for many programs on your computer. I would suggest running a too like Malwarebytes to see if you have anything malicious on there, then maybe go in to a command prompt and do "sfc /scannow" to fix any violations in windows.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#10
(06-25-2014, 09:24 PM)refraction Wrote: Those are similar, but you need the 2013 x86 version to use the new versions of the emulator. If you cannot install them, it's probably the case for many programs on your computer. I would suggest running a too like Malwarebytes to see if you have anything malicious on there, then maybe go in to a command prompt and do "sfc /scannow" to fix any violations in windows.

Well, I let the setup idle and it FINALLY worked itself out. Im going to try and install the emulator now and hopefully Ill be playng happily soon. Will I still be able to use my saved game data from before? If not that would epically suck.
Reply




Users browsing this thread: 1 Guest(s)