Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Kingdom Hearts 2 Lag
#1
Hello, so I'm trying to play Kingdom Hearts 2.
As you can probably tell by the thread title, it lags.
I mostly get 40-50 FPS, but at CPU intensive places (like fighting, etc.) It drops down to 30.

Here are my specs:
GPU: GT240
CPU: Pentium D 2.8ghz
RAM: 4gb
OS: Windows 7 Ultimate

Now, I understand that my CPU is weak, so what may be the best emulation/bios settings to make it run at its best? (note, changing the res does not help at all, I have the same FPS from 640x480, and 1280x1024.)
Reply

Sponsored links

#2
Your GPU were quite good, that's why you don't notice any difference when reduce/increase your resolution...

Try:

1. Enable speedhacks

2. Change EE/IOP and VU Clamp modes to "None"

3. Download latest PCSX2 SVN

http://pcsx2.net/download/development/svn.html
Reply
#3
or upgrade to a capable Core 2 Duo on the LGA775 socket
Reply
#4
Addition to Squall's post:

Also, find the ones that clocked 3GHz or higher so at least you can play most of games that compatible with PCSX2 (excluding high resource demanding ones)...
Reply
#5
E8400 bare minimum Laugh
Reply
#6
Thanks for the help, but my MB is pretty ancient, so it can only run that pentium.
And my case is built especially for that mobo, so I guess its time to buy a new pc.
Reply




Users browsing this thread: 1 Guest(s)