Thread Rating:
  • 1 Vote(s) - 1 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Kingdom Hearts 2 a bit slow
#1
Hey guys. I've tried PCSX2 a long while ago on a previous lesser laptop, and could never get anything to run smoothly. Now with a bit of a better laptop, I seem to be getting better. I really want to try to get Kingdom Hearts 2 working as smooth as possible.

Here's my laptop:

   
   

And here's my settings in PCSX2 including the plugins.
                           
       



I have tried many different combinations. Is there anything else I should try out? Any different plugins I should try? A different revision of v0.9.7? I can get Kingdom Hearts 2 running at about 30fps, but it seems the entire game is slowed down at about half the speed it should be moving at. The music and sound effects also aren't quite keeping up. I went through the guide and chose what seemed to be the most optimized choices, but I may have chosen wrong. I am also running it off of a disc, would turning it into an iso really help out? I will try that next. Other than that, any suggestions? Thanks guys.
Reply

Sponsored links

#2
the answer is the GPU. The quadro NVS 150m is a 9200 based integrated video card directed to the business segment, not good for games in general.

Changing the default values for NTSC and PAL hardly helps and possibly source of all kind of desynch and timing issues I can imagine.

you could try increasing the frame skipping and trying different gauges on VU and EE hacks. But it should not be expected full speed.

Yours is that case where running under software mode may be better, but even so this would be the case where a four core CPU clearly beats a 2 cores.

Imagination is where we are truly real
Reply
#3
Thanks, I got it to pretty much be playable, not full speed, but close enough. Rendered cutscenes seem to work out fine, but pre-rendered cutscenes, it seems the video is lagging a bit, and the audio kinda cuts and skips to sync with the video. Any idea on how to fix this? Can I set something so I can toggle a setting with a button, so I can change speeds just when I get to those cutscenes? Thanks
Reply
#4
If you set the Synchronizing mode in SPU2-X to "TimeStretch" it should keep in sync.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#5
max out the slider speedhacks
Reply
#6
Wouldn't;/ that break the game, I've been playing my Kingdom Hearts 2 with EE -1GS - 0.

Chances are you can't probably play it with that Laptop in Full speed, Since this beautiful emulator right here is very cpu intensive
Reply
#7
The GPU is the big problem here, I doubt you can fix this.
Reply
#8
(04-09-2011, 06:22 AM)Ashvanale Wrote: Wouldn't;/ that break the game, I've been playing my Kingdom Hearts 2 with EE -1GS - 0.

Chances are you can't probably play it with that Laptop in Full speed, Since this beautiful emulator right here is very cpu intensive

nah q6600 at 2.4ghz with maxed out speedhacks and i get >70fps
Reply
#9
Offtopic but yeah i guess i mean i'm using a Q8300 (Aside from some games that still has minor frame rate dips) i;ve been getting alot of games on the perfect side.
Reply
#10
Yeah, the CPU is fine for this game. It's the GPU that barely deserves the name "graphics accelerator".
The best chance to play this game still is with GSdx software rendering, which bypasses the thing Tongue2
Reply




Users browsing this thread: 1 Guest(s)