Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Kingdom Hearts 2 final mix fps problems
#1
So I just got Kingdom Hearts 2 final mix, and in the beginning in ran very slow so I turned down all the settings. The game now runs smoothly at 55-60 fps, but when it goes to a scene where I don't have to control the character, like a cutscene, it goes to about 75 fps and everything is way too fast. So I turned on vsync, but then the game runs at 40 fps when I'm playing so that doesn't work either. How can I fix this problem without having to turn vsync on and off everytime?
Reply

Sponsored links

#2
Turn frame limiter on under emulation settings... and turn vsync off, theres no need for it.
[Image: jmt41l-2.png]
SSD: 250GB | HDD: 2TB | GPU: MSI GTX 970 4G Gaming
Reply
#3
(04-16-2013, 01:53 PM)Kroepoek Wrote: So I just got Kingdom Hearts 2 final mix, and in the beginning in ran very slow so I turned down all the settings. The game now runs smoothly at 55-60 fps, but when it goes to a scene where I don't have to control the character, like a cutscene, it goes to about 75 fps and everything is way too fast. So I turned on vsync, but then the game runs at 40 fps when I'm playing so that doesn't work either. How can I fix this problem without having to turn vsync on and off everytime?

First, to get "actual help" instead wild guesses, tell us the machine's specs.

But since we can do wild guesses, one less wild is that the "framelimiter" is deactivated. So uncheck the little box and remove the vsync.

There are parts the emulation is faster in a same game and parts where the speed may fall bellow the standard.

So, depending on the CPU having more than 3 cores, enable MTVU. if still getting slowdowns try EE cyclerate and VU cycle stealing, don't abuse them, the least you use, the best. So is about finding the optimal compromise between the "need for speed" hacks vs machine power.
Imagination is where we are truly real
Reply
#4
I've got an Intel core Quad CPU with 2.5 GHz and my GPU is an ATI Radeon HD 5700, I think thats good enough to play this game, and I've already got MTVU, EE cyclerate and VU cycle stealing on. I'll try if its the problem with framelimiter.

It only says disable framelimiting which I haven't turned on. But underneath it says Base Framerate Adjust, Slow Motion Adjust and Turbo Adjust which I have to 1000%, Is that the problem?
Reply
#5
(04-16-2013, 02:18 PM)Kroepoek Wrote: I've got an Intel core Quad CPU with 2.5 GHz and my GPU is an ATI Radeon HD 5700, I think thats good enough to play this game, and I've already got MTVU, EE cyclerate and VU cycle stealing on. I'll try if its the problem with framelimiter.

The CPU architecture is old, so it's not the same as the same clock is on icore newer CPUs. That machine will struggle with most games and probably with Kingdom Hearts also, despite it is not among the most demanding.

5700 is telling about the series, a 5790 is much faster than a 5770 which is way faster than a 5750 which is already at the mainstream- side.

Edit: reinforcing that speedhacks will be sure necessity on this rig. the first attempt could be EE cycle rate at middle point (2) and VU cycle stealing at 2 also (even so may not be enough).
Imagination is where we are truly real
Reply
#6
(04-16-2013, 02:23 PM)nosisab Ken Keleh Wrote: The CPU architecture is old, so it's not the same as the same clock is on icore newer CPUs. That machine will struggle with most games and probably with Kingdom Hearts also, despite it is not among the most demanding.

5700 is telling about the series, a 5790 is much faster than a 5770 which is way faster than a 5750 which is already at the mainstream- side.

It only says disable framelimiting which I haven't turned on. But underneath it says Base Framerate Adjust, Slow Motion Adjust and Turbo Adjust which I have to 1000%, Is that the problem?
And in dxdiag it just says 5700 series, and by the way I'm able to play many new games with high settings on full fps, some examples are Far Cry 3 and Assassin's Creed 3
Reply
#7
(04-16-2013, 02:27 PM)Kroepoek Wrote: It only says disable framelimiting which I haven't turned on. But underneath it says Base Framerate Adjust, Slow Motion Adjust and Turbo Adjust which I have to 1000%, Is that the problem?
And in dxdiag it just says 5700 series, and by the way I'm able to play many new games with high settings on full fps, some examples are Far Cry 3 and Assassin's Creed 3

In case you dont know already, you could have a pc that can run all pc games out today at max settings and still get lag in ps2 emulation. Its not the same as running a natively pc game
[Image: jmt41l-2.png]
SSD: 250GB | HDD: 2TB | GPU: MSI GTX 970 4G Gaming
Reply
#8
(04-16-2013, 02:27 PM)Kroepoek Wrote: It only says disable framelimiting which I haven't turned on. But underneath it says Base Framerate Adjust, Slow Motion Adjust and Turbo Adjust which I have to 1000%, Is that the problem?
And in dxdiag it just says 5700 series, and by the way I'm able to play many new games with high settings on full fps, some examples are Far Cry 3 and Assassin's Creed 3

Surely, these settings on GS should not be touched without careful consideration, they aren't speedhacks at all. The first step is returning them to the nominal values. the frame limiter is active by default (meaning the box comes deactivated), yourself must have changed it at some point.

Increasing the turbo does not increase the FPS, it just tell the max it can go, if the machine is not getting to 120 FPS with it at 200% it will not get 120 FPS if putting it at 1000% as well.

But comparing with PC games is nonsense, the native game doesn't have to have it's code "translated" before being able to run on PC. So these games are demanding on video card mostly and not much on the CPU, almost completely the inverse of what happens in emulation.
Imagination is where we are truly real
Reply
#9
(04-16-2013, 02:38 PM)nosisab Ken Keleh Wrote: Surely, these settings on GS should not be touched without careful consideration, they aren't speedhacks at all. The first step is returning them to the nominal values. the frame limiter is active by default (meaning the box comes deactivated), yourself must have changed it at some point.

Increasing the turbo does not increase the FPS, it just tell the max it can go, if the machine is not getting to 120 FPS with it at 200% it will not get 120 FPS if putting it at 1000% as well.

But comparing with PC games is nonsense, the native game doesn't have to have it's code "translated" before being able to run on PC. So these games are demanding on video card mostly and not much on the CPU, almost completely the inverse of what happens in emulation.

Thanks, some guy on youtube had these settings and it got my fps to 60 in the first place. And I didn't know you couldn't compare PC games to PS2 games.
Reply
#10
(04-16-2013, 02:41 PM)Kroepoek Wrote: Thanks, some guy on youtube had these settings and it got my fps to 60 in the first place. And I didn't know you couldn't compare PC games to PS2 games.

You can compare, just the results make no sense due to the different nature of "comparands" Smile

There is Billyash (a user of this forum) making some wild but interesting experiences changing the references at ini level. Be advised the results may be wilder than the initial guesses but could be the only thing to help getting relative stable FPS... just be prepared to do a lot of compensations and it will probably be valid only for the current game... but may be worthy trying in this case.

Seek for him and try direct contact.
Imagination is where we are truly real
Reply




Users browsing this thread: 1 Guest(s)