Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Kingdom Hearts 2 frame rate boosting
This is a minor gripe. Kingdom Hearts 2 is playable, mostly dropping to 40 at the lowest during large scenes or big battles, but that's the thing: I want the frame rate to stay between 50 and 60. I'm using the 1888 beta of Pcsx 2 and the plugin pack. Now the fun part, config settings and system specs: Glare
Graphics: GSdx 2404 (MSVC 15.00, SSE2) 0.1.15
Resolution - 1280 x 800 60 Hz
Renderer - Direct3D 10 (Hardware)
Interlacing - None
Aspect Ratio - 16:9
D3D Enhancements - Native
Allow 8-bit textures - Checked (Everything else unchecked/grayed out settings)

SoundWackoPU2-X 1.2.0
Interpolation - Linear
All boxes are unchecked
Module - No sound/XAudio 2
Latency - 201 ms

First Controller:LilyPad svn (r 1853) 0.10.0
Does this really matter? I'm using a PS3 controller and everything is mapped the correct way. There are some minor response delays, any way I can fix this, or are there any other plugins that work? The SSRX Pad or whatever it's called (This is an edit and I don't feel like checking the specs again) doesn't work on the beta for some strange reason.

Cdvdrom:cdvdGigaherz (r2361) 0.8.0
Drive L: Don't think this matters, I own the game but I'm using an iso because I have 2 copies, one broken, the other one works but it's buried somewhere.

(Everything else is null)

BIOS: USA v01.60(7/02/2002) Console
The BIOS is one a friend gave to me, so I don't know if it's a copy of his PS2 BIOS or one downloaded off the internet.

All the configs with the exception of CPU and Speed Hacks are at default settings.

CPU Config:
EERec, VU0rec, VU1rec, and Multi threaded GS mode are all checked, micro VU0 and VU1 are unchecked.

Frame Limiting - Limit

Speed Hacks: Default Cyde Rate/x1.5 Cyde Rate. I swap between the two because I see no huge difference, though switching to one at a certain time seems to be faster than the other.

All other hacks have been tested with different combinations, and I still need to see if any combination will create a noticeable speed boost.

System Specs:
Operating System - Microsoft Windows 7 Home Premium (W7 is better than I thought it'd be. I have a few gripes but...)
Version - 6.1.7600 Build 7600
Other OS Description - Not Available
OS Manufacturer - Microsoft Corporation
System Manufacturer - HP-Pavilion
System Type - x64-based PC
Processor - AMD Athlon™ II X4 620 Processor, 2600 Mhz, 4 Core(s), 4 Logical Processor(s)
BIOS Version/Date - American Megatrends Inc. 5.18, 9/8/2009
SMBIOS Version - 2.5
Locale - United States
Installed Physical Memory (RAM) - 6.00 GB
Total Physical Memory 5.75 GB
Available Physical Memory - 3.88 GB
Total Virtual Memory - 11.5 GB
Available Virtual Memory - 9.17 GB
Page File Space - 5.75 GB

Graphics Card - NVIDIA GeForce 9100
Adapter RAM - 256.00 MB (268,435,456 bytes)
Resolution - 1920 x 1080 x 60 hertz
Bits/Pixel - 32

And that should be everything. I've played around with the options and the speed hacks, but so far there's no severe boost in my frame rate. I usually run the game by itself, no other applications to slow it down. I am ashamed to say I have a far above average knowledge of computers, but it involves very very little software or hardware knowledge. This is why I'm taking computer classes. Thank you for spending your time reading this bullsExclExclt, and I will be immensely grateful if you can help.

Sponsored links

Try disabling "Allow 8-bit textures", you have a weak graphics card so there's probably not much more you can do about it unless you upgrade I'm afraid. Try changing the clamp modes in "config > advanced" to 'none' but I doubt that will help much, maybe try the Frame Skipping feature in "config > cpu" options too.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
This was immensely helpful, thank you

Users browsing this thread: 1 Guest(s)