Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Kingdom Hearts 2, lag when monsters spawn
#1

My game(Kingdom Hearts 2) runs at about 57-60 fps, but until i enter a new map and monster's spawn, my fps starts to drop. How do i fix this? I think it has something to do with bloom or something. Also my fps drops during Tales of Abyss in battle and some parts of FFX and Megaman X7 please help me.

My specs are:
Operating System = Microsoft Windows 7 Ultimate Edition Service Pack 1 (build 7601), 64-bit
Physical RAM = 4095 MB
CPU name = AMD Athlon™ 64 X2 Dual Core Processor 6000+
Vendor/Model = AuthenticAMD (stepping 03)
CPU speed = 3.013 ghz (2 logical threads)
x86PType = Standard OEM
x86Flags = 178bfbff 00002001
x86EFlags = ebd3fbff

And im using pcsx2 .9.9 so here are my configs
GSDX 2190(MSVC 15.00, SSE2) 0.1.15 [GSDx-SSE2]
using Direct3D11 with 1440 x 900 D3D since its my screen res. and only texture filtering on and aspect ratio on stretch.

and my emulator settings are set on Balanced.
Reply

Sponsored links

#2
what is your video card?
Main Hub:i5-4670(3.4Ghz Factory Clocked),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
Reply
#3
I think it is ATI RADEON HD 4800 SERIES
Do you need anymore information?
Reply
#4
those specs is in average level i wonder why is slowing down try disable AMD's Cool and Quiet then report back.
Main Hub:i5-4670(3.4Ghz Factory Clocked),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
Reply
#5
How do i do that?
Reply
#6
enter CMOS(during start-up PC's bios hit DEL)
Main Hub:i5-4670(3.4Ghz Factory Clocked),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
Reply
#7
Okay let me try it out ( i picked disable for AMD K8 cool & quiet or something like that)
Didn't make a difference Sad, i even have power option on High performance for my computer. Is there any other way? I don't even know why my fps drops lol
Reply
#8
Your processor is a bit older (and therefor slower).
Maybe trying increasing the Speedhacks.
Changing the Emulation Settings to "Aggressive" or "Aggressive plus" will do that.

I think your GPU should handle that up-scaling, but have you tried native res just in case?

You could also see if the game runs any better on the most recent stable release of PCSX2 (0.9.8).
Reply
#9
The Agressive speed hack causes the fake fps thingy to happen. And if you mean native res in the graphic thingy, i tried it, it hasn't really done anything to the fps.
Oh but where can i download the stable pcsx2 0.9.8?
And it makes some of my games crash(the higher usage of hacks like aggressive)
Reply
#10
oh well i think it's time you switch your AMD to intel...
Main Hub:i5-4670(3.4Ghz Factory Clocked),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
Reply




Users browsing this thread: 1 Guest(s)