Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Kingdom Hearts 2 question
#1
Ok. So. Long time user, first time poster.
I originally got Pcsx2 to play Kingdom Hearts(Oh the nostalgia). Took me a lot of finagling, and searching these forums, but I finally got it working.
With default settings, it was total crap.
I got it to play PERFECTLY. constant 60 fps.
Played it, beat it.
Now, I'm looking forward to playing Kingdom Hearts 2.
I read virtually every thread on KH2, but most of them led me to assume that they simply didn't have a good enough machine to work it. I figured, hey, mine played KH1 didn't it?
Now, what I'm wondering is, is KH2 simply just more graphics intensive, and I've pushed my machine to the limit?
Or is there some Holy Grail of config combinations that I'm overlooking?
Below I list my PC specs, and current settings that work for KH1.

SPECS:
Intel Core 2 Duo CPU @ 2.20 GHz
2GB RAM
On-board graphics Sad
I know this is a pretty poor setup, but it managed KH1 perfectly.


CURRENT SETTINGS:
(Some of these things, like some speedhacks and the native res, are just on for safety and I could have played without them with not much hit on fps)
--------------------
GRAPHICS: GSdx9
Direct3D9 (software)
Pixel Shader 3.0
Native Internal res
Log z ON
Alpha Correction ON
(All others off)
--------------------
SOUND: SPU2-X
Interpolation: Nearest
Module: XAudio 2
Latency: 77ms
(All other options off)
--------------------
CPU CONFIG:
EERec ON
VU0rec ON
VU1rec ON
MTGS ON
Frame Limiting: VU Skip
--------------------
SPEEDHACKS:
EE Sync: x2
INTC sync hack: ON
IOP x2 Cycle rate ON
--------------------
ADVANCED:
default
--------------------

Currently, KH2 runs with about 45 fps, and flickers.

WHAT I HAVE FOUND IN MY EXPERIMENTS:
--------------------
GRAPHICS:
Hardware mode only runs slower.
Pixel Shader 2 makes no difference.
ZEROGS plugin runs faster than GSdx by about 15 frames, but only for KH2.
ZEROGS has nasty effect on screen colors, and brightens and fuzzys everything.
--------------------
SOUND:
Other plugins simply sound awful and don't affect speed.
--------------------
CPU:
In normal mode, it is significantly slower. In VU Skip mode, it runs slightly faster, but flickers. In Skip mode, it runs slightly faster, but flickers A LOT.
Skip and VUSkip only flicker in ZEROGS, not GSdx.
--------------------
SPEEDHACKS:
???
--------------------
ADVANCED:
???
--------------------

I currently have the latest official release, the latest public beta, and the latest svn build at my disposal.
I believe my answer lies somewhere in the speedhacks or graphics realm.
Or maybe even in the myriad of checkboxes in the ZEROGS plugin. (I don't understand those)
I have experimented with the awesome new VU cycle stealer, but I think it is what is causing the nasty flicker in Framerate Skip mode.

Basically, if someone could evaluate everything I've written and give me some feedback I'd be most grateful. I know it's a lot.
Have I done all I can do, and the only problem is in my crappy graphics card?
Is there a magical cure I have overlooked?
Are some of my configs conflicting and decreasing my framerate?

Thanks in advance.
And thanks for the AWESOME work!!!

Alex
Reply

Sponsored links

#2
yea your pc is pretty good for kh2, just set it to Normal and set almost all the speed hacks (setting it to normal solves all the flickering), and i'm able to run kh2 fullspeed on a Core 2 Duo @ 1.86GHz and it has a 256MB integrated graphics card Smile Tongue (that's lower speed than your pc Tongue)
Windows 7 64bit
Intel Pentium Dual-Core E5200 OC to 3.6GHz, Intel GMA x4500, 1GB DDR2

NinjaMight just work on next guideNinja
Reply
#3
With those settings you specified, I'm getting 15 fps.
=/
Reply
#4
set gsdx to Dx9(hardware) Smile
Windows 7 64bit
Intel Pentium Dual-Core E5200 OC to 3.6GHz, Intel GMA x4500, 1GB DDR2

NinjaMight just work on next guideNinja
Reply
#5
Okay. It seemed faster in the start menu, but in-game it was still 15-20 fps. I tried on both the official and recent build.
Thanks for your help, by the way. Most of the help I've gotten for KH1 was from reading your posts! =]
Reply
#6
set the "disable effects processing" checkbox in SPU2-x and by almost all speed hacks i mean also the VU Cycle Stealing and maybe the Idle Loop one Smile (i pretty much have EE Cycle Rate to Default, the WaitCycle uchecked and the VU Cycle Steal to MAX Smile)
Windows 7 64bit
Intel Pentium Dual-Core E5200 OC to 3.6GHz, Intel GMA x4500, 1GB DDR2

NinjaMight just work on next guideNinja
Reply
#7
Still no change. I'm confused as to what could so awful with my config if you're able to get 60 fps...
Reply
#8
what's the full spec of your graphics card? Smile
Windows 7 64bit
Intel Pentium Dual-Core E5200 OC to 3.6GHz, Intel GMA x4500, 1GB DDR2

NinjaMight just work on next guideNinja
Reply
#9
Mobile Intel 965 Express Chipset Family(on board)
384 MB
Reply
#10
hmm so it's a laptop (that's probably why), also the pc i use kh2 on has Windows 7 as the OS (that could be another reason) and it's a desktop, but pcsx2 doesn't work very well on laptops Mellow, but tell us what is your OS. Smile
Windows 7 64bit
Intel Pentium Dual-Core E5200 OC to 3.6GHz, Intel GMA x4500, 1GB DDR2

NinjaMight just work on next guideNinja
Reply




Users browsing this thread: 1 Guest(s)