Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Kingdom Hearts 2 - slow on decent rig?
#1
Hi,

I'm new to this forum and I've been dabbling in a bit of PS2 emulation for a little bit now. I've been reading around and realize that a decent dual-core will run this thing at good speeds on the most part.

I've been getting framerates in Kingdom Hearts 2 of around 30% to 50% in battles, but I'm perfectly fine in the opening credits (over 300%) and also around 100% to 150% in some non-fmv cutscenes.

I'm running this:
Intel Core 2 Q6600 @2.4Ghz
4GB OCZ
Nvidia 8800GT


Running R1888 with all the latest GsDx.
I'm not too sure which hacks to use for the game, but I did turn on MicroVU and Status Flag Hack, since I read somewhere that it'd help Could someone help me out? maybe supply a config that they have running.
Reply

Sponsored links

#2
You should be getting better speed for sure, can you show us your full settings? are you running the game from iso or disc?
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#3
Here they are. I'm running it off ISO.


Attached Files Thumbnail(s)
           
Reply
#4
Well you can enable some other speedhacks, "x2 cycle rate", "INTC Sync Hack", "Idle Loop Fast-Forward" and "VU Cycle Stealing" set to slight or moderate couldnt hurt really, and disabling "allow 8-bit textures" might help too.

You dont happen to have some power saving software/feature active or other programs on the background running? can you check with a program like CPU-Z if the speed of the CPU is normal when running PCSX2?
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#5
(10-27-2009, 01:28 AM)Shadow Lady Wrote: Well you can enable some other speedhacks, "x2 cycle rate", "INTC Sync Hack", "Idle Loop Fast-Forward" and "VU Cycle Stealing" set to slight or moderate couldnt hurt really, and disabling "allow 8-bit textures" might help too.

You dont happen to have some power saving software/feature active or other programs on the background running? can you check with a program like CPU-Z if the speed of the CPU is normal when running PCSX2?

Ok, so it looks like my CPU was running at 1.6 instead of 2.4, after a couple BIOS tweaks I've been running at 100% for a couple mins. I'm going to play it for a bit and see if the FPS drops at all. Thanks for the help.
Reply




Users browsing this thread: 1 Guest(s)