Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Kingdom Hearts | Freezing in Battles
#1
Hey guys. Im playing PSCX2 on Windows Vistia running via Bootcamp on my MacBook with DirectX 9.

Whenever I play Kingdom Hearts there is a steady FPS of 55 to 60. But whenever I get into battle, after a view swings of my keyblade on the heartless, the game image freezes and so do the sounds of the enemies attacking. But I can still hear the background music. The status box thing doesnt say anything about it. Speedhacks are disable along with Gamefixes. Any ideas?

Reply

Sponsored links

#2
Try that "OPH Flag hack" under Gamefixes...?
Reply
#3
Thanks dude. I think it might have been my gamesave. Now heres another problem, on destiny island, the wood looks completely brown and the sand is completely black. What can I do about these graphic glitches?


EDIT: Also, whenever my EE hits 0% my game hangs until it goes back up to at least 1%. It never seems to hit 100%. How can I prevent the 0%?
Reply
#4
If you're using savestates and you encounter errors/glitches, try from your last memory card save. That can cause a lot of issues.

Assuming you haven't changed any "Emulation Settings", maybe setting GSdx to native or use the software renderer.

What is your CPU and GPU, anyway?
Reply
#5
(01-30-2011, 05:04 AM)Rezard Wrote: If you're using savestates and you encounter errors/glitches, try from your last memory card save. That can cause a lot of issues.

Assuming you haven't changed any "Emulation Settings", maybe setting GSdx to native or use the software renderer.

What is your CPU and GPU, anyway?

I was running from the DVD before, now I'm running from the iso I ripped. I'm also only playing from mem card saves. I am playing on GSDX native and with Direct3D9 (Hardware).

My only problem now is during some cutscenes and some areas, the FPS can really get slow (around 40). And I'm still having some issues

Main Issue: Look at this video: http://www.youtube.com/watch?v=e6LIrtFAF34

For me, the ocean isnt textured, its just a blank blue. And all the wood you see, is just a blank brown.

Here are all of the specs of my computer.
http://www.apple.com/macbook/specs.html

Any plugins or different revisions of 0.9.7 that I should be using?


P.S. I'll keep checking back on this thread every 10min or so.
Reply
#6
Good idea with the ISO.

So, you have a Core 2 Duo 2.4Ghz and a GeForce 320M. As for plugins; the default should do fine, just be sure and use the GSdx plugin with the highest instruction set your C2D supports (SSSE3 or SSE4). You shouldn't necessarily ecpect the speed to always be perfect at 2.4Ghz, so some slowdowns are to be expected.

Now you GPU is another story. It is fairly decent, but suffers from a major setback; it shares it's memory. Also, being 256mb isn't helping, but being shared makes it slower. I'm guessing that video was done on a higher-end system, or at least a better GPU (using DX10/11).

BTW - Why are you only using DX9?

Reply
#7
(01-30-2011, 05:39 AM)Rezard Wrote: Good idea with the ISO.

So, you have a Core 2 Duo 2.4Ghz and a GeForce 320M. As for plugins; the default should do fine, just be sure and use the GSdx plugin with the highest instruction set your C2D supports (SSSE3 or SSE4). You shouldn't necessarily ecpect the speed to always be perfect at 2.4Ghz, so some slowdowns are to be expected.

Now you GPU is another story. It is fairly decent, but suffers from a major setback; it shares it's memory. Also, being 256mb isn't helping, but being shared makes it slower. I'm guessing that video was done on a higher-end system, or at least a better GPU (using DX10/11).

BTW - Why are you only using DX9?

Well I have DX10 install im pretty sure, but I'm not sure how I would use that with PCSX2. Is there anything I can do to make my GPU crap unshared? :\

What can I do about the graphics issue? I'm lookin for solutions here Sad
Thanks for your quick replies its a great help and really gives a strong first impression of the forums here.
Reply
#8
To use DX10, go under "Config" on the main PCSX2 window, into "Video (GS)", and then to "Plugin Settings". Change the renderer to "Direct3D 10 (Hardware)".

Unfortunately, you can't change your GPU. It simply has no built in memory of it's own, and will have to borrow from your system RAM. Just stick to native res, and get DX10 going with PCSX2. It can make a difference.
Reply
#9
(01-30-2011, 05:51 AM)Rezard Wrote: To use DX10, go under "Config" on the main PCSX2 window, into "Video (GS)", and then to "Plugin Settings". Change the renderer to "Direct3D 10 (Hardware)".

Unfortunately, you can't change your GPU. It simply has no built in memory of it's own, and will have to borrow from your system RAM. Just stick to native res, and get DX10 going with PCSX2. It can make a difference.

The option isnt there. Only the Direct3D 9 Hardware and the software one then the others but no Direct3D 10 options.
Reply
#10
Download DirectX here, and make sure you have the latest. You are using the latest PCSX2, right?

You can verify you DirectX version by opening the Start menu and typing "dxdiag" (without the quotes) and press Enter. Click the "Display" tab. You may see "DirectX 11", but trust me; you'll be limited to 10.
Reply




Users browsing this thread: 1 Guest(s)