Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Kingdom Hearts II FM speed problems
#1
Hi, I tried to use the Widescreen/60fps patch, but was having trouble configuring my settings for my game to function correctly.

With some settings, everything is perfect, but Roxas runs super fast. Others, he walks normal, but the in-game clock is running fast, as well as certain music(not all)

Most setting combos either involve things going fast or slow, but never all perfect.


Host Machine Init:
Operating System = Microsoft (build 9200), 64-bit
Physical RAM = 7374 MB
CPU name = AMD A8-6600K APU with Radeon™ HD Graphics
Vendor/Model = AuthenticAMD (stepping 01)
CPU speed = 3.900 ghz (4 logical threads)
x86PType = Standard OEM
x86Flags = 178bfbff 3e98320b
x86EFlags = 2fd3fbff

Patch file:
http://pastebin.com/CzDpkVUe

Settings:
http://imgur.com/a/eLflC

With these exact settings, game runs smooth most everywhere, but ingame clock runs fast. Normal cutscenes run fine, only background music can be fast sometimes. I just initiated one of the "Sora data flashbacks" and the video/captioning was running ahead, but the voices were normal.
Reply

Sponsored links

#2
You need a fast GPU for the 60fps hacks.

Make sure turbo is off and the framelimiter is on. (Tab and F4 I believe).
Reply
#3
I have a 7850 2GB, which should be pretty darn good. I am sure I can handle the 60fps. Is there a way to test if that is the cause?

http://www.newegg.com/Product/Product.as...6814127727

It is so weird. Certain audio cues will trigger faster, but most cutscene audio is fine. Is that because of the English patch being out of sync, or just how they are called by the game's engine?
Reply
#4
In the .pnach, remove the half game speed entirely.
Reply
#5
If I disable the half speed, change speedhacks back to lowest, and audio to timestrech, it now runs cutscenes at like 150% speed, and gameplay seems to be fast as well...

EDIT: Maybe I just had to reboot the emulator itself, not just the game. It now seems to run perfect with 60fps patch on, but everything else on default...(100% base framerate, default speedhacks/lowest values, etc)

While I'm here, is there a way to fix the subtitles being weird?
[Image: G8CzSCm.png]
Reply
#6
Speedhacks tend to mess with audio, so yeah, I always turn speedhacks off.

And as far as I know, those subtitles glitches are a result of the English patch.
One thing you can do is disable them in the .pnach.

However, I'm hoping that when 2.5 Remix is out, the translators will go back and correct the current English patch, fix the translations, and hopefully the font alignment as well.
Reply




Users browsing this thread: 1 Guest(s)