Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Kingdom Hearts, Specific Settings = Low Frames
#1
Hey guys,

Relatively new to pcsx2 emulator. Downloaded, ran, and began seriously using today. The sticky mentions a dislike of laptop processors, but I'm currently using specs:

Windows 7 64-bit
Intel Core i7-2630QM @ 2.00 GHz
nVidia GeForce GT 555M
6 GB Ram

Playing Kingdom Hearts 1 (fullscreened on my computer, and it's smooth 60 fps except for a couple spots). I get super bad frames around the waterfalls on destiny island, staring into the water, and when the shadows take Riku/Sora during the shadow swallowing destiny island. Oh yea, and the Kairi/door scene, but everyone seems to be having problems there. My knee-jerk is that there is a rendering problem somewhere, but the game runs super fine everywhere else. It gets slow in specific cutscenes. The opening with Utada Hikaru was seamless, but the sunset of Destiny islands majorly messes the game up (30ish frame drop), and Riku sounds like he's high.

Some cutscenes that DO work (full 60 fps, fullscreened): opening cinematic, first and second disney character scenes (donald and goofy launching gummi ship, and donald discovering mickey's letter). I think it's anything high particle demanding, for example the boss fight on destiny island where you re-fight the intro shadow monster crashed the game, but I think that's because AVG was running in the background. I haven't tried again since then.

I don't know how to continue from here, I tried running GSDX software with 3 extra render threads, like mentioned in a previous post, and still had frame drops near the waterfall (and generally making the computer stare out at water). Running on native resolution in gsdx hardware also throws it off.

(noobish question: best way to upload snapshots of system specs? I'm using snipping tool and loading the pics from there.)

I'd really appreciate any help, and I'm sorry if I missed uploading any specific specs, but let me know and I can include them.
   
   
   

EDIT: It's a Dell Alienware M14x, widescreen, that native runs 1600x900
Reply

Sponsored links

#2
Those specs seem low for your custom res. Try native or 720p.

AVG is a terrible antivirus, imo. I would disable all startup programs in msconfig.

Also, I'd update your Geforce drivers, just because.
Reply
#3
Thanks for the feedback!

I updated graphics (there was an update, oops). Tried running at previous settings, still dropped frames.

Switched to native, everything runs smoothly. I'm a tiny bit depressed, was hoping I could run the game prettier. Are there any ways to do that, or should I just deal?

EDIT: Everything was smooth, until I hit sunset with Riku/Kairi/Sora cutscene. Framerate still plummeted to around 30, but at least all the water/shadow particles were animating fine. I changed the resolution to 1280x720 and there were still dropped frames.
Reply
#4
If you haven't enable the MTVU speedhack it will help you out big time since you have a quad cpu
Reply




Users browsing this thread: 1 Guest(s)