Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Kingdom Hearts crashing after trying to start a new game
#1
I try to start a new game in kingdom hearts and it crashes as it would just leave the main menu.

Code:
/tmp/yaourt-tmp-root/aur-pcsx2/src/pcsx2-1.0.0-r5350-sources/common/src/Utilities/Linux/LnxHostSys.cpp(64) : assertion failed:
    Function:  void SysPageFaultSignalFilter(int, siginfo_t*, void*)
    Thread:    MTGS
    Condition: false
    Message:   Unhandled page fault @ 0x00000000

Stacktrace:
[00] 0x0xf6a823a0                                
[01] GSDeviceOGL::IASetVertexBuffer(void const*, unsigned int)
[02] GSDeviceOGL::StretchRect(GSTexture*, GSVector4 const&, GSTexture*, GSVector4 const&, unsigned int, GSBlendStateOGL*, bool)
[03] GSDeviceOGL::StretchRect(GSTexture*, GSVector4 const&, GSTexture*, GSVector4 const&, unsigned int, bool)
[04] GSDeviceOGL::DoMerge(GSTexture**, GSVector4*, GSTexture*, GSVector4*, bool, bool, GSVector4 const&)
[05] GSDevice::Merge(GSTexture**, GSVector4*, GSVector4*, GSVector2T<int> const&, bool, bool, GSVector4 const&)
[06] GSRenderer::Merge(int)                      
[07] GSRenderer::VSync(int)                      
[08] GSRendererSW::VSync(int)                    
[09] GSvsync

I ran pcsx2 from terminal and it output this begining to end.

Code:
pcsx2
Interface is initializing.  Entering Pcsx2App::OnInit!
Applying operating system default language...
SetLanguage: 'English (U.S.)' [] is not supported by the operating system
Command line parsing...
Command line parsed!
glX-Version 1.4 with Direct Rendering
Supported Opengl version: 3.3.0 NVIDIA 310.19
GL_ARB_shading_language_420pack is not supported
convert.glsl (entry vs_main, prog 2) :

convert.glsl (entry gs_main, prog 3) :

convert.glsl (entry ps_main0, prog 4) :

convert.glsl (entry ps_main1, prog 5) :

convert.glsl (entry ps_main2, prog 6) :

convert.glsl (entry ps_main3, prog 7) :

convert.glsl (entry ps_main4, prog 8) :

convert.glsl (entry ps_main5, prog 9) :

convert.glsl (entry ps_main6, prog 10) :

convert.glsl (entry ps_main7, prog 11) :

merge.glsl (entry ps_main0, prog 12) :

merge.glsl (entry ps_main1, prog 13) :

interlace.glsl (entry ps_main0, prog 14) :

interlace.glsl (entry ps_main1, prog 15) :

interlace.glsl (entry ps_main2, prog 16) :

interlace.glsl (entry ps_main3, prog 17) :

shadeboost.glsl (entry ps_main, prog 18) :
#define SB_SATURATION 50
#define SB_BRIGHTNESS 50
#define SB_CONTRAST 50

ALSA lib pcm_dsnoop.c:613:(snd_pcm_dsnoop_open) unable to open slave
ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
ALSA lib pcm_dmix.c:957:(snd_pcm_dmix_open) The dmix plugin supports only playback stream
ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
* SPU2-X: Enumerating PortAudio devices:
*** Device 0: 'HDA Intel PCH: ALC892 Digital (hw:0,1)' (ALSA)
*** Device 1: 'HDA NVidia: HDMI 0 (hw:1,7)' (ALSA)
*** Device 2: 'HDA NVidia: HDMI 0 (hw:1,8)' (ALSA)
*** Device 3: 'HDA NVidia: HDMI 0 (hw:1,9)' (ALSA)
*** Device 4: 'iec958' (ALSA)
*** Device 5: 'spdif' (ALSA)
LSA lib pcm.c:7339:(snd_pcm_recover) underrun occurred
ALSA lib pcm.c:7339:(snd_pcm_recover) underrun occurred
^CSA lib pcm.c:7339:(snd_pcm_recover) underrun occurred

I'm running arch linux and version 1.0 from the aur.

dunno if it's relevant but all of my backups and memory cards are running from a samba server in my house.

Sponsored links

#2
Upgrade to a newer version of pcsx2. it is already fixed
#3
On 1.0.0-5 from Arch Linux repos, when trying to start a new game, after selecting difficulty and vibration:

/build/src/pcsx2-1.0.0-r5350-sources/common/src/Utilities/Linux/LnxHostSys.cpp(64) : assertion failed:
Function: void SysPageFaultSignalFilter(int, siginfo_t*, void*)
Thread: MTGS
Condition: false
Message: Unhandled page fault @ 0x00000000

Stacktrace:
[00] 0x0xf6a5ffc9
[01] 0x0xf1b97e36
[02] GSDeviceOGL:LaughoMerge(GSTexture**, GSVector4*, GSTexture*, GSVector4*, bool, bool, GSVector4 const&)
[03] GSDevice::Merge(GSTexture**, GSVector4*, GSVector4*, GSVector2T<int> const&, bool, bool, GSVector4 const&)
[04] GSRenderer::Merge(int)
[05] GSRenderer::VSync(int)
[06] GSRendererSW::VSync(int)
[07] GSvsync


On the latest SVN, trying to do anything, even just starting the emulator with no disc in:

/home/alexis/builds/pcsx2-svn/src/pcsx2/common/src/Utilities/Linux/LnxHostSys.cpp(64) : assertion failed:
Function: void SysPageFaultSignalFilter(int, siginfo_t*, void*)
Thread: MTGS
Condition: false
Message: Unhandled page fault @ 0x00000028

Stacktrace:
#4
Working on latest SVN with zzogl, but colors are completely inaccurate during FMVs. :/
#5
First crash was fixed long ago. However the other crash isn't normal but I would need more data. First use a debug build (hopefully it would print the stacktrace). Then launch pcsx2 from a terminal and copy past the output.
#6
I am also getting the same error in the last version from AUR pcsx-svn

Code:
/tmp/yaourt-tmp-axelectrik/aur-pcsx2-svn/src/pcsx2/common/src/Utilities/Linux/LnxHostSys.cpp(64) : assertion failed:
    Function:  void SysPageFaultSignalFilter(int, siginfo_t*, void*)
    Thread:    MTGS
    Condition: false
    Message:   Unhandled page fault @ 0xd66ff03c

Stacktrace:
[00] void Build_Clut_Texture<unsigned int>(unsigned int, unsigned int, unsigned int*, unsigned char*, unsigned int*)
[01] CMemoryTargetMngr::GetMemoryTarget(tex0Info const&, int)
[02] SetTexVariablesInt(int, int, tex0Info const&, bool, FRAGMENTSHADER*, int)
[03] SetTexInt(int, FRAGMENTSHADER*, int)        
[04] Flush(int)                                  
[05] VB::FlushTexData()                          
[06] Flush(int)                                  
[07] void GIFRegHandlerTEX0<0u>(unsigned int const*)
[08] void _GSgifTransfer<3>(unsigned int const*, unsigned int)
[09] GSgifTransfer

JUst for the record I'm running
Arch Linux x86_64
Geforce GTX 660 (Nvidia Drivers)
Intel i5 3570k

The error happens randomly during gameplay and sometimes at the same point.
If this was fixed before, is there any patch or something?

BTW Also FMV are having strange colors..




Users browsing this thread: 1 Guest(s)