Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Kingdom Hearts in-game menu and sunset/sky slowdown.
#1
Hello everyone, I'm new around here and I'm using this emulator for the first time.

I'm playing Kingdom Hearts right now because a friend of mine really likes it and convinced me to try it out. I'm enjoying the game a lot but I'm having some slight problems with the emulator; nothing game breaking but annoying nonetheless. I've tested some stuff so I'll try to give as much details as possible.

First of all, my settings and my specs:
I'm using PCSX2 1.0.0 and running the game from an ISO.
[Image: EgooqdW.png]
[Image: v7Hf7lx.png]
[Image: qWrDefG.png]
[Image: Gz8YRXW.png]
(every other setting is default or irrelevant)

[Image: LL4pSHc.png]
[Image: H2jg1Ec.png]

I'm running the game with stable 60fps even in big battles with a lot of effects and without limiter can go up to 90-110 most of the time. Although, every time I open the in-game menu my framerate drops to ~45 and everything slows down. This also happens in some/most cutscenes (a good example is in Destiny Island during the sunset cutscene). I'm uploading a video of the issue right now but it might take a while: http://youtu.be/DBLRUdEy2nc

Now, I have found some half-solutions. The problem doesn't happen in native resolution (but that might be because, even though there's a framedrop, I doesn't drop beyond the 60fps limit) and it doesn't happen using the GSdx9 (MSVC 15.00, SSE2) 0.11.4 [GSdx9] plugin (even with my 1680x1050 resolution). Changing speedhack does nothing to this issue.

I feel like I'm hitting a wall here so I hope that this info is enough for some of you to figure out the problem... maybe it's something common and I just don't know. Thanks in advance.

PS: Just let me now if there's any option or info I forgot to share.
Reply

Sponsored links

#2
make sure your windows power plan is set to high performance, and maybe lower gsdx internal res.
unfortunately, the sunset cutscenes are quite GpU demanding and will probably slowdown even on high end machines.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
Use software mode for the laggy cutscenes.
Menu is like that because it runs at 60fps internally rather than 30fps like the rest of the game.

patch=1,EE,002B624C,extended,00000001

This will force 30fps in the menu. It will remove the vps lag, but the menu dropping from 60 to 30 will be noticeable.
i5-3570k @4.7 GHz
GTX 570
Asus Z77 SABERTOOTH
12GB G.Skill Ripjaws @ 1666
Cooler Master Storm Scout & Corsair TX 650w
Reply
#4
Hey jesalvein,
My power plan is set to high performance. Well, if I drop down my res it doesn't lag as much but since my main annoyance is the menus and since it doesn't happen using an older version of GSdx9 I think it isn't performance related (the EE, GS and VU percentages actually do drop down to half when i open the menu). Maybe there's a fix or option somewhere? Maybe related to the text or sprites in the menu? Or maybe the effect that happens in the background of the menu?

Hey Xendran2,
I'm sorry for being a noob but how do I apply that? Nevermind, found out how to do it. And it solved my problem in the menus! Thank you so much! Is this gonna affect the cutscenes aswell? Do the cutscenes run at 60fps aswell?
Reply
#5
That will only change the menus, as the menus are the only things in the game that run at 60fps.
i5-3570k @4.7 GHz
GTX 570
Asus Z77 SABERTOOTH
12GB G.Skill Ripjaws @ 1666
Cooler Master Storm Scout & Corsair TX 650w
Reply
#6
So, with the cutscenes is purely my hardware pulling me back?

And why do the videos also lag for me? Not a framedrop but a stutter.
Reply
#7
That sunset cutscene will lag even on a fairly beefy rig like mine. As for other cutscenes, yeah there's not much you can do but get better hardware.
I'm not sure what causes video stuttering.
i5-3570k @4.7 GHz
GTX 570
Asus Z77 SABERTOOTH
12GB G.Skill Ripjaws @ 1666
Cooler Master Storm Scout & Corsair TX 650w
Reply
#8
Set the EE Cyclerate to 1.
Specs: Intel Pentium P5 @ 60 Mhz, 1 Gigabyte HDD, OS: DOS
Reply
#9
ItsGreat@ Yeah, thanks! I think that solved the video problem.
Reply




Users browsing this thread: 1 Guest(s)