Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Kingdom Hearts slow down issue
#1
Hey everyone, I finally got KH running at a stable 60fps even during cutscenes by booting from an iso instead of a disk but now I seem to have run into a brand new problem. It seems that whenever my camera is facing a certain direction on destiny island(namely towards the tree house in this case) my fps suddenly drops down to something like 35-40 fps which can get pretty frustrating. I'm wondering if it is something I might need to mess around with plug-ins for or if it could be my specs(feeling like my cpu might be a little slow atm).

Here they are for reference: Intel Core i5 M 520 @~2.52GHz, ATI Mobility Radeon HD 5820, and 4.0GBs of RAM. Anyone got any ideas?
Reply

Sponsored links

#2
What is the EE% and the GS% at the top of the title bar saying?
Want to contribute? Don't know how? Check out the PCSX2 Wiki page!



Keep safe with MyWOT.

I have everything...
Reply
#3
Nice laptop. That CPU should be able to hit 2.66Ghz, though. Wink

What do ya got going on in your PCSX2 configuration? Any Speedhacks? Change the video settings?

Post some screen shots of your settings, please. Smile
Reply
#4
EE% is about 45-55 and GS% is around 3-20 normally.
When looking in the direction mentioned, EE% drops to around 36-42 and GS% range gets a little higher, ~ 8-21ish
Reply
#5
Are you running at higher than native resolution in your GSdx settings? If so, try checking "native" and see if you still lag.
Want to contribute? Don't know how? Check out the PCSX2 Wiki page!



Keep safe with MyWOT.

I have everything...
Reply
#6
(06-08-2011, 11:07 PM)Rezard Wrote: Nice laptop. That CPU should be able to hit 2.66Ghz, though. Wink

What do ya got going on in your PCSX2 configuration? Any Speedhacks? Change the video settings?

Post some screen shots of your settings, please. Smile

Ya I just overclocked it today with the 5% boost available in bios, might do some more to it later on if i get the time.

Not sure exactly what to post but ill put up what i think is important, let me know if you guys need anything else.

Turned off the speed hacks when the game started freezing after the 1st boss(should have been fixed) and got past it but on or off i still seem to have this same problem.
(06-08-2011, 11:10 PM)MyDreamName Wrote: Are you running at higher than native resolution in your GSdx settings? If so, try checking "native" and see if you still lag.

Nope native but can run X3 pretty smothly i think.


Attached Files Thumbnail(s)
                               
Reply
#7
Thank you for using native, and being sure you're not pushing your GPU. Smile

On your settings:

Perhaps disable the Enable fast CDVD and mVU Block Hack (they're not commonly recommended).
Alternatively, you could give the Presets a try.
Is Allow 8-bit textures actually helping you?

Also, the EE Cyclerate and VU Cycle Stealing sliders tend to make a big impact on speed. They are also quite capable of breaking games (case by case basis), but usually quite benefitial. Make sure you've tried them.
Reply
#8
Tried disabling Fast CDVD and mVU Block Hack with no luck. Same with toggling 8-bit textures on and off. On an interesting side note if I pause the game while in the fps drop the frames will return to normal in the pause menu until I resume again. I can walk around anywhere just fine as long as my view isn't facing the tree house. I'm still pretty new to the psx2 emulator and this is all a bit puzzling to me. It seems that if I keep the view on it, the farther I move away from it the worse my fps gets. Brought it down to 20fps by swimming out but right back to 60fps when i rotate the camera some.

Update: Just tried the EE Cyclerate and VU Cycle Stealing sliders, changed the fps from 20 to about 35 when maxing the VU slider. EE slider didn't really seem to have any effect, neither did turning on the rest of the speed hacks I had disabled along with them.
Reply
#9
This is pretty normal behavior with PCSX2. It wouldn't be too far off to assume that there is something in the way that the particular image/scene (i.e. the tree house) was done on the PS2 natively, but is not yet implemented (whether that be properly, or at all) with the emulator. The devs do deal with a lot of unknown factors. Wink

I did mention the 8-bit setting for one main reason: it is off by default.

Also, leaving those two hacks off may or may not help. The potential for them to break some particular thing will exist as you go along, so if it's not helping...

Have you tried the Presets yet? I do recommend you use Speedhacks to help with speed. Your CPU is decent, but it is technically slower for the cause.
Reply
#10
8bit should not be enabled unless it is required

in KH's case, it is not and will negatively affect performance.
Reply




Users browsing this thread: 1 Guest(s)