Thread Rating:
  • 1 Vote(s) - 1 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Kingdom hearts 2 problem
#1
I need some help.
When I play KH2 with PCSX2, everithing works fine until I reach the main menu and I select something. Then, the screen becomes black and, in some cases, the computer reboots automatically. This only happens when I select Direct3D 10/11 at the graphics plugin. With Direct3D 9 works perfectly but it´s slower.
The game is NTSC and I´ve tried with PCSX2 0.9.5 and 0.9.7 but I keep getting the same results.
Reply

Sponsored links

#2
maybe ur pc cant hold the pcsx2... whats ur pc specs btw
Reply
#3
Eeeh... I think they are:

OS: Windows 7 x32
Processor: Intel Mobile Core 2 Duo T6400, 2GHz
Ram: 2 Gb
GPU: Mobile Intel® 4 Series Express Chipset Family
Reply
#4
i could be wrong, but imho your notebook is too slow, especially the graphic chip sucks, intel graphic is kinda the worst you can have.

i don't think it will get much faster if you get dx10/11 to work.
Intel 486 DX33 33Mhz
8MB EDO Ram
S3 Graphics Trio64V+
Windows 95
Running MGS3 Snake Eater fully playable @ 0.05 fps
Reply
#5
yup he's right.. you can try buying a amd desktop and oc it
Reply
#6
Yeah trust me dude, I use that same chipset, you're lucky you can run it period. I run the original Kingdom Hearts and that runs better for me than 2. With speedhacks I gets 40-60 in good areas and 20-40 in hectic areas. It's slow and steady for me until I get those parts from newegg for my new desktop. Then it's party time, but for now, just tinker the settings. And direct X ten doesn't work with the chipset, the thing just can't take it, so stick with nine. If you scrim around the forums you can find suggestions for speed. These are just a few I dug up. In Emulation settings set clap to none and round to nearest whenever they appear.
Use native resolution, but sometimes 512x512 will work better for some people, I use native
Texture filtering should a square, but it's greyed out anyways if you're using native
Turn on all recommended speedhacks and tinker with the bars at the top until they start to slow your laptop

I think that's it, good luck and hope that helps
Reply
#7
Just upgrade your ram an extra 1 or 2 GBs. Win 7 uses mostly 1GB of ram while PCSX2 uses 2 GB ram or more to run a a game without giving any problems(depending on a lot of factors). My laptop runs an AMD Athlon x2 2.1GHz with 3 gigs of ram and I play Kingdom Hearts fine and dandy. But i think the problem could be your GPU and/or GPU memory. Intel Graphics are sometimes unable to work with PCSX2 or they lack video memory. I have an ATI RADEON 3100 with 256mb plus up to 1GB with combined with RAM. Use a program called GPU-Z to check what your Laptop's graphics hold, then post screenshots.
Toshiba Satellite Notebook L505D
Windows 7 32-Bit - 3GB RAM
AMD Athlon X2 QL-65 2.1GHz
ATI RADEON 3100 256MB Memory Size-1GB shared.
DirectX 9/10/11
Reply
#8
or get a Desktop PC like darkvirus says. But try to get one with a fair amount of ram, a good CPU, and one with Graphics like nVIDIA or ATI. DX11 Recommended
Toshiba Satellite Notebook L505D
Windows 7 32-Bit - 3GB RAM
AMD Athlon X2 QL-65 2.1GHz
ATI RADEON 3100 256MB Memory Size-1GB shared.
DirectX 9/10/11
Reply
#9
This is what GPU-Z says
http://img36.imageshack.us/i/lolisd.gif/

But it says DirectX support: 10.0
¿Doesn´t that mean it should work?
Reply
#10
hmm...your GPU specs seem fine, a little small in memory size but it looks good. Just in case, make sure your DirectX is updated. It could be the RAM, Have you had any blue screens of death when this happens(just checking)? Maybe the 2GB of ram is not enough, and is making the emulator overload the CPU with too much load making it restart.
Toshiba Satellite Notebook L505D
Windows 7 32-Bit - 3GB RAM
AMD Athlon X2 QL-65 2.1GHz
ATI RADEON 3100 256MB Memory Size-1GB shared.
DirectX 9/10/11
Reply




Users browsing this thread: 1 Guest(s)