Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Lag
#1
Hello,

I'm kinda new to this ps2 emulator stuff, but with the tutorial I set it up quite good I thought (although most stuff was good as it was on defaults).

Now I was about to play Scarface: the game. But I get lagged to around 15 fps when the actual game starts (instead of the limited 50 in the cutscenes).

I tried to change some settings, but I have no idea what it could be. Also the graphics look quite awkward, but I think that's just ps2 (I can't expect it to run like a PC game).

[Image: damnit_b7b4.png]

Any suggestions what I could change to avoid this? To keep a long story short: fps drops with 35 if the cutscenes ends and the "real" game begins.

Edit: here's a screen of the ***** up graphics:
[Image: damnit2_0d53.png]


Sponsored links

#2
whats the spec of your machine?
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
#3
Processor: intel i7 @ 2.7 Ghz
GPU: AMD radeon HD 6950 (no, I didnt really look at compatibility stuff)
Ram: 6 Gb

Also the log says it's attempting more memory (or something). Not sure if it's relevant, but I say it anyway.
#4
hmm not sure what it means.... Most of the above issues should be solved by putting GSDX in software mode, however as you have an i7, id suggest putting the rendering threads to 3, but speed may remain low.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
#5
Very nice. I put that to 3 and I put to software mode. Result is now the game runs at 23 fps and quite smooth. Also the graphics are normal now.

Is there any way to speed it up even more? Right now I use Directx 9 mode from the graphics plug-in, with 3 threads and software-mode.

Anyway thanks a lot already and I'll give you rep I guess.

Edit: I tweaked some settings and apparently it was the sound causing the lag. Timestretch made everything go fps drop, while Async Mix doesn't do that. Quite weird.
#6
how very odd!! wel im glad you've found your problem Laugh enjoy your game! (however the game might crash, so you're warned ;p)
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
#7
One more problem. The game runs smooth, but I noticed it gets slower by time. And when it reaches very slow I can see in the log it (successfully) attempts to resize the cache. It continues this way until it's 80mb and can resize anymore which results the game goes slower until it crashes/freezes.

Any suggestion? I know you helped me a lot, but this is yet another problem I concurred. I tried some different plug-ins, but I found that the default ones are simply the best (since the others make graphics/sound even more weird).

[Image: damniiiit_3168.png]
#8
hmm you could try changing to Super VU's in the options, other than that, there isnt much you can do Wacko not sure why the limit is 80mb however!
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
#9
That fixed the cache problem, so it runs smooth. But I do get some random freezes sometimes (no crashes). I want to use hardware mode for the graphics, but then I get green/purple tints. Is there anything what could fix that?
#10
You could enable the gsdx hacks and fiddle with the skipdraw setting, see if any of the options fix it.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!




Users browsing this thread: 1 Guest(s)