Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Laggy emulation on Fullscreen....
#1
Sometimes PCSX2 randomly starts lagging on fullscreen mode, only stops lagging when I exit fullscreen, and then reenter. This is kind of annoying because it happens rather often, and my cpu can handle much higher 250+ FPS when tab is pushed, or FPS is unlimited. This happens on all games tested.

I run a Core i7 860@4.12ghz , I have a single GTX 295 clocked @711.1566.1280 (much higher than stock), on Windows 7 Ultimate x64.

I am using the latest beta, r1888 with the latest plug-ins.

I dont have any Speed-Hacks enabled, I tried toggling many settings but none of them makes any difference, games just get laggy in fullscreen at random times.

I also want games looking as crisp as possible to take advantage of my more powerful hardware. I have set internal res at 2048.1536 (QXGA), and 8x AA using the ini, but it seems that the quality can be better. I tried enabling Anisotropic filtering and higher AA, using nHancer, but it did not work. How can I try to enable scaling 4x, and does it make a difference should I try it??
Reply

Sponsored links

#2
Quote:8x AA using the ini
Unfortunately, GSDX's MSAA is still pretty buggy and it produces hiccups here and there, which is why the function is not in the menu yet. Not sure if that might be the problem or not. Have you try turning MSAA off? Also, disable 8-bit texture if you have that ticked.

Anyhow, scaling is not completed yet. But...if you're feeling impatient, you can always compile the latest GSDX from Google codes. Just don't expect any support for it, because it is not publicly released yet.

FYI: Only one of your GPU is being used (or should I say half), because PCSX2 does not support SLI/CrossFireX.

By the way, what game is this and what are your PCSX2 configs?
Nappa: Vegeta! What does the scouter say about his power level?
Vegeta: It's...one thousand and six.
Nappa: Wh-...really?
Vegeta: Yeah! Beat him up Nappa!
Nappa: Yay!
Reply
#3
dr_thrax: SLI and crossfire are not intentionally supported... but both Nvidia and ATi have profiles that work on games not designed for multiple GPUs... that said some people have gotten it to work by forcing it in ATi, not sure anyone has for nvidia (or if they even have the option to force it in older games)


MSAA in rev 1888 has a memory leak. Even if you used only 2x it will eventually cause slowdowns like that. You'll have to wait till a new version is released or compile a newer version yourself, though it has it's own issues.
[Image: 2748844.png]
Reply
#4
Yep, as said here, msaa is a pretty bad idea currently. It has a memory leak, and also causes many small glitches.
As for the slowdown, that sounds like vsync messes up. Try disabling it.
Reply
#5
I know that Koji. As a matter of fact, there's a program that can force Crossfire in games. I think it was called Crossfire Xtension or something and people claimed that it works with more games than the crossfire profiles in ATI's drivers. Whether that's true or not, I wouldn't know.

Anyhow, I haven't heard of any third party program that forces SLI in unsupported games (mainly because Nvidia got that part covered, I think). So unless Nvidia made a SLI profile for PCSX2 (and I haven't heard about it), there's no way to force SLI in PCSX2.
Nappa: Vegeta! What does the scouter say about his power level?
Vegeta: It's...one thousand and six.
Nappa: Wh-...really?
Vegeta: Yeah! Beat him up Nappa!
Nappa: Yay!
Reply
#6
Thanks for the quick reply. I have noticed that turning on msaa to 8x causes a much greater slow down than it should, however, when frames are unlimited FPS is still higher than 60. Also I have tried to emulate using native resolution with no AA, and the problem still exists. I have tried this on Persona 4, Persona 3 FES, and FFX. I cannot understand why FPS is much higher than 60 when unlimited, then drops to 40s in fullscreen when limited at random times, speed is normal when I hit alt+enter again.

Also I read, that it is possible to use nhancer/nvidia CP to enable AA, does this still work because it has not worked with my attempts.

Thanks.
Reply
#7
Check your speed hacks? Certain ones (especially VU cycle steal and EE sync hack) can cause all sorts of fun with how fast or slow games are or cause false FPS reading.

Also, again, make sure you have Vsync turned off... Both in PCSX2's settings and in your driver controls. If either is on, you'll get controller lag and other unpleasantness.
[Image: 2748844.png]
Reply
#8
(11-18-2009, 03:49 PM)rama Wrote: As for the slowdown, that sounds like vsync messes up. Try disabling it.

Do that. Tongue2
Reply
#9
Thanks for more quick replies. I should have seen that but I totally missed it. After turning off V-sync, the issue is gone. However, there is now alot of vertical tearing, is there anyway to smooth this out without V-sync??

As for the antialaising, it looks a ton better with 8x, than with nothing but I see that it is definitely buggy. But as I keep saying I found a thread that had enabled it through nHancer/Nvidia CP, does this still work with latest revision cause it did not for me.
Reply
#10
You can use an app like D3DOverrider (comes with Rivatuner) and use it to force Triple Buffer, shouldnt cause more trouble when using Vsync that way.

The AA from nhancer only works with the D3D9 (Hardware) renderer as far as I remember.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply




Users browsing this thread: 1 Guest(s)