Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Language problem?
Hi there. Im new to Pcsx2, and jhave recently downloaded it.

Its all working, ater numerous trials I have finally gotten Final Fantasy X to work at a decent rate, but there is one problem.

I have the English version of FFX on CD, and I made it into an ISO file to use on the PC..however, when I open the game, it's all in French for some reason. I am unable to change the language in the game for some reason, and it's kinda annoying haha.

The language setting in the Pcsx2 lobby is in English, and my original game is in why is it in French?

If there is a simple answer to this problem, I am sorry for wasting peoples time, but a bit of steering in the right direction would be appreciated!


Sponsored links

Select the CDVDnull plugin and click Run->Execute. That will get you into the bios configuration where you can change the system's language
[Image: newsig.jpg]

Users browsing this thread: 1 Guest(s)